1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

I need Gigabyte HD5850 bios, please help

Discussion in 'AMD / ATI' started by incinerate, Jul 14, 2010.

  1. incinerate New Member

    Joined:
    Jul 14, 2010
    Messages:
    3 (0.00/day)
    Thanks Received:
    0
    I flashed my Gigabyte HD5850 with unlock bios of Asus HD5850, running 850/1200 no problem so far.
    I kept the original bios backup by GPUZ on a 3.5 years old Seagate sata drive. Yesterday the drive was not detected during boot, seems it's dead. I really need the original bios of Gigabyte HD5850 (GV-R585D5-1GD-B).
    If you have the same card, please save the bios and send to incinerate4@gmail.com or upload somewhere and give me the link.
    Thank you.
     
  2. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    15,309 (3.83/day)
    Thanks Received:
    12,473
  3. DanishDevil

    DanishDevil

    Joined:
    Oct 6, 2005
    Messages:
    10,231 (2.94/day)
    Thanks Received:
    2,139
    Location:
    Newport Beach, CA
  4. DanishDevil

    DanishDevil

    Joined:
    Oct 6, 2005
    Messages:
    10,231 (2.94/day)
    Thanks Received:
    2,139
    Location:
    Newport Beach, CA
  5. incinerate New Member

    Joined:
    Jul 14, 2010
    Messages:
    3 (0.00/day)
    Thanks Received:
    0
    Thank you very much for your fast response, but I couldn't find bios with matching frequencies, my HD5850 was 725/1000 before flashed.
    765/1000 bios is from Gigabyte HD5850 OC, is that 400/900 same as 725/1000 ?
     
  6. DanishDevil

    DanishDevil

    Joined:
    Oct 6, 2005
    Messages:
    10,231 (2.94/day)
    Thanks Received:
    2,139
    Location:
    Newport Beach, CA
    Those sound like 2D clocks. You can always download the files and check them out via RadeonBiosEditor, or RBE.
     
    incinerate says thanks.
  7. incinerate New Member

    Joined:
    Jul 14, 2010
    Messages:
    3 (0.00/day)
    Thanks Received:
    0
    I checked the 400/900 one, RBE showed 725/1000.
    Thank you very much for your help.
     
  8. DanishDevil

    DanishDevil

    Joined:
    Oct 6, 2005
    Messages:
    10,231 (2.94/day)
    Thanks Received:
    2,139
    Location:
    Newport Beach, CA
    No problem. Glad you found what you needed, and sorry to hear about your backup drive.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page