1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

InstallShield Wizard Required installation file is missing (7z.exe) HELP

Discussion in 'General Software' started by puma99dk|, Feb 13, 2012.

  1. puma99dk|

    puma99dk|

    Joined:
    Aug 29, 2005
    Messages:
    3,444 (1.03/day)
    Thanks Received:
    775
    i by an accident choose "System Restore" instead of making a "Restore point" and after my Windows 7 Ultimate SP1 x86 booted up everytime i run a installed that uses "InstallShield" i get this message:

    [​IMG]


    if anyone got a fix i would be very happy bcs, i don't have the mental energy these days to do alot and i got tired of my old Windows having to many errors lately so plz help me here, reinstalling will just exhaust me even more mentally than i am at the moment.
     

    Attached Files:

  2. brandonwh64

    brandonwh64 Addicted to Bacon and StarCrunches!!!

    Joined:
    Sep 6, 2009
    Messages:
    18,680 (9.96/day)
    Thanks Received:
    6,154
    Location:
    Chatsworth, GA
    try running CCLEANER
     
    Crunching for Team TPU
  3. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,808 (13.18/day)
    Thanks Received:
    14,190
    Reinstall 7zip?
     
    95Viper says thanks.
  4. puma99dk|

    puma99dk|

    Joined:
    Aug 29, 2005
    Messages:
    3,444 (1.03/day)
    Thanks Received:
    775
    erocker i don't even have 7z installed and if i do the same error still appears.

    brandonwh64 i do have CCleaner but what should i click on off?
     
  5. brandonwh64

    brandonwh64 Addicted to Bacon and StarCrunches!!!

    Joined:
    Sep 6, 2009
    Messages:
    18,680 (9.96/day)
    Thanks Received:
    6,154
    Location:
    Chatsworth, GA
    Just run the scan and clean system files and dead registry links.
     
    Crunching for Team TPU
  6. puma99dk|

    puma99dk|

    Joined:
    Aug 29, 2005
    Messages:
    3,444 (1.03/day)
    Thanks Received:
    775
  7. 95Viper

    95Viper

    Joined:
    Oct 12, 2008
    Messages:
    4,419 (2.00/day)
    Thanks Received:
    1,616
    Location:
    στο άλφα έως ωμέγα
    Odd you don't have 7zip on the machine, since it thinks it did.:ohwell:

    Looks like your registry entries may have gotten hosed for the Windows installer (that would be 5.0 version, if using windows 7).
    Windows installer can be downloaded for versions up to 4.5.
    Version 5.0+ is included on your install disks or the windows 7 sdk.

    About Windows Installer
    Windows Installer Redistributables

    Try this:

    Diagnose and fix program installing and uninstalling problems automatically

    or, this:

    How to troubleshoot problems when you install or uninstall programs on a Windows-based computer
     
  8. puma99dk|

    puma99dk|

    Joined:
    Aug 29, 2005
    Messages:
    3,444 (1.03/day)
    Thanks Received:
    775
    i have tired the Microsoft FixIt program it doesn't fix anything, and installing 7z doesn't do anything the setup still gives me the 7z.exe error :(
     
  9. 95Viper

    95Viper

    Joined:
    Oct 12, 2008
    Messages:
    4,419 (2.00/day)
    Thanks Received:
    1,616
    Location:
    στο άλφα έως ωμέγα
    Try, either,

    1. recover from the backup you made... you did backup your system, didn't you.

    2. restoring to the previous restore point, before the one that hosed up the system

    3. installing the the install .msi from the sdk or your windows 7 disk

    4. last resort... re-install your OS

    :ohwell:
     
  10. OnePostWonder

    Joined:
    Dec 27, 2008
    Messages:
    582 (0.27/day)
    Thanks Received:
    107
    I ran a registry cleaner once that completely fudged my Windows Installer. After trying everything I could think of (and everything I could find online), the only fix I found was to reinstall the OS. Attempting to reinstall the Windows Installer did little, if anything, to help.

    You're situation is a little different, so hopefully you'll find something before you reach the point of having to reinstall the OS.
     
  11. puma99dk|

    puma99dk|

    Joined:
    Aug 29, 2005
    Messages:
    3,444 (1.03/day)
    Thanks Received:
    775
    well i got the problem solved, i simple went to C:\Program Files\ and find the folder called InstallShield Installation Information and renamed it to InstallShield Installation Information.old and than run the PowerDVD12 installation again and it just installed it no errors no nuth just installed it, so i just saved myself a reinstall ^^
     
  12. OnePostWonder

    Joined:
    Dec 27, 2008
    Messages:
    582 (0.27/day)
    Thanks Received:
    107
    Nice job! Glad you saved yourself the reinstall.
     
  13. puma99dk|

    puma99dk|

    Joined:
    Aug 29, 2005
    Messages:
    3,444 (1.03/day)
    Thanks Received:
    775
    indeed and i am a little happier for that ^^
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page