1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Missing Sound of Impact?

Discussion in 'Games' started by HiddenStupid, Dec 14, 2007.

  1. HiddenStupid New Member

    Joined:
    Jul 17, 2007
    Messages:
    741 (0.28/day)
    Thanks Received:
    8
    is it jus me or what? theres no sound of impact in ever quest 2? like when hitting the mob it dont have sound... only sound of swinging weapon like woosh and woot... and ahhh and haaaa... but no sound of impact! its like you hitting the air/wind! im talking about when you attack the mob with normal default attack.

    its playable in very high setting for me but a bit jerky.... I stick on high setting most the time but still look awesome! i play in soga mode. i cant play in extreme setting... too choppy. btw does anyone experience the same in eq2? theres no sound of impact... like there no sound of hitting the mob but only sound of swinging weapon like woosh and woot and ahhh and haa but no sound of hitting.... well sometimes you hear but rarely. its like you hitting the air/wind. im in usa and it should not be connection lagg. also the hp bar is delay as well. is it just me?

    showing off.... these are a mix of high setting and very high setting mode.

    - athlon64 3200+ winchester
    - 1.5gig ram
    - X850XT


    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page