1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

MSI R6950 flashing bios problem

Discussion in 'AMD / ATI' started by Cinders, Mar 21, 2013.

  1. Cinders New Member

    Joined:
    Mar 21, 2013
    Messages:
    4 (0.01/day)
    Thanks Received:
    1
    Hi all, hope someone can give me advice here

    Problem:
    MSI R6950 2PM2D2GD5
    I cannot successfully flash a working bios into position 1 (afaik position 2 is the protected one, or at least that's the way I've been doing it).
    On my prior mobo, I had it flashed to a 6970 reference bios, and while it gave me troubles with checksums, I got it to boot and work.

    I've rebuilt with an M5A99FX PRO mobo, and it won't POST (gives a red light POST error on card). Going to position 2 (original bios), it posts fine.

    So after trying ATIFlash, WinFlash, RBE, etc. it gives me SSID and adapter checksum errors. I used forced flash (both in dos and in winflash), which will not post.

    Ok, so I tried to flash the original BIOS into position 1 (modded position), but it gives me checksum errors (SSID and adapter). I cannot even flash the original BIOS into position 1, nor any other BIOS that I've tried, including modded ones and other copies of original BIOS.

    Just to clarify: I'm fine in position 2. Not touching that one as far as modding, since it's the only one that boots.

    So the new issue comes from the new MOBO that won't POST past this. I'm not sure if it's not liking the checksum or what and just stopping dead.

    Also, when I force flash it and check it in WinFlash and RBE, it does report the forced BIOS is indeed there, but just won't boot up under that BIOS. It's verified flashed.

    I'd appreciate any advice. My google-fu is strong and I've looked up the most common fixes. I'm not sure what's going on here.
    Last edited: Mar 21, 2013
  2. Law-II

    Law-II

    Joined:
    May 9, 2011
    Messages:
    1,527 (1.30/day)
    Thanks Received:
    619
    Location:
    Mainland Britain
    Hi

    Welcome to TPU

    look up this issue: Asus bios and unlocked cards

    other members of the tpu community may be able to assit further

    EDIT from search bar on TPU front page - first hit here - http://www.techpowerup.com/forums/showthread.php?t=166708 this is not much but is a start

    Q. What is the exact model number of the vga card? [need to know as the original bios is required]

    - it may be possible for an image to be lifted from the position 2
    - Use GPU-Z example: & save to File make two copies of this and keep safe
    Extract vga bios.jpg


    atb (all the best)

    Law-II
    Last edited: Mar 22, 2013
  3. Cinders New Member

    Joined:
    Mar 21, 2013
    Messages:
    4 (0.01/day)
    Thanks Received:
    1
    Will do, thanks for the current info. I did pull the original BIOS from position 2, but it gives checksum errors when trying to flash, and when I force flash it, I get no POST.

    I'll get the images up
    Law-II says thanks.
  4. Cinders New Member

    Joined:
    Mar 21, 2013
    Messages:
    4 (0.01/day)
    Thanks Received:
    1
    It's a MSI R6950-2PM2D2GD D5 (912-V803-669)

    [​IMG]

    [​IMG]


    The working ROM, that came with the card and seems to be original is:
    2D - 250,150,0.9 3D - 725, 1250, ---.rom

    And I saved it via GPU-Z (thanks)
  5. Cinders New Member

    Joined:
    Mar 21, 2013
    Messages:
    4 (0.01/day)
    Thanks Received:
    1
    *FIXED!!!*

    Thanks so much! The problem *was* that ASUS has blocked the 6970 BIOS on the 6950 card. I followed that link you provided and found the solution. Simply load up the 6970 BIOS in WinFlash/RBE, change 6970 to 6950, save, flash, reboot. Reload drivers. Bam! Fixed.

    Again, I really appreciate your time and attention here.
  6. Law-II

    Law-II

    Joined:
    May 9, 2011
    Messages:
    1,527 (1.30/day)
    Thanks Received:
    619
    Location:
    Mainland Britain
    Hi

    Great news:toast: thank you for the feedback

    atb

    Law-II
  7. jmcslob

    Joined:
    Mar 14, 2009
    Messages:
    2,886 (1.47/day)
    Thanks Received:
    451
    Location:
    Internet Heaven
    Law-II says thanks.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page