1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Need some help with 9600 Gt display drivers...

Discussion in 'General Software' started by Cja123, Jul 24, 2009.

  1. Cja123

    Joined:
    Aug 26, 2008
    Messages:
    634 (0.27/day)
    Thanks Received:
    39
    Location:
    Fresno, CA
    Hey peeps,

    While playing Oblivion, I would encounter crashes quite often. I assumed that this was because my display drivers were out of date. I am still operating off of the drivers that came on a CD with the card. After installing the updated driver 190.38 WHQL for windows vista 64 bit, I could not get rivatuner to allow me to overclock the card. In fact there is no overclocking settings even available. The second driver area where you can click the card icon and bring up the overclocking settings is not there. It just says, "The display drivers not detected" at the top of the empty box. Since I couldn't get rivatuner to work I downloaded ntune. After downloading that I clicked the shortcut and I got a BSOD. When my computer restarted, I noticed that the "ntune" and "ntune monitoring" shortcuts were both just white paper icons that could not be double clicked (meaning I couldn't start them up). I deleted them seeing as they were useless and then right clicked on the desktop and went into nvidia control panel. There I saw a new tab labeled performance, ntune must have added this feature. I clicked on the tab and said yes to the user license agreement and BAM, BSOD. I'm guessing that I am having fat driver compatibility issues. I'm sure I have to clean the drivers and start over anew.

    My questions are;
    1. What's the process involved in removing display drivers from your computer? (I have never done it before).
    2. What drivers should I install? Since apparently the ones I chose weren't correct.
    Oh shit didn't even mention what kind of card I have, it's a MSI 9600 GT.

    :toast:
     
  2. newtekie1

    newtekie1 Semi-Retired Folder

    Joined:
    Nov 22, 2005
    Messages:
    20,230 (6.10/day)
    Thanks Received:
    6,271
    1.) Uninstall the drivers from control panel. Then, run DriverSweeper in safe mode to get rid of anything left over.

    2.)Re-install the 190.38 driver(yes, these are the correct drivers.)

    DO NOT install ntune, it is a POS program that cause more compatibility and hardware problems than anything else. Use Rivatuner.

    See the second post in this thread explaining how to get Rivatuner to work with the latest drivers.
     
    Crunching for Team TPU 50 Million points folded for TPU
  3. Cja123

    Joined:
    Aug 26, 2008
    Messages:
    634 (0.27/day)
    Thanks Received:
    39
    Location:
    Fresno, CA
    I have had it for quiet awhile, months. It doesn't BSOD during Oblivion. It did when I tried to use ntune to overclock it since rivatuner was not picking up the forceware drivers.
     
    Darren says thanks.
  4. Cja123

    Joined:
    Aug 26, 2008
    Messages:
    634 (0.27/day)
    Thanks Received:
    39
    Location:
    Fresno, CA
    This is what rivatuner looks like after uninstalling drivers and then reinstalling. Still no overclocking options.
    [​IMG]
     
  5. Darren

    Darren New Member

    Joined:
    Feb 27, 2005
    Messages:
    1,936 (0.54/day)
    Thanks Received:
    345
    The only thing I can suggest is to stop using Riva tuner, use NiBitor to edit the video card's bios and then use Nvflash to flash the card permanent.
     
  6. newtekie1

    newtekie1 Semi-Retired Folder

    Joined:
    Nov 22, 2005
    Messages:
    20,230 (6.10/day)
    Thanks Received:
    6,271
    Again...
     
    Crunching for Team TPU 50 Million points folded for TPU
  7. Cja123

    Joined:
    Aug 26, 2008
    Messages:
    634 (0.27/day)
    Thanks Received:
    39
    Location:
    Fresno, CA
    Alright I guess I can give that a try... stupid rivatuner lol.
     
  8. Cja123

    Joined:
    Aug 26, 2008
    Messages:
    634 (0.27/day)
    Thanks Received:
    39
    Location:
    Fresno, CA
    Oh shoot thanks man I didn't see it the first time lol. I was thinking "what the hell is this guy smoking.. I don't see anything about that." Lol thanks bro :toast:
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page