1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Network Transfer slows down

Discussion in 'Networking & Security' started by Tau, Jun 23, 2009.

  1. Tau

    Tau New Member

    Joined:
    Mar 9, 2007
    Messages:
    821 (0.30/day)
    Thanks Received:
    92
    Well I have an interesting issue that i need to fix here.

    I have a Vista Business X64 SP1 vlited install (100% stable) now when i reboot that machine and copy a file from the fileserver i get fast speeds 75-85MB/s (it jumps around a bit since its using the onboard on the client and its not the greatest NIC)

    Then after a few hours (not sure how many havent tested that yet) lets call it a day of the client being online i try to copy from the fileserver again (same file) i get 6.8MB/s basically bang on... it fluctuates up to 7.5 then back to 6.8 no matter how long i leave the transfer.... then i reboot its speedy again....

    Iv tried killing off most all the running processes, i thought it might be diskeeper on this end eating up HDD speed or something.... but its not...

    I'm kinda stumped any ideas?
  2. slyfox2151

    slyfox2151

    Joined:
    Jan 14, 2009
    Messages:
    2,606 (1.29/day)
    Thanks Received:
    524
    Location:
    Brisbane, Australia
    im going to say your problem lies with vista... mine does the same thing on 3 different pc's xfering to any other one when they all had vista.

    iv moved my pc to win 7 and the problem has gone from this pc, however the other 2 still need reboots every day or 2.
  3. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,007 (11.72/day)
    Thanks Received:
    9,401
    network speeds slow down on vista, if you have audio playing. long time bug, no working solution.

    some media players cause this when paused, so audio doesnt have to be playing, per se.
  4. Zebeon New Member

    Joined:
    May 1, 2009
    Messages:
    245 (0.13/day)
    Thanks Received:
    65
    Location:
    USA
    Vista has a built in TCP/IP autotune feature- That is what makes your network transfer slow down so much.
    I don't know all the details, but have seen this b4- Do a google search for vista autotune- It will tell you how to change the settings and I think you can even turn it off.
  5. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,007 (11.72/day)
    Thanks Received:
    9,401
    trust me, i messed with all that stuff. the only solution is to close anything tied in to audio, or move to 7. the autotune is blamed a lot, when its not related at all.
  6. Zebeon New Member

    Joined:
    May 1, 2009
    Messages:
    245 (0.13/day)
    Thanks Received:
    65
    Location:
    USA
    that is interesting- I have never heard of that b4, but thanks for the tip- It may come in handy down the road-
  7. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,007 (11.72/day)
    Thanks Received:
    9,401
    it was an absolute killer at lan parties. some people never turn WMP or winamp off, so it was nasty when transferring files to and from them.
  8. Tau

    Tau New Member

    Joined:
    Mar 9, 2007
    Messages:
    821 (0.30/day)
    Thanks Received:
    92
    Wow....

    I cant beleave something like this has not been patched yet.... I recently just switched my main pc to vista from XP.... i did a reboot and it seemed the slowdown was within ~5 minutes after the machine booted to desktop...

    I will try again here after im done with this batch of work and not open anything sound related and see if that helps things....

    ***EDIT***

    Well a fresh reboot and thigns were speedy, fired up foobar, still speedy, played a file in foobar and the speeds plumeted to 6.8MB/s from 70MB/s. stop the track and it ramps back up to 70....

    Youtube sound also has the same effect.

    Though it only does it when a track is active.... so playing or paused....

    This really boggles my mind, how could a bug this huge go unpatched for so damn long? im doing some more research into the matter now and ill post my findings.
    Last edited: Jun 23, 2009
  9. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,007 (11.72/day)
    Thanks Received:
    9,401
    normally closing the program is enough to make it speed up again.
  10. Tau

    Tau New Member

    Joined:
    Mar 9, 2007
    Messages:
    821 (0.30/day)
    Thanks Received:
    92
    Not something I'm willing to do.

    I also fixed it :):cool:

    A simple reg edit, and disabling a service and i have no more network slowdown :)

    For those interested;


    1) Open Regedit navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Audiosrv\DependOnService

    Open that key and remove the MMCS line.

    2) Run services.msc and disable (dont try to stop it) the MMCS service.

    3) Reboot

    4) Enjoy.
  11. newtekie1

    newtekie1 Semi-Retired Folder

    Joined:
    Nov 22, 2005
    Messages:
    19,718 (6.22/day)
    Thanks Received:
    5,866
    Ah, that would explain why I have never noticed this, I have TVersity installed, which disables MMCS for me...
    Crunching for Team TPU More than 25k PPD
  12. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,007 (11.72/day)
    Thanks Received:
    9,401
    hmmm.


    i recall hearing about a fix like this, but what it did was swapped poor network speeds, for stuttering audio when network traffic was high...


    i had this archived away in some notes too.


    Windows throttling mechanism
    Because multimedia programs require more resources, the Windows networking
    stack implements a throttling mechanism to restrict the processing of
    non-multimedia network traffic to 10 packets per millisecond.



    To configure the throttling rate, change the value of the
    NetworkThrottlingIndex registry entry under the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Multimedia\SystemProfile\
    Name : NetworkThrottlingIndex
    Value type : DWORD
    Value data : From integer 1 through integer 70 (Decimal) (Decimal)

    By default, the value for the NetworkThrottlingIndex registry entry is set
    to 10. When the NetworkThrottlingIndex registry entry does not exist, the
    behavior resembles the default behavior. Network throttling can be
    completely turned off by setting the value to FFFFFFFF (hexadecimal). You
    must restart the computer after you make a change to the value of the
    NetworkThrottlingIndex registry entry.

    *Important *The default value is unlikely to cause degradation in network
    performance in most common Internet usage scenarios that use broadband
    connections. We recommend that you only use the throttling mechanism after
    you fully understand the tradeoff between multimedia playback quality and
    network performance.
  13. Tau

    Tau New Member

    Joined:
    Mar 9, 2007
    Messages:
    821 (0.30/day)
    Thanks Received:
    92
    I have been testing for any sound degredation and have got nothing over the past couple hours of testing, all the time i have been moving a 100GB dummy file back and forth over the network.

    Confirmed no issues in either foobar (ASIO mode) or MPC.

    So im all happy now :)
  14. CAPITAL LETTERS

    CAPITAL LETTERS New Member

    Joined:
    Jan 4, 2009
    Messages:
    136 (0.07/day)
    Thanks Received:
    13
    Location:
    Ninja's Dont Need Homes
    im guessing you would have an on-board ethernet adapter. correct?

    very interest problem.

    how many other users are on the network?
    and what is the route you are connected to this file server. eg, though a switch then router or a couple of switches and routers?

    gigabit network?

    im just trying to sus out any possible network issues


    lol ok never mind, i didnt read far enough to realise you fix it

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page