1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Networking Windows 7 and Ubuntu 9.10

Discussion in 'Networking & Security' started by MoonPig, Feb 25, 2010.

  1. MoonPig

    MoonPig

    Joined:
    Aug 7, 2008
    Messages:
    5,730 (2.42/day)
    Thanks Received:
    886
    Location:
    Wakefield, UK
    Hey,

    Just installed Ubuntu on my Media Center as Win7 beta is running out. Everything works great except networking. My setup is that i have all the media on this computer (running Windows 7 Home Premium) and then just an 80GB Hard-Drive on the Media center (running Ubuntu 9.10).

    It asks for my 'Domain' and 'Password' when i try to connect to my computer from Ubuntu, so i put in what i have in "ControlPanel > Network > Homegroup" but it just comes up with an error connecting.

    For 'Domain' i have: WORKGROUP (It's given when the message box appears)
    For 'Password' i have the exact one i put in Homegroup.

    Any help would be great.

    Thanks

    Edit: One other problem. I have to manually set my resolution everytime i load Ubuntu. It's an onboard nVidia chip, so i have to use the nVidia CP over the 'Display' option in Ubuntu. Any way to fix it at the resolution i want?
     
    Last edited: Feb 25, 2010
  2. caleb

    Joined:
    Sep 15, 2004
    Messages:
    1,553 (0.41/day)
    Thanks Received:
    206
    Location:
    Poland,Slask
    Domain isn't the same as workgroup. Look up your domain settings plus check security settings for win7. I have win7 and vista lap and I couldnt connect to a simple share to that win7 from vista without it constantly asking for login/pw so Im guessing it must be some security setting on the win7.

    Are you using XBMC? I dont know about ubuntu but there should be something like sax there too. Maybe its overriding the cp settings.
     
  3. MoonPig

    MoonPig

    Joined:
    Aug 7, 2008
    Messages:
    5,730 (2.42/day)
    Thanks Received:
    886
    Location:
    Wakefield, UK
    Thats the thing, im lost on what i need to put in that message box. Where do i find my domain settings. Also, im not sure about much to do with Ubuntu, this is the first time ive used it properly.
     
  4. caleb

    Joined:
    Sep 15, 2004
    Messages:
    1,553 (0.41/day)
    Thanks Received:
    206
    Location:
    Poland,Slask
    Right click MyComputer -> props and tehre you can switch between wgrp and domain. Select workgroup and google how to share in win7.
     
  5. MoonPig

    MoonPig

    Joined:
    Aug 7, 2008
    Messages:
    5,730 (2.42/day)
    Thanks Received:
    886
    Location:
    Wakefield, UK
    I have everything shared from when i used Windows 7 on both computers. It worked flawlessly. Just it's not working now. This is what i see, not sure how i can change it.

    [​IMG]
     
  6. caleb

    Joined:
    Sep 15, 2004
    Messages:
    1,553 (0.41/day)
    Thanks Received:
    206
    Location:
    Poland,Slask
    MoonPig says thanks.
  7. MoonPig

    MoonPig

    Joined:
    Aug 7, 2008
    Messages:
    5,730 (2.42/day)
    Thanks Received:
    886
    Location:
    Wakefield, UK
    Hmmm ok. Not sure them links really help. I can see my computer from Ubuntu if i go to Network Places (or whatever), but it prompts with the Domain and Password message...

    Anyone know what i need to put into that box?
     
  8. caleb

    Joined:
    Sep 15, 2004
    Messages:
    1,553 (0.41/day)
    Thanks Received:
    206
    Location:
    Poland,Slask
    What about removing anything from the domain field in ubuntu and just putting a Guest into login field ? What exacly did u change in ubuntu setup after install ? Perhaps it wants to add itself to domain cause you configured it as domain member not a workgroup one ?
     
  9. caleb

    Joined:
    Sep 15, 2004
    Messages:
    1,553 (0.41/day)
    Thanks Received:
    206
    Location:
    Poland,Slask
    PS the fact that its on network places in ubuntu it doesnt mean the linux sees this as a share you setup on the Win7. ( I assume you want to connect to a shared folder from begining)
     
  10. MoonPig

    MoonPig

    Joined:
    Aug 7, 2008
    Messages:
    5,730 (2.42/day)
    Thanks Received:
    886
    Location:
    Wakefield, UK
    This is a clean install. I did it last night then applied ALL the updates this morning. I've looked on afew forums and any errors seem to be solved by the update. I found this which is EXACTLY what i want to do, but they don't specify where the workgroup details came from.

    http://www.randyjensenonline.com/blog/connect-ubuntu-810-windows-7-share

    [​IMG]

    Thats the bit im struggling with.
     
  11. caleb

    Joined:
    Sep 15, 2004
    Messages:
    1,553 (0.41/day)
    Thanks Received:
    206
    Location:
    Poland,Slask
    Well. The guide looks like the guy got lucky "click share click add and it works" not really tellin ya much. IMHO Its dodgy because you dont have any domain so why in the world would linux ask for a domain passwd ? Thats why I asked you to list shares with smbclient. Linux aint windows and dont trust its GUI tools absolutely
     
  12. MoonPig

    MoonPig

    Joined:
    Aug 7, 2008
    Messages:
    5,730 (2.42/day)
    Thanks Received:
    886
    Location:
    Wakefield, UK
    [​IMG]

    That says that my domain is "WORKGROUP"... So im just looking for the password?
     
    Last edited: Feb 25, 2010
  13. angelkiller

    angelkiller

    Joined:
    May 16, 2008
    Messages:
    1,258 (0.51/day)
    Thanks Received:
    225
    Location:
    North Carolina
    Have you tried simply setting up a shared folder?

    I ask this becasue it's possilble to 'see' a Windows 7 computer without being able to connect to them. My PS3 picks up my W7 laptop as a media server, but it can't connect. (No shared folders.) I can also 'see' other W7 machines on the LAN, but I can't connect to any of them.

    I think if you set up a shared folder on the W7 box, that would allow Ubuntu to actually connect to the W7 box. I've never had to mess with domain names and such when networking Ubuntu with Windows.
     
  14. MoonPig

    MoonPig

    Joined:
    Aug 7, 2008
    Messages:
    5,730 (2.42/day)
    Thanks Received:
    886
    Location:
    Wakefield, UK
    I've just created a folder on my win7 machine's desktop and shared it. I gave it 'Everyone' permissions. From the Ubuntu machine, i still can't access my Win7 computer though.

    When i go to "Places > Network > Danny-PC" i get this message box:

    [​IMG]
     
  15. angelkiller

    angelkiller

    Joined:
    May 16, 2008
    Messages:
    1,258 (0.51/day)
    Thanks Received:
    225
    Location:
    North Carolina
    Log in using the same account and password of the user of the Win7 Box.
     
  16. MoonPig

    MoonPig

    Joined:
    Aug 7, 2008
    Messages:
    5,730 (2.42/day)
    Thanks Received:
    886
    Location:
    Wakefield, UK
    I've tried that. Im the only user on this computer, the user is 'Danny' and i have no password. So, when i used them details:

    Username: Danny
    Domain: WORKGROUP
    Password:

    I just got nothing, then the same box pops back up. I've tried the HomeGroup password i set and still nothing.
     
  17. angelkiller

    angelkiller

    Joined:
    May 16, 2008
    Messages:
    1,258 (0.51/day)
    Thanks Received:
    225
    Location:
    North Carolina
    Hm. I am out of suggestions.

    However, I do have an Ubuntu box at home so I can do some testing later today.
     
    MoonPig says thanks.
  18. angelkiller

    angelkiller

    Joined:
    May 16, 2008
    Messages:
    1,258 (0.51/day)
    Thanks Received:
    225
    Location:
    North Carolina
    Alright. It's just as I thought earlier.

    Without setting up anything, it won't work. Ubuntu will see the Win7 box, and that box will come up, and no login info will work.

    To get it to work, I used a shared folder. Pick any folder that you wanna share on the Win7 box and right click, Properties, Sharing. Next click Share. Make sure the correct people have the correct permissions. Click Share again then click done. And that's it. On the Ubuntu box, connect how you have been previously connecting. (Places, Network) Click on the Win7 computer. The box will appear again, but this time enter the username and password of the user who is sharing the folder on the Win7 computer. Leave the Domain as Workgroup, unless you've chaned it on your Windows computers. That should get you in. Then click on the folder you have shared. (You may have to enter the info again) But after the second time you should be browsing your folder on the Win7 Box.

    I followed this exact procedure and it worked. Hopefully this'll work for you too.
     
  19. msgclb

    msgclb

    Joined:
    May 15, 2008
    Messages:
    1,719 (0.70/day)
    Thanks Received:
    4,271
    Location:
    Oklahoma City
    I'm going to be installing Ubuntu 9.10 in a couple of weeks on a new build and hopefully I will be able to access it through my network. Currently my 24/7 computer is running Vista and it can access all the rigs on my network including more than one Windows 7 Home Premium system.

    I'm writing this from one of my Window 7 WCG/Folding systems and I can access my network. I haven't done anything special except that I changed my User Account Control Settings to 'Never notify' even though that was not recommended and did almost the same thing that angelkiller recommended in post 18.

    [​IMG]

    I'll be watching this thread to see what your solution will be.
     
  20. Killer_Rubber_Ducky

    Killer_Rubber_Ducky

    Joined:
    Oct 20, 2009
    Messages:
    2,715 (1.41/day)
    Thanks Received:
    300
    Try setting up a shared folder in ubuntu. I had that problem but fixed it by setting up sharing in ubuntu. It should be under the system menu
     
  21. Batou1986

    Batou1986

    Joined:
    Oct 2, 2005
    Messages:
    2,527 (0.74/day)
    Thanks Received:
    386
    Location:
    Baltimore MD
    9.10 Karmonic breaks the crap out of simple SMB shareing with windows try 8.xx that still works fine.
     
  22. msgclb

    msgclb

    Joined:
    May 15, 2008
    Messages:
    1,719 (0.70/day)
    Thanks Received:
    4,271
    Location:
    Oklahoma City
    I've now got my Ubuntu 9.10 installed and I'm trying to set up sharing with Windows 7 or Vista. So far the only thing the Windows network sees is the printer. I guess I'm going to have to do some reading! Everything I've tried in Ubuntu 9.10 has returned errors. It just doesn't want to share with anyone.:banghead:
     
  23. angelkiller

    angelkiller

    Joined:
    May 16, 2008
    Messages:
    1,258 (0.51/day)
    Thanks Received:
    225
    Location:
    North Carolina
    Have you tried my method above? I have rarely had issues with sharing between Ubuntu and Windows. (XP & 7)
     
  24. newtekie1

    newtekie1 Semi-Retired Folder

    Joined:
    Nov 22, 2005
    Messages:
    20,400 (6.08/day)
    Thanks Received:
    6,418
    It might be worth noting that Windows 7, I believe, requires the user account have a password. Otherwise it will not allow the account to be used to access the computer from the network.
     
    driver66 says thanks.
    Crunching for Team TPU
  25. msgclb

    msgclb

    Joined:
    May 15, 2008
    Messages:
    1,719 (0.70/day)
    Thanks Received:
    4,271
    Location:
    Oklahoma City
    I tried to share a folder but it failed.

    Here's what I tried:
    Selected the folder an clicked Properties. Selected the Shared tab. Checked the Share this folder box. Clicked the Create Share button. I get this message...

    Failed to execute child process
    "testparm" (No such file or directory)

    Since I clicked on a folder it must exist so I'm confused.:confused:

    I just realized that this is a new install and I haven't run any updates. I'll have to do that and then try to share a folder again.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page