1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

New Crucial M4 SSD 040H firmware released!

Discussion in 'Storage' started by RejZoR, Dec 4, 2012.

  1. RejZoR

    RejZoR

    Joined:
    Oct 2, 2004
    Messages:
    4,778 (1.29/day)
    Thanks Received:
    1,004
    Location:
    Europe/Slovenia
    DOWNLOAD:
    http://www.crucial.com/support/firmware.aspx

    Changelog:
    Release Date: 12/04/2012

    - Improved robustness in the event of an unexpected power loss. Significantly reduces the incidence of long reboot times after an unexpected power loss.
    - Corrected minor status reporting error during SMART Drive Self Test execution (does not affect SMART attribute data).
    - Streamlined firmware update command for smoother operation in Windows 8.
    - Improved wear leveling algorithms to improve data throughput when foreground wear leveling is required.
     
    dhdude says thanks.
  2. RejZoR

    RejZoR

    Joined:
    Oct 2, 2004
    Messages:
    4,778 (1.29/day)
    Thanks Received:
    1,004
    Location:
    Europe/Slovenia
    Works great though you have to use ISO image. Stupid Windows updater yet again doesn't detect my SSD...
     
    dhdude says thanks.
  3. dhdude

    Joined:
    Feb 22, 2010
    Messages:
    184 (0.11/day)
    Thanks Received:
    45
    Location:
    Kent, UK
    I've yet to update the M4's firmware in two builds I've recently finished for family members, so I'll be sure to check this out!
     
  4. LAN_deRf_HA

    LAN_deRf_HA

    Joined:
    Apr 4, 2008
    Messages:
    4,559 (1.88/day)
    Thanks Received:
    954
    Check the comments on the crucial forum to see if people are having issues before updating.
     
  5. Inioch

    Inioch

    Joined:
    Aug 19, 2008
    Messages:
    567 (0.25/day)
    Thanks Received:
    97
    Location:
    Finland
    Updated today using the usb-iso method. Had to change the drive from marvell adapter to intel for the update to work. I was still using the 0009 before update :)

    The forums didn't seem to indicate any big problems with this one, except for the windows updater not working properly.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page