1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

non stop problems for me and Roccat Kave headset!

Discussion in 'General Hardware' started by Stonesour767, Oct 31, 2009.

  1. Stonesour767

    Stonesour767 New Member

    Joined:
    Jan 3, 2009
    Messages:
    182 (0.08/day)
    Thanks Received:
    1
    I've been having so many damn problems since i moved over to windows 7! My current one is this. I bought a pair of Roccat Kave headphones the other day, took me 3 or so days to figure out how to get the microphone to work properly! now, for some strange and unknown reason im getting a hell of a lot of feedback or whitenoise on my microphone when ever it's on. Some times it can be so deafening that i have to mute the microphone! if it helps at all im using a creative X-FI titanium sound card.
     
  2. Stonesour767

    Stonesour767 New Member

    Joined:
    Jan 3, 2009
    Messages:
    182 (0.08/day)
    Thanks Received:
    1
    come on! i really need help with this. I've got a big game tonight where i need my mic working properly. There must be someone who knows what i could do. Or knows windows 7 enough to tell me some things about the sound settings.
     
  3. AsRock

    AsRock TPU addict

    Joined:
    Jun 23, 2007
    Messages:
    11,751 (4.06/day)
    Thanks Received:
    2,054
    Location:
    US
    You tried the on board sound card ?. Or even reinstall the drivers if it used to work before.
     
  4. temp02 New Member

    Joined:
    Mar 18, 2009
    Messages:
    493 (0.22/day)
    Thanks Received:
    166
    How about turning this off?
    [​IMG]
    Other than this nothing else occurs to me about that "static" sounds...
     
  5. Stonesour767

    Stonesour767 New Member

    Joined:
    Jan 3, 2009
    Messages:
    182 (0.08/day)
    Thanks Received:
    1
    i dont get a custom tab and i have just reinstalled the drivers. getting very odd.


    none of the drivers or programs supplied with the disk work after ive tried uninstalling then reinstallnig them. i get an error from the program which helps saying it cant find the device.


    Also is there a way to completely, and i mean compeltely delete the creative files off of my pc. I've used driver cleaner to ger them off but i was wondering if maybe that missed some things.
     
    Last edited: Nov 1, 2009
  6. Vistage New Member

    Joined:
    Nov 3, 2009
    Messages:
    1 (0.00/day)
    Thanks Received:
    0
    I might be able to help you... and possibly make your headphones sound better. I know that wasn't in your original problem.. but all the hoops I had to go through I was thinking some of this might help. I also had sort of a weird problem where I would hear myself.

    First off dont remove the creative software from your computer. Its one of the ways you can change the audio settings for the card. I been in contact with the company I got my kave headsets from. There is a serious issue with the Tip n Remote controls. But regarding you issue with the MIC i had the similar issue. It happens whenever I go to default settings on the creative control panel. Here is how I fixed it and made my headsets sound great.

    1. Since windows 7 was finally released alot of companies have released their drivers for their respective devices. Check the creative website for your updated drivers.

    2. Once you have the creative software installed go to the blue and grey controll panel. Make sure you are on the Main Display of the Entertainment Mode. Click the speaker icon and make sure its set to 5.1. Go to bass settings and enable Bass Redirection. Set the Crossover Frequency to 100hz. As thats the max the vibration unit can handle. Click on Subwoofer Gain. I seemed to get better bass with that enabled.

    3. Set the system Volume with the big Volume nob to 90 percent.

    4. Go back to the main Display on Entertainment Mode. If you see two right ">>" signs to the bottom right of the blue section in the control panel press them.

    5. Go to Jacks and make sure microphone is selected if you have a flexjack.

    6. Main Display again. Click the Mixer Icon... For some reason I have to Unmute and Mute the Mic mixer setting to remove the fuzz and feedback. If you have a REC section to the right of this make sure its set to Microphone. Should be a little down arrow.

    7. Back to Main Display. There should be a little mic icon that showed up now. There you can test your mic and sound like a robot if you would like. Also make sure you turn off the CMSS - 3d. on the main display because that setting is designed for stereo headphones.

    Also turn down the microphone level a little bit. I turned myself down to level 10 and I was still able to hear everything great. With no feedback or whitenoise.

    Please let me know if this helped in anyway to enchance your sound or worsen it. At first I had a crap load of problems with it.
     
  7. robozk New Member

    Joined:
    Jan 12, 2010
    Messages:
    1 (0.00/day)
    Thanks Received:
    0
    i also have problems with roccat kave but my sound card is terratec aureon 7.1 pci. i've installed and updated every driver on my pc but they just never seem to work right. when i tested the speakers, it plays all the speakers but with no bass... and the desktop remote changes the volume of the front speakers only... this is getting annoying. operating system is windows 7
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page