1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Performance degradation

Discussion in 'General Hardware' started by ivicagmc, Sep 23, 2010.

  1. ivicagmc

    ivicagmc

    Joined:
    Mar 17, 2010
    Messages:
    176 (0.11/day)
    Thanks Received:
    27
    Location:
    Serbia
    What could cause graphics performance to reduce in windows 7. First I notice that FPS in starcraft 2 and borderlands has split in half. Since my system was quite old (around 5 months)and full of crap, I reinstalled it. Now borderlands is working better but not like before, Far Cry 2 likewise, and most interesting thing is that windows performance index for my 5770 has reduced from 7.4 to 7.3, both in gaming and aero. Everything else is the same as was before. Now, I tried putting old drivers, and some other things, but last big thing I did before everything started was putting new MB BIOS (asus M3A). I tried to put old one back but asus flash wont let me to put older version.
    My question is how to return to older BIOS and is there some settings in bios that might cause all this?
     
  2. hat

    hat Maximum Overclocker

    Joined:
    Nov 20, 2006
    Messages:
    16,920 (5.91/day)
    Thanks Received:
    2,064
    Location:
    Ohio
    ivicagmc says thanks.
    Crunching for Team TPU
  3. ivicagmc

    ivicagmc

    Joined:
    Mar 17, 2010
    Messages:
    176 (0.11/day)
    Thanks Received:
    27
    Location:
    Serbia
    OK, This is rely strange. I removed graphics card, clean it a little bit, reinserted and now everything is as it should be. It was'n dirty, I cleaned it 2 days ago.... What could possibly be that I did before, to cause all this?????
     
  4. hat

    hat Maximum Overclocker

    Joined:
    Nov 20, 2006
    Messages:
    16,920 (5.91/day)
    Thanks Received:
    2,064
    Location:
    Ohio
    Maybe the PCI-E lanes are dirty.
     
    Crunching for Team TPU
  5. erixx

    erixx

    Joined:
    Mar 24, 2010
    Messages:
    3,351 (2.04/day)
    Thanks Received:
    463
    Now seriously: Maybe your GPU fan was not spinning!
     
  6. sneekypeet

    sneekypeet Unpaid Babysitter Staff Member

    Joined:
    Apr 12, 2006
    Messages:
    21,563 (6.99/day)
    Thanks Received:
    6,098
    I see issues where the card doesnt get seated exactly correct all the time. Its completely feasable the dirt or just not getting the card in the slot all the way could easily bring performance down.
     
  7. jasper1605

    Joined:
    Nov 6, 2009
    Messages:
    1,274 (0.72/day)
    Thanks Received:
    228
    Location:
    Ohio
    this is interesting. I'm going to have to give my system a thorough cleaning if I ever notice some degradation. Thanks for bringing this up!
     
  8. Techtu

    Techtu

    Joined:
    Mar 6, 2010
    Messages:
    2,143 (1.29/day)
    Thanks Received:
    499
    Location:
    In the night garden
    I personally can't see the dust/dirt getting caught in the PCI lanes & etc. Once fitted the components should be a snug fitting... hence the stability ;) As the OP said 2 days ago he cleaned out his rig and then noticed the degradation, this was probably the result of some dust getting caught when he/she was fitting the components back together.
     
  9. jasper1605

    Joined:
    Nov 6, 2009
    Messages:
    1,274 (0.72/day)
    Thanks Received:
    228
    Location:
    Ohio
    A good point as well lol. My system could still use a good cleaning as it hasn't gotten pampered in a few months since I changed the PSU out lol.
     
  10. Techtu

    Techtu

    Joined:
    Mar 6, 2010
    Messages:
    2,143 (1.29/day)
    Thanks Received:
    499
    Location:
    In the night garden
    Canned air is the best thing for the job :D

    [​IMG]
     
  11. EastCoasthandle

    EastCoasthandle New Member

    Joined:
    Apr 21, 2005
    Messages:
    6,889 (2.00/day)
    Thanks Received:
    1,505
    More then likely the several reboots is what did it. Not something that is needed often.
     
  12. Raovac

    Raovac

    Joined:
    May 25, 2006
    Messages:
    139 (0.05/day)
    Thanks Received:
    16
    :wtf: Since when is a 5 month old rig concidered OLD???? :rolleyes:
     
  13. Techtu

    Techtu

    Joined:
    Mar 6, 2010
    Messages:
    2,143 (1.29/day)
    Thanks Received:
    499
    Location:
    In the night garden
    I suppose it depends on how often it is used and how good/bad the user is at keeping it clean/virus free. :)
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page