1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Phantom 410 case power LED broken?

Discussion in 'NZXT' started by kamechi, Apr 1, 2014.

  1. kamechi

    Joined:
    Jul 8, 2009
    Messages:
    24 (0.01/day)
    Thanks Received:
    0
    Hi i need some help, i have a phantom 410 white and recently i found the power LED is not lightning up anymore.

    i also have asrock z77 extreme 4 and i pretty sure i plug in the correct pwr LED+ / pwr LED- cable.

    how can i fix it? is it mobo faulty or the LED faulty?
  2. itsakjt

    itsakjt

    Joined:
    Oct 9, 2010
    Messages:
    1,173 (0.83/day)
    Thanks Received:
    379
    Location:
    Kolkata, India
    Check the LED manually with a 3V battery by electrically connecting it. Of course remove the connector from the motherboard prior to doing it. If the LED does not light up, take apart the corresponding part of the case and check the solder joints. LEDs don't usually give out. If in the rare chance, the LED itself is dead, buy a new one and pop it in. :)
  3. kamechi

    Joined:
    Jul 8, 2009
    Messages:
    24 (0.01/day)
    Thanks Received:
    0
    i tried plug HDD power lead cable into the PWR lead on the motherboard and it light up. so i guess is the pwr LED faulty. How can i replace it? Do i have to cut off the old one?
  4. itsakjt

    itsakjt

    Joined:
    Oct 9, 2010
    Messages:
    1,173 (0.83/day)
    Thanks Received:
    379
    Location:
    Kolkata, India
    Yes you have to cut off the old one and replace it with another LED. Just solder the wires in the suitable terminals. :)

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page