1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Please Help with 4850's in CrossFire!

Discussion in 'AMD / ATI' started by darrenholb, Feb 24, 2009.

  1. darrenholb New Member

    Joined:
    Feb 24, 2009
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    Hi

    I have 2 powercolour HD4850 `s PowerColor PLAY! HD4850 512MB GDDR3

    http://www.powercolor.com/eng/products_features.asp?ProductID=4506

    I am having so much trouble to enable thease in crossfire mode, i have tried different bios`s and they just killed the card, so flashed back to original. Dose anybody have a new bios so thease cards will work with the latest drivers from ATI. Thankyou all, if you can help me with this problem you will save a life lol.

    Dazzy.
     
  2. Hybrid_theory

    Hybrid_theory New Member

    Joined:
    Mar 31, 2007
    Messages:
    1,895 (0.69/day)
    Thanks Received:
    163
    Location:
    ontario canada
    Shouldn't need to flash their bios for crossfire to work. Just hook the connector and enable in catalyst i believe.
     
    Last edited: Feb 24, 2009
  3. JrRacinFan

    JrRacinFan Served 5k and counting ...

    Joined:
    Mar 17, 2007
    Messages:
    19,414 (7.08/day)
    Thanks Received:
    4,483
    Location:
    Youngstown, OH
    What driver revision are you trying?
     
  4. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,662 (13.29/day)
    Thanks Received:
    14,055
    Follow this guide: http://forums.techpowerup.com/showthread.php?t=52502

    The key is making sure that all traces of your previous drivers are gone. Deffinitely use Catalyst 9.2 as ATi did some work with them concerning the 4850 and CrossFire. Any more questions, just ask. :)
     
  5. darrenholb New Member

    Joined:
    Feb 24, 2009
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    Im on cat 9.2, gonna give it another go with your suggestions will report back, thanks all for you quick response , fingers crossed.
     
  6. J-Man

    J-Man New Member

    Joined:
    May 14, 2007
    Messages:
    2,248 (0.84/day)
    Thanks Received:
    81
    Location:
    Oakham, UK
    Pretty simple... just use the bridge and enable crossfire in CCC?
     
  7. darrenholb New Member

    Joined:
    Feb 24, 2009
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    Hi

    Tried as above, my crossfire always works in 8.10 just a problem with any higher driver. All comp bios correct and up to date, cards installed with both bridges, now after installing a clean 9.2 cat and driver it says that 1 card is disabled - its ok in the device manager. Thanks all if anyone else can help would be appreciated, are we sure this may not be fixed with a new bios, if so dose anyone have one. Thanks Again.

    Dazzy
     
  8. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,662 (13.29/day)
    Thanks Received:
    14,055
    Where does it say that one card is disabled? Are you able to go into CCC and enable CrossFire? What motherboard are you using and are the chipset drivers up to date?
     
  9. darrenholb New Member

    Joined:
    Feb 24, 2009
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
  10. darrenholb New Member

    Joined:
    Feb 24, 2009
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    Motherboard is Biostar 790gx with latest bios. (works fine with 8.10 drivers and ccc)
     
  11. darrenholb New Member

    Joined:
    Feb 24, 2009
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
  12. JrRacinFan

    JrRacinFan Served 5k and counting ...

    Joined:
    Mar 17, 2007
    Messages:
    19,414 (7.08/day)
    Thanks Received:
    4,483
    Location:
    Youngstown, OH
    Hmmmm .....

    Try out the 8.12 CCC Hotfix drivers and also, do a driver clean while your at it.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page