1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Questions about X850Pro AGP

Discussion in 'Graphics Cards' started by JustAnotherSquid, Sep 6, 2005.

  1. JustAnotherSquid New Member

    Joined:
    Sep 6, 2005
    Messages:
    31 (0.01/day)
    Thanks Received:
    0
    X850Pro AGP VIVO: How to get 16 pipes and still have variable speed fan

    edit - go to page 3 for the instructions on how to unlock pipes and retain variable speed fan

    Hello all,

    Just picked up an X850Pro AGP, and am happy to report that unlocking all 16 pipes was as easy as flashing the BIOS with one from an X850XT-PE, and then de-clocking it to X850XT speeds (the stock cooler can't handle 540/580). Unlocking the pipes bumped performance by about 20%, and increasing the speeds from 500/500 to 520/540 gave another 5% or so. Very nice. :)

    However, after flashing the card and installing ATITool, I started to notice odd behaviour from the fan. It is now either on or off - it is not working as a variable speed fan no matter how I configure ATITool. I don't know if it was before the flash. Also, the default on/off temperature is 90degC, which seems very, very high.

    So using ATITool I've got it set to come on at 50degC instead, and have an Arctic Cool Silencer 5 on the way.

    Now for the questions:
    If you have a X850Pro AGP, is your fan variable speed or is it just on/off?
    If just on/off, does it cycle at 90degC?
    Will replacing the stock cooler with the Arctic Cool unit allow variable speed fan control?

    Thanks in advance for your help.
    Last edited: Sep 8, 2005
  2. dolf New Member

    Joined:
    Mar 16, 2005
    Messages:
    2,058 (0.60/day)
    Thanks Received:
    30
    I have had the same "problem" with my X800XT AGP. The fan works only on/off reaching 70C/50C. After flashing X800XT PE BIOS the propblem has gone and the fan speed depends on the GPU temperature as in between fan doesn't completely stops :D .
    It is probably matter of BIOS. You should try some other XT BIOSes. You can check whether the BIOS changes the fan RPM using RivaTuner by chooseing "Hardware monitoring" you can see the "Fan duty cycle" graphic. ;)

    Success
    Last edited: Sep 7, 2005
  3. SPHERE New Member

    Joined:
    Mar 31, 2005
    Messages:
    822 (0.24/day)
    Thanks Received:
    1
    Location:
    arizona (cave creek)
    lol yet another flashed x850 pro agp wow almost all of them are flashing!!!!

    is it a vivo?
  4. JustAnotherSquid New Member

    Joined:
    Sep 6, 2005
    Messages:
    31 (0.01/day)
    Thanks Received:
    0
    Yeah, it's an AGP VIVO. Unlocked with just a BIOS flash, and runs great at 520/540 with the stock cooler.

    ATITool says max is 540/580 with stock cooler. I have a Silencer5 on the way - not to go faster, but because the stock fan is so damn noisy. Any extra speed afforded by the better cooling will just be a bonus. :)

    BTW, the X850Pro AGP is on sale this week at Best Buy for $250, so you can effectively get an X850XT for that price.
  5. SPHERE New Member

    Joined:
    Mar 31, 2005
    Messages:
    822 (0.24/day)
    Thanks Received:
    1
    Location:
    arizona (cave creek)
    lol thats 6 success stories so far... and 7 trys wow this is better than the x800 agp pro vivo to xt mod....

    damn i realy want a lian li case but it looks like that money may go to a x850 pro lol!
  6. blinker0 New Member

    Joined:
    Sep 2, 2005
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    Location:
    louisville kentucky
    Make that 7 ... Now all I need is to find the right Voltmod for this board.. As I have My water blocks made for the memory.. But want to do voltmods first.. Alot easier to not have to work around the blocks
  7. SPHERE New Member

    Joined:
    Mar 31, 2005
    Messages:
    822 (0.24/day)
    Thanks Received:
    1
    Location:
    arizona (cave creek)
    wow..

    is that a vivo aswell?
  8. blinker0 New Member

    Joined:
    Sep 2, 2005
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    Location:
    louisville kentucky
    yes its a vivo with 16ns chips.. and cant wait to Vmod it and get some dedicated water on there... It isnt sweating at all at 560 GPU and 620 Mem.. so patiently waiting... Have water on the GPU already.. Just not dedicated yet
  9. JustAnotherSquid New Member

    Joined:
    Sep 6, 2005
    Messages:
    31 (0.01/day)
    Thanks Received:
    0
    So you guys with X850Pros, is your stock fan variable speed or just on/off?
  10. SPHERE New Member

    Joined:
    Mar 31, 2005
    Messages:
    822 (0.24/day)
    Thanks Received:
    1
    Location:
    arizona (cave creek)
    my xtpe is dynamic :) but its controllable via ati tool :)
  11. Weigy104 New Member

    Joined:
    Jul 6, 2005
    Messages:
    242 (0.07/day)
    Thanks Received:
    3
    Location:
    Glasgow
    i'm not 100% sure but but i know that the fan speed control is in the bios. so instead of just flashing the bios you can use a bios editor to try and change it. but as i say not sure if it will work. plus you mihgt not want to flash to a different bios incase it doesn't work aswell as the one you have. ;)
  12. JustAnotherSquid New Member

    Joined:
    Sep 6, 2005
    Messages:
    31 (0.01/day)
    Thanks Received:
    0
    Yes, the PE bios has the ability to control the fan. However, for all bios fan speed values < 90%, the actual fan speed is zero. For all values >= 90%, the actual fan speed is 100%. So I'm thinking the fan has a fixed speed motor, and won't run below a certain supply current (about 90% of spec).
  13. 20PPC New Member

    Joined:
    Sep 7, 2005
    Messages:
    16 (0.00/day)
    Thanks Received:
    0
    Stock ATI X850 Pro Fan Control

    My new stock ATI X850 Pro (AGP) has dynamic fan control. I verified it using ATITool and I can hear it. When in 2D desktop it is running 54% and actually has an annoying "rattle" noise. When I launch 3D apps the fan increases speed and actually gets less annoying.

    I want to try flashing mine to get the 16 pipes but want to keep the stock clocks for now. Can you guys point me to a BIOS that will give me 16 pipes (if I'm lucky) and that will retain the dynamic fan control?
  14. JustAnotherSquid New Member

    Joined:
    Sep 6, 2005
    Messages:
    31 (0.01/day)
    Thanks Received:
    0
    I recommend checking it visually. ATITool says my fan is on at 54% too, but visual inspection shows it's not moving. I understand the aural comment but there are probably more than a few fans in your case. If you could visually verify that it's spinning when ATITool says it's at 54%, that would be awesome.
  15. JocelynLeigh New Member

    Joined:
    Sep 6, 2005
    Messages:
    5 (0.00/day)
    Thanks Received:
    0
    Guys I'm confused from the write up....(or X850 XT Bios if you are modding an X850 Pro VIVO)

    DId he forget to add the PE? or should we just use the newest X850 XT Bios? :confused:
  16. JustAnotherSquid New Member

    Joined:
    Sep 6, 2005
    Messages:
    31 (0.01/day)
    Thanks Received:
    0
    I'm confused by your question. ;) Here's a clip from my first post:

    I also experimented with an X850XT bios, and it also unlocked all 16 pipes, but it did not perform quite as well in benchmarks at the same clock speeds. I don't know if the PE has more aggressive memory timings, but in any event, it offered the best performance so that's what I'm running (currently de-clocked from PE speeds to 520/540 until the stock cooler can be replaced).
  17. 20PPC New Member

    Joined:
    Sep 7, 2005
    Messages:
    16 (0.00/day)
    Thanks Received:
    0
    Yes, I did verify the fan is moving and that it is the fan making the noise.

    edit: This is a stock VIVO ATI card I bought at BB this past weekend on sale in case you were wondering.
  18. 20PPC New Member

    Joined:
    Sep 7, 2005
    Messages:
    16 (0.00/day)
    Thanks Received:
    0
    I also just verifed that I can dynamically adjust the fan using ATITool. Funny thing is the rattle is there even as I crank the fan speed up, it is just that at the higher speeds the fan noise masks the rattle noise coming from the fan on the card.

    So back to your main issue, I think another BIOS needs to be found if the one you are using doesn't allow you to adjust the dynamic fan control.

    Does anyone know of a BIOS that will allow for this on the X850 Pro VIVO AGP and also give us the 16 pipes?
  19. 20PPC New Member

    Joined:
    Sep 7, 2005
    Messages:
    16 (0.00/day)
    Thanks Received:
    0
    One more question Squid, what specific X850XTPE BIOS did you use on your card that ISN'T allowing for dynamic fan control? Got a link or version?
  20. ctrl-alt-del New Member

    Joined:
    Sep 8, 2005
    Messages:
    1 (0.00/day)
    Thanks Received:
    0
    Workarround for fan - needs speed tests

    Unlocking all 16 channnels on X850 PRO

    I have the same situation with the loss of variable fan control after the XT or XT PE flash. Here is a way to unlock all 16 and keep the fan control.

    You can try this...

    1. Make a backup of the original X850 pro bios
    2. Use the MODIFIED flashrom to flash a x850xt or X850xt pe bios. This will enable all the 16 pipelines
    3. Use the UNMODIFIED flashrom to restore your original bios. This will NOT overwrite the new pipeline information and allow the fan to function.

    Of course you will still be runing 500/500.
    My temps are at 75C with the fan running at 95% during the ATI tool test at 500/500 for over 1 hour. But its stable.

    If you want to run any faster you really should get a ATI Silencer 5 (Rev. 2)

    I do not know what this offically makes your board or if the full 16 are really used. RIVATUNER says they are there. I need to run more tests. But it does work. :D
    Last edited: Sep 8, 2005
  21. blinker0 New Member

    Joined:
    Sep 2, 2005
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    Location:
    louisville kentucky
    use any of the 850 Xt or XT PE bios and set clocks to stock in ATI tool.. Just the XT Bios only increases clocks to 520 GPU and 540 Memory. But you get the 4 extra pipes but dont know about the fan controll
  22. JustAnotherSquid New Member

    Joined:
    Sep 6, 2005
    Messages:
    31 (0.01/day)
    Thanks Received:
    0
  23. 20PPC New Member

    Joined:
    Sep 7, 2005
    Messages:
    16 (0.00/day)
    Thanks Received:
    0
    I haven't done mine yet. I want to be the eighth person successful at this but I also want to retain control over my fan. I like ctrlaltdel's suggestion. Where can I get the unmodded flasher to restore the pertinent Pro BIOS values after getting the 16 pipes?
  24. 20PPC New Member

    Joined:
    Sep 7, 2005
    Messages:
    16 (0.00/day)
    Thanks Received:
    0
    This is all making sense now. After reading various posts on X850 Pro modding the conclusion is that folks loose control over their fans. This is probably because the fan controllers on the XT and XT-PE are configured differently. So what us X850 Pro modders need is a BIOS that retains fan control but gives us the 16 pipes. Either that or we need a work around as ctrl-alt-del has suggested.
  25. JustAnotherSquid New Member

    Joined:
    Sep 6, 2005
    Messages:
    31 (0.01/day)
    Thanks Received:
    0
    Or we need to get a Silencer 5. Mine should be here early next week. ;)

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page