1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

RAM & MOBO Help Please

Discussion in 'General Hardware' started by Robopimp, May 31, 2012.

  1. Robopimp

    Robopimp New Member

    Joined:
    May 20, 2012
    Messages:
    19 (0.03/day)
    Thanks Received:
    0
    I finished my build but Im having a problem with my RAM. I installed 4 x 4Gb Corsair Vengance 1866Mhz on my ASUS P8Z77-V PRO but the MOBO reports 1333Mhz. What can I do ??
    Thanks for the help :)
  2. Robopimp

    Robopimp New Member

    Joined:
    May 20, 2012
    Messages:
    19 (0.03/day)
    Thanks Received:
    0
    There's also a BIOS update for my MOBO, can that fix it ? What are the recommended steps to update the BIOS ??
  3. entropy13

    entropy13

    Joined:
    Mar 2, 2009
    Messages:
    4,867 (2.60/day)
    Thanks Received:
    1,169
    What are your complete specs? Where did you check that it's running at 1333MHz? Have you been to the BIOS already?
  4. theoneandonlymrk

    theoneandonlymrk

    Joined:
    Mar 10, 2010
    Messages:
    3,158 (2.11/day)
    Thanks Received:
    489
    Location:
    Manchester uk
    Read the mother boards manual and manual y set the memorys speed in the bios
  5. theoneandonlymrk

    theoneandonlymrk

    Joined:
    Mar 10, 2010
    Messages:
    3,158 (2.11/day)
    Thanks Received:
    489
    Location:
    Manchester uk
    bios update good, this mobile not gd type.;)
  6. Robopimp

    Robopimp New Member

    Joined:
    May 20, 2012
    Messages:
    19 (0.03/day)
    Thanks Received:
    0
    When I go into the BIOS I can see several things like Temps, cpu freq, and RAM. The RAM part reports 1333mhz.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page