1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Running Games in Window mode causes crash.

Discussion in 'NVIDIA' started by Grownman, Feb 27, 2009.

  1. Grownman

    Grownman New Member

    Joined:
    Dec 19, 2008
    Messages:
    139 (0.07/day)
    Thanks Received:
    4
    Location:
    CA
    Hi guys, I recently built a new pc back in Januaray and have been having this problem where if I try to run any type of game in window mode, my system will completely dip in fps then lock up and then it will crash and reboot on its own... Here are my pc specs

    Q9550 @stock
    Ultra 120E
    Evga 780i
    BFG GTX 295
    Corsair 4gb 1066
    Corsair 1000W
    500gb Seagate 7200.11 32mb cache

    Vista Home Premium 64bit
    Samsung T240HD 24"

    This is quite annoying because when i try to alt-tab in fullscreen it takes a while to load to desktop and then to go back takes time to load etc. I am also using 181.22 drivers.
     
  2. RevengE

    RevengE

    Joined:
    Dec 31, 2008
    Messages:
    2,662 (1.25/day)
    Thanks Received:
    211
    Location:
    Ohio
    Try Reinstalling Your Video Drivers.
     
  3. Grownman

    Grownman New Member

    Joined:
    Dec 19, 2008
    Messages:
    139 (0.07/day)
    Thanks Received:
    4
    Location:
    CA
    Done it already, with a clean registry with ccleaner and removing the drivers, rebooting and then reinstalling. =[
     
  4. RevengE

    RevengE

    Joined:
    Dec 31, 2008
    Messages:
    2,662 (1.25/day)
    Thanks Received:
    211
    Location:
    Ohio
    is it all games or just a certain few? Also Check to see nothing is overheating and let me know what you find.
     
    Last edited: Feb 27, 2009
  5. Tatty_One

    Tatty_One Senior Moderator Staff Member

    Joined:
    Jan 18, 2006
    Messages:
    16,748 (5.23/day)
    Thanks Received:
    2,544
    Location:
    Worcestershire, UK
    I think you will find that these days, windowed mode does not invoke 3D clocks on your graphics card, hence the crash, the only way to actually get around this power saving pain that you get now with both NVidia and ATi is to mod the 2D clock set in a BIOS editor and flash it.
     
  6. inf3rno

    inf3rno

    Joined:
    Nov 25, 2008
    Messages:
    415 (0.19/day)
    Thanks Received:
    41
    Location:
    Pakistan
    He might be right your windowed mode is not forcing the 3d clocks of your GFX card.
     
  7. Grownman

    Grownman New Member

    Joined:
    Dec 19, 2008
    Messages:
    139 (0.07/day)
    Thanks Received:
    4
    Location:
    CA
    hmm i would not know how to flash the bios in on my gfx. However i am in the nvidia control panel and in the advanced manage 3d settings and the last setting under the global settings tab is vertical sync and a option is use the 3d application setting which it is on atm or FORCE ON, or FORCE OFF. Would that do anything?
     
  8. Marineborn

    Marineborn New Member

    Joined:
    Jan 17, 2009
    Messages:
    2,144 (1.02/day)
    Thanks Received:
    312
    easy fix, dont play them in windowed mode, or....what you can do...blame it on the gtx295 bursting into flames and crashing your system. HEH!
     
  9. Grownman

    Grownman New Member

    Joined:
    Dec 19, 2008
    Messages:
    139 (0.07/day)
    Thanks Received:
    4
    Location:
    CA
    =.=" great solution....
     
  10. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,808 (13.18/day)
    Thanks Received:
    14,190
    From what I've read the GTX 295 in particular is bad for running in windowed mode. There is no fix really.
     
  11. D007

    D007

    Joined:
    Mar 7, 2007
    Messages:
    3,226 (1.16/day)
    Thanks Received:
    438
    Location:
    Pompano beach, Florida
    yea that's helpful...
    post count +1? lol..

    I'm no pro..
    but flashing the bios is something I'd look into.
    Not sure why you want windowed mode, but there must be a reason.
    I'd actually like to learn how to flash my gpu bios as well.
    Im sure it's very useful.

    as for those nvidia settings you mentioned..
    I doubt they will help.
    they're just defaults for video processing.

    I'd leave them on default if you don't know what they do..
    they each have a description though as to what they do.
    could help your have an idea of what your personal preferences are.
    the only tings in there that have caused me issues are things like triple buffering.
    triple buffering is a pain and can lead to more crashes..

    I generally say to let the application decided as all applications are different..
    that way you can set each individual application, to run the way that specific app works best..
    no two games run the same..

    triple buffering on left for dead is like praying for a crash..
    while on another game it might actually be useful..
    although I haven't seen it be useful yet..

    good luck.
     
    Last edited: Feb 27, 2009
  12. Tatty_One

    Tatty_One Senior Moderator Staff Member

    Joined:
    Jan 18, 2006
    Messages:
    16,748 (5.23/day)
    Thanks Received:
    2,544
    Location:
    Worcestershire, UK
    I'm more than happy to help anyone do a BIOS mod and subsequent flash, ATi or NVidia I have done literally hundreds.
     
  13. Grownman

    Grownman New Member

    Joined:
    Dec 19, 2008
    Messages:
    139 (0.07/day)
    Thanks Received:
    4
    Location:
    CA
    hmm, ill prob stick to the full screen then. don't want to void my warranty etc. However today playing wow i was running at 1920x1200 every max full aa etc and then i was experimenting around and i set to windowed mode. The current drivers i have 181.22 when running in window mode the fps drops dramatically and then the lag begins in the game window only. Then if i minimize the window and open firefox or any program and reopen "wow" the whole system lags up with a repeating ingame atmosphere sound or w/e sound it was at when it locked up...

    Now is it possible that the power supply is not adequate? It's a corsair 1000W I'm sure that its plenty but what i mean is currently i have the 8 pin and 6 pin both coming from the "non modular" side of the psu. Is it possible that when running in window mode this consumes more energy and therefore hits a pt on the rails etc?
     
  14. Tatty_One

    Tatty_One Senior Moderator Staff Member

    Joined:
    Jan 18, 2006
    Messages:
    16,748 (5.23/day)
    Thanks Received:
    2,544
    Location:
    Worcestershire, UK
    Because in windowed mode also, it is likely that only one GPU is active.
     
    Grownman says thanks.
  15. Grownman

    Grownman New Member

    Joined:
    Dec 19, 2008
    Messages:
    139 (0.07/day)
    Thanks Received:
    4
    Location:
    CA
    Yeah, I think so too.... I just did a bench with furmark.

    [​IMG]

    Says, one gpu active.... Is there a way to change this or have both GPU's running at all times?
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page