1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sabertooth X58

Discussion in 'Motherboards & Memory' started by Arrakis+9, Apr 8, 2011.

  1. Arrakis+9

    Arrakis+9

    Joined:
    Aug 10, 2007
    Messages:
    1,538 (0.55/day)
    Thanks Received:
    601
    Location:
    PL_badwater
    [rant]

    Alright, so im looking to my 3rd board not because i like it but because i've been having issues with it. the first one had a very bad stuttering issues, replaced the board, problem went away. second board been great for a full 2 months no issues at all, now just recently its been killing my usb devices that i plug into it, first i killed my phone while it was charging, then my 8gb pen drive, and shortly after my usb wireless card.

    those 3 devices litterlay just stopped working while they were plugged in and now wont ID on any computer i plug them in to. i got the sabertooth because i wanted reliably and not have to worry about upgrading for a very long time but now going into my 2nd replacement board from my original purchase its looking like shit. i was basically wondering if anyone else has had any issues with x58 boards and more in general asus boards. im seriously starting to doubt their QA and its leaning me towards another brand name.

    [/rant]
     
  2. LDNL

    LDNL

    Joined:
    Jan 25, 2011
    Messages:
    476 (0.31/day)
    Thanks Received:
    107
    Location:
    Finland
    Bad memory support on the deluxe board. Switched to a gigabyte board and had like 2 other sets after the first and all ran like a charm. Not really a so called fault but still annoying.
     
    Arrakis+9 says thanks.
  3. Arrakis+9

    Arrakis+9

    Joined:
    Aug 10, 2007
    Messages:
    1,538 (0.55/day)
    Thanks Received:
    601
    Location:
    PL_badwater
    i definitely wont be going back to gigabyte either oh how i miss you DFI and abit
     
  4. Rapidfire48

    Joined:
    Feb 23, 2009
    Messages:
    536 (0.24/day)
    Thanks Received:
    65
    DFI and Abit now they made some quality boards.
     
  5. Arrakis+9

    Arrakis+9

    Joined:
    Aug 10, 2007
    Messages:
    1,538 (0.55/day)
    Thanks Received:
    601
    Location:
    PL_badwater
    i actually still have two abit boards still running strong i LOVE my ix38 quad GT
     
  6. micropage7

    micropage7

    Joined:
    Mar 26, 2010
    Messages:
    6,507 (3.50/day)
    Thanks Received:
    1,557
    Location:
    Jakarta, Indonesia
    but Abit now lost in space :shadedshu
     
  7. Fatal

    Fatal

    Joined:
    Jan 21, 2009
    Messages:
    734 (0.32/day)
    Thanks Received:
    122
    Location:
    Golden, Colorado
    My board has been fine no issues at all. I know they just did a BIOS update for the board that has something to do with the USB.
     
  8. erixx

    erixx

    Joined:
    Mar 24, 2010
    Messages:
    3,609 (1.94/day)
    Thanks Received:
    541
    Nowadays mobo industries just make to many different boards to put a decent ammount of love in them. It is nonstop newer newer newer boards. I have had 1 bad Gigabytes and 2 dead Asus Striker series (with Nv chipset). Shit happens.

    I have no problem at all with my running P5Q Pro and P7P55D Pro boards, yet the corresponding forums at Asus are full of people swearing and sentencing Asus to death because *they* have some issue. If you make 80.000.000 mobos, you cannot inspect every single one before selling it... but some boards have more than average faults (Striker series)
     
  9. Dia01

    Dia01

    Joined:
    Sep 14, 2006
    Messages:
    517 (0.16/day)
    Thanks Received:
    64
    Location:
    QLD, Australia
    I've had the Sabertooth for approximately 2 months now and hasn't missed a beat, might be bad pot luck having such issues.
     
  10. Rado D

    Rado D

    Joined:
    Jun 22, 2010
    Messages:
    496 (0.28/day)
    Thanks Received:
    46
    Location:
    Portsmouth,UK
    You are questioning the whole spectrum x58 boards just because you are having issues with one of the models from specific brand??..

    anyways,I had Asus P6T Deluxe for about 2 years,never had any issues with it.Now I use Rampage III Extreme and love it.Also no issues.
     
  11. carrlos New Member

    Joined:
    May 1, 2011
    Messages:
    1 (0.00/day)
    Thanks Received:
    0
    I installed one X58 and got constant a constant CPU led and memory led. Never worked. Exhanged it for another one and everything worked fine until I plugged in my backup drive. The light came on, then after a few seconds went off. It was never recognized by the USB port. Then I tried my cell phone. Nothing. Now my phone can't charge and isn't recognized by any computer.

    Anyone know why this happens?
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page