1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Samba share inaccessible. clock is not synchronized with DC's clock

Discussion in 'General Software' started by Hybrid_theory, Sep 19, 2012.

  1. Hybrid_theory

    Hybrid_theory New Member

    Joined:
    Mar 31, 2007
    Messages:
    1,895 (0.70/day)
    Thanks Received:
    163
    Location:
    ontario canada
    On an internal network, we use ntp between our servers but they slowly get out of sync with the real time. Most users are running Windows 7, and the domain is on Windows 2008 R2. We have an Ubuntu 9.04 server with some shared folders running samba 3.3.2. When we changed the time to reflect the real time, most users had issues accessing this share. Once they rebooted most were fine.

    The ones that still had issues, I did some googling and found a command: net time /domain:domain.com /set. That fixed most of the users left.

    There's still one user left being unable to access the shared folder (possibly others). The exact error message is: This server's clock is not synchronized with the primary domain controller 's clock.

    I had a look, he has the proper timezone, time is correct, daylight savings time setting is correct. Not sure why else this is failing. Ideas?
  2. 3870x2

    3870x2

    Joined:
    Feb 26, 2008
    Messages:
    4,875 (2.05/day)
    Thanks Received:
    689
    Location:
    Joplin, Mo
    You have probably already tried this but set the time without using NTP.

    Also, is this user using windows 7?

    Another redundant task im sure: make sure Windows Time is on in services.msc and is using the System Account.
    Last edited: Sep 19, 2012
  3. Hybrid_theory

    Hybrid_theory New Member

    Joined:
    Mar 31, 2007
    Messages:
    1,895 (0.70/day)
    Thanks Received:
    163
    Location:
    ontario canada
    He is using Windows 7.

    Just to confirm, set the time manually on the workstation? Haven't tried that actually.
  4. 3870x2

    3870x2

    Joined:
    Feb 26, 2008
    Messages:
    4,875 (2.05/day)
    Thanks Received:
    689
    Location:
    Joplin, Mo
    This will tell us if it is actually the time issue or something else in the authentication process giving some false time error.

    You can also set the time window for kerberos authentication higher temporarily, and see if you are still getting the same error. Last but not least, reboot the file server (not sure how difficult this would be for your establishment. Here we can reboot our CentOS FS pretty quickly, but we are not a very large company.
  5. Hybrid_theory

    Hybrid_theory New Member

    Joined:
    Mar 31, 2007
    Messages:
    1,895 (0.70/day)
    Thanks Received:
    163
    Location:
    ontario canada
    So I sent the user those suggestions. responded with third reboot fixed it.

    ah windows, gotta love it.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page