1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sapphire 4870x2 BIOS? (I need it.)

Discussion in 'AMD / ATI' started by kompulsive, Feb 10, 2009.

  1. kompulsive New Member

    Joined:
    Feb 5, 2009
    Messages:
    96 (0.05/day)
    Thanks Received:
    0
    I am wanting to flash the BIOS on my card to see if it gets rid of the problems I am having. The date on my BIOS, according to CCC, is 9/23/2008. It would be a great help if anyone has a BIOS newer than this that they could provide. If you don't know how to save your BIOS, just download GPU-Z, open it up, and click the button next to "BIOS Version."

    Thanks a million!
  2. kompulsive New Member

    Joined:
    Feb 5, 2009
    Messages:
    96 (0.05/day)
    Thanks Received:
    0
    BUMP! One of you out there with a Sapphire 4870X2 must have a BIOS!
  3. nafets New Member

    Joined:
    Jul 26, 2008
    Messages:
    611 (0.28/day)
    Thanks Received:
    133
    It's highly unlikely you'll find anything newer or better. As I said in the other thread, it doesn't have to be a Sapphire BIOS. It can be from other manufacturers, except Gainward/Palit and Asus, which have a slightly modified HD4870X2, in terms of GPU/MEM clocks and cooling...
    Last edited: Feb 11, 2009
  4. thraxed Guest


    Yeah that would be true but we are talking Sapphire... Just an FYI Sapphire 4870x2 do not use official ati stock bios. So most users would end up making there problems worse for their card if they use any of the bios in your suggestion.
  5. nelson1979 New Member

    Joined:
    Feb 24, 2009
    Messages:
    1 (0.00/day)
    Thanks Received:
    0
  6. kompulsive New Member

    Joined:
    Feb 5, 2009
    Messages:
    96 (0.05/day)
    Thanks Received:
    0
    The 9.2 drivers fixed my problem. Thanks anyway!
  7. Squark

    Squark New Member

    Joined:
    Nov 11, 2008
    Messages:
    36 (0.02/day)
    Thanks Received:
    7
    Location:
    Merry ol' England
    Hey this is what GPU-Z shows for me, I think I could do with a newer BIOS

    [​IMG]

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page