1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sapphire 5970 owners *all is fixed*

Discussion in 'AMD / ATI' started by fullinfusion, Sep 10, 2010.

  1. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,028 (3.36/day)
    Thanks Received:
    1,888
    I was thinking I should put together a small post on the problems us Sapphire 5970 owners have encountered with a fix that involves flashing the gpu's Bios.

    I as many others owe much thanks to True_Gamer from Bit Tech forums for putting all his time and energy with Sapphire informing them all of the problems the 5970 had, and to come up with a fix for all the problems.

    Note, please type in dos ATIFLASH -i before you flash the gpu, that will tell you what gpu is the MASTER and which is the SLAVE. Some gpu's have master as 1 and slave as 0... So please be sure and check before flashing.

    Also it will be faster renaming the files to m.ac1 and
    s.ac1



    Below is the copy from True_Gamer's posting... :respect:




  2. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,028 (3.36/day)
    Thanks Received:
    1,888
    Here is the link that explains everything. LINK
    Cold Storm, scaminatrix and DRDNA say thanks.
  3. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,028 (3.36/day)
    Thanks Received:
    1,888
    Any body?
  4. t_ski

    t_ski Former Staff

    Joined:
    Apr 11, 2006
    Messages:
    10,749 (3.55/day)
    Thanks Received:
    4,194
    Very interested. I will check it out later when I am sober :toast:
    Crunching for Team TPU
  5. t_ski

    t_ski Former Staff

    Joined:
    Apr 11, 2006
    Messages:
    10,749 (3.55/day)
    Thanks Received:
    4,194
    OK, so I sobered up and finally sat down and read through the entire true_gamer thread. I downloaded all the files and flashed both my HIS card and my Sapphire OC. The HIS had been suffering from a cold-bug problem below 29C since installing my EK FC5970 a few months back, and I plan on slapping another FC5970 on the Sapphire. Since the BIOS flash 30-some minutes ago, I have hooked all four San Ace fans back up and had the GPU down as low as 27C without artifacts so far. I need to do a long-term test and some gaming, which I intend to do next. I'll keep you posted.
    grunt_408 and fullinfusion say thanks.
    Crunching for Team TPU
  6. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,028 (3.36/day)
    Thanks Received:
    1,888
    Cool and I doubt your going to have any problems with the new Bios T_ski.

    I been using and testing for 2 weeks now and the only complaint I have is about 2c higher idle temps, but that's minor at the least.

    All I know is I can now run 1000MHz core's + 1300MHz memories with no problem a slight voltage bump didn't fix. Heck before I was lucky to hit 940 1250 with all voltages I tried.

    Any body else give this new Bios a go yet?

    Where the hell is Black Panther? Im sure he's also doing to love the change's that are fixed :D
  7. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,028 (3.36/day)
    Thanks Received:
    1,888
    Dudes! This bios and the new 10.9 ccc seems to be slick as shit!!!!

    I'm loving it. Ill report back after running some marks :rockout:
  8. t_ski

    t_ski Former Staff

    Joined:
    Apr 11, 2006
    Messages:
    10,749 (3.55/day)
    Thanks Received:
    4,194
    Crunching for Team TPU
  9. t_ski

    t_ski Former Staff

    Joined:
    Apr 11, 2006
    Messages:
    10,749 (3.55/day)
    Thanks Received:
    4,194
    The real test of this came this weekend, as I went out of town overnight Friday. I powered this system off before I left and turned it back on this morning, to find my watercooled card idling at 27-28C. Normally, I'd have all kinds of artifacts and lockups at this temp, but with the new BIOS these are gone.

    Thanks again fullinfusion :toast:
    fullinfusion says thanks.
    Crunching for Team TPU
  10. grunt_408

    grunt_408

    Joined:
    Aug 5, 2007
    Messages:
    2,026 (0.79/day)
    Thanks Received:
    485
    Location:
    Australia
    I stumbled accross that the other night. All interesting stuff. Thankyou for sharing.
    fullinfusion says thanks.
  11. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,028 (3.36/day)
    Thanks Received:
    1,888
    Hey glad i could point ya to the Guy that made this all happen. I myself started up my rig after being off all week and the window was left open... The cold killed my favorite plant but besides that I noticed my gpu running @ 10c after start up... No artifact's for me :rockout:
  12. grunt_408

    grunt_408

    Joined:
    Aug 5, 2007
    Messages:
    2,026 (0.79/day)
    Thanks Received:
    485
    Location:
    Australia
    Bios went on mine no problems. The Saphire one.
  13. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,028 (3.36/day)
    Thanks Received:
    1,888
    Stock bios clocks n all?
  14. grunt_408

    grunt_408

    Joined:
    Aug 5, 2007
    Messages:
    2,026 (0.79/day)
    Thanks Received:
    485
    Location:
    Australia
    GPU 735MHz
    Mem 1010MHz
  15. t_ski

    t_ski Former Staff

    Joined:
    Apr 11, 2006
    Messages:
    10,749 (3.55/day)
    Thanks Received:
    4,194
    Craigleberry, you put an OC on that card since you flashed it?
    Crunching for Team TPU
  16. grunt_408

    grunt_408

    Joined:
    Aug 5, 2007
    Messages:
    2,026 (0.79/day)
    Thanks Received:
    485
    Location:
    Australia
    Not yet mate. But give me time :).
  17. t_ski

    t_ski Former Staff

    Joined:
    Apr 11, 2006
    Messages:
    10,749 (3.55/day)
    Thanks Received:
    4,194
    Hoping to try some OC on mine this weekend. Fullinfusion's been bugging me to ;)

    FYI: with the previous BIOS, mine was limited to 940/1300 (same as fullinfusion). He's now getting 1000 on the core while still on air...
    grunt_408 says thanks.
    Crunching for Team TPU
  18. grunt_408

    grunt_408

    Joined:
    Aug 5, 2007
    Messages:
    2,026 (0.79/day)
    Thanks Received:
    485
    Location:
    Australia
    I am just waiting on some tube now then it should all come together. I am hopefull of 1000 on the core on water.
    fullinfusion says thanks.
  19. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,028 (3.36/day)
    Thanks Received:
    1,888
    I run 1000mhZ on air lol. I have hose if ya want bro... The wife says send it to her fellow Aussie :rolleyes:
    grunt_408 says thanks.
  20. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,028 (3.36/day)
    Thanks Received:
    1,888
    BP you found your way yet?

    Im here if you need help flashing
    Black Panther says thanks.
  21. dr emulator (madmax)

    dr emulator (madmax)

    Joined:
    May 5, 2009
    Messages:
    2,241 (1.17/day)
    Thanks Received:
    176
    Location:
    the uk that's all you need to know ;)

    bp's a lady :slap:
  22. pantherx12

    pantherx12 New Member

    Joined:
    Jan 2, 2009
    Messages:
    9,714 (4.78/day)
    Thanks Received:
    1,699
    Location:
    ENGLAND-LAND-LAND
    They could of been muddling us up. The amount of times I get called a woman on this forum :laugh:
  23. Black Panther

    Black Panther Senior Moderatorâ„¢ Staff Member

    Joined:
    May 30, 2007
    Messages:
    8,561 (3.27/day)
    Thanks Received:
    1,916
    Which utility do you suggest using for booting from USB? The link below is dead..


    (And I'm nervous, I've built pc's, overclocked gpu's and cpu's... but never have I flashed a gpu bios!) :eek:
  24. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,028 (3.36/day)
    Thanks Received:
    1,888
    Black Panther is a LADY :eek:

    my bad lol
  25. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,028 (3.36/day)
    Thanks Received:
    1,888
    gimme a sec I have the file saved, where do you want it uploaded to?

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page