1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

screen tearing crysis 2

Discussion in 'Games' started by Marineborn, Mar 25, 2011.

  1. Marineborn

    Marineborn New Member

    Joined:
    Jan 17, 2009
    Messages:
    2,144 (0.99/day)
    Thanks Received:
    312
    hey wasup guys cant seem to figure this one out, got some massive screen tearing in crysis 2 in extreme graphics mode, with vsync one. it gets especially bad wheres there is lots of light, light reflections seem to be causing the problem so it might not be screen tearing but it looks very similar, i have a 32 inch sharp flat screen for a tv, 60hz refresh rate, dont have scren tearing in any other game even the original crysis any ideas would be helpfull thanks guys
     
  2. TheMailMan78

    TheMailMan78 Big Member

    Joined:
    Jun 3, 2007
    Messages:
    21,301 (7.71/day)
    Thanks Received:
    7,782
    Is your TV set to game mode?
     
  3. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,959 (12.98/day)
    Thanks Received:
    14,383
    How many FPS are you getting with vsync off? If it's under 60 fps and Crysis 2 vsync is 60 fps, you're going to have things like stuttering and tearing.
     
  4. Marineborn

    Marineborn New Member

    Joined:
    Jan 17, 2009
    Messages:
    2,144 (0.99/day)
    Thanks Received:
    312
    ive checked with it on and off, ill try game mode but that usually just changes the tints and colors, but its worth a shot
     
  5. TheMailMan78

    TheMailMan78 Big Member

    Joined:
    Jun 3, 2007
    Messages:
    21,301 (7.71/day)
    Thanks Received:
    7,782
    On some TVs it changed the refresh rate.
     
  6. Marineborn

    Marineborn New Member

    Joined:
    Jan 17, 2009
    Messages:
    2,144 (0.99/day)
    Thanks Received:
    312
    game it a shot no go, but goit it to stop flickering with just a stop alteration not even a alteration if anyone has the same problem start playing the game go into option toggle vysnc off then hit apply then when it asks you if you want to keep this option hit no and itll go black and back tot he game and the flicker will be gone *shrugs*


    on another note the game uses maximum of 74% of both gpus of 6870's in crossfire just for some uselesss knowledge thats atleast the peak i hit
     
    Last edited: Mar 25, 2011

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page