1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Setting up a network

Discussion in 'Networking & Security' started by 1Kurgan1, Jun 27, 2009.

  1. 1Kurgan1

    1Kurgan1 The Knife in your Back

    Joined:
    Dec 8, 2008
    Messages:
    10,412 (3.21/day)
    Thanks Received:
    2,410
    Location:
    Duluth, Minnesota
    I am lost when it comes to networking, but I would like to setup one finally. I have my gf's comp and my comp on a Homegroup, but it just seems like a bandaid, not a real fix. Sometimes I can grab files for hers, othertimes it will only let me stream because I don't have permission to grab them and I'm not sure how to get permission.

    The real goal here would be to have the ability to grab any file from my gf's comp and be able to place it on mine, and vice versa, would also be nice to find some way to work the PS3 into this whole deal, I'm not exactly sure what the PS3's abilities to work with computers are, but any help here would be fantastic, as I said, I am lost when it comes to this type of thing.
     
    odameyer says thanks.
  2. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    46,046 (9.67/day)
    Thanks Received:
    13,702
    Location:
    Australalalalalaia.
    homegroups are worthless - its basically an easier way to share to stuff like the xbox 360.


    Remember rule one of networking: if its shared so anyone can get it, that means ANYONE. anyone who jumps on your wireless, any virus from the internet, can go and trash those files.

    All you really need to do is disable password protected file sharing (right click network, poperties - its in there) and then find the folders you want to share. right click and share, but click 'specific people' instead of homegroup.

    Add "everyone" (type it) and set them to read only access. tada, now anyone can READ those files, but not write. this will NOT work with files on your desktop/my documents etc. MS dont allow that anymore.
     
    odameyer and 1Kurgan1 say thanks.
    10 Year Member at TPU
  3. 1Kurgan1

    1Kurgan1 The Knife in your Back

    Joined:
    Dec 8, 2008
    Messages:
    10,412 (3.21/day)
    Thanks Received:
    2,410
    Location:
    Duluth, Minnesota
    I got my wireless off now, like I said lost when it comes to that, I need to figure out how to set the PW, but I don't like wireless so not a huge deal. Is it a big deal to worry about anyone that can get it? I'm really looking to be able to grab files from hers mostly, and hers has nothing on it, since I'm the one with the HDD's, but sometimes I need a few things off there.

    But anyways I just turned off password protection and it still warns me, I'm trying to copy and paste a file from over there, that just does nothing, so I try to even open it and then it says I still don't have permission.

    I'd still really like to have access to everything instead of having to share one item at a time, and would like to figure a way to get the PS3 able to play video and any other thing it's capable of doing with the PC's.
     
    odameyer says thanks.
  4. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    46,046 (9.67/day)
    Thanks Received:
    13,702
    Location:
    Australalalalalaia.
    in order to get permission, you need to add a user to the shares list for that folder.

    Keep in mind for you to add a user name (say, Kurgan) that username must exist on both PC's *and* have the same password on both.

    99% of people who set up network sharing simply set folders as read only (media folders, games etc) and then set up a "dump" folder with full access, so when you want to paste files you do it in there.

    Yes its a big issue with the security, i lost every EXE file on a 400GB drive once due to a nasty virus attacking my network shares from a housemates PC.
     
    odameyer and 1Kurgan1 say thanks.
    10 Year Member at TPU
  5. 1Kurgan1

    1Kurgan1 The Knife in your Back

    Joined:
    Dec 8, 2008
    Messages:
    10,412 (3.21/day)
    Thanks Received:
    2,410
    Location:
    Duluth, Minnesota
    Well I couldn't get it to share with my PC, I put in my PC's name and my username on her comp and it couldn't find either of them. I added Homegroup and set it to read only and then it worked.
     
    odameyer says thanks.
  6. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    46,046 (9.67/day)
    Thanks Received:
    13,702
    Location:
    Australalalalalaia.
    shoot me a PM with your MSN, even if i have to remote desktop, i'll help with this.
     
    odameyer says thanks.
    10 Year Member at TPU
  7. FordGT90Concept

    FordGT90Concept "I go fast!1!11!1!"

    Joined:
    Oct 13, 2008
    Messages:
    20,715 (6.28/day)
    Thanks Received:
    9,834
    Location:
    IA, USA
    I only share the desktop and my documents with full read/write/modify access. Any computer on the network can access those folders with immunity; however, I do not apply this to laptops that may leave my local network. When dealing with laptops, I pull/push the data from/to the desktops that have those directories shared. The bulk of the data is on my server which has user-specific access to directories again with read/write/modify access. No computers, anywhere, have execute permissions over the network (stops a virus cold if it tries to propagate). All computers except my server work on the same workgroup. The server is a DNS.
     
    1Kurgan1 and odameyer say thanks.
    Crunching for Team TPU
  8. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    46,046 (9.67/day)
    Thanks Received:
    13,702
    Location:
    Australalalalalaia.
    desktop and my docs cannot be shared in vista and 7, they locked that down. There is automatically shared "public" folders they put in to replace that functionality.
     
    odameyer says thanks.
    10 Year Member at TPU

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)