1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Setting up Filezilla FTP

Discussion in 'Networking & Security' started by Cybrnook2002, Aug 12, 2008.

  1. Cybrnook2002

    Cybrnook2002

    Joined:
    Nov 3, 2007
    Messages:
    937 (0.36/day)
    Thanks Received:
    146
    Ok, I have the server installed on my pc, and my friend has the client. I have port forwarded on my router for port 21 and for the open port connection range 50000-51000. I have adjusted my AVG firewall to allow apache server services and file sharing. My friend can connect to my pc. I see him on my server list, and I see him connect as passive. But when he pulls the LIST command, he gets an error 405 can get file info. He cant seem to pull my shared directories. He can connect, but cant see any files or folders, even though I have him setup with read permission on 4 directories. Any ideas?
     
  2. DanTheBanjoman SeƱor Moderator

    Joined:
    May 20, 2004
    Messages:
    10,553 (2.73/day)
    Thanks Received:
    1,383
    Does he have a home directory on his account?
     
  3. Flak

    Joined:
    Jul 7, 2008
    Messages:
    403 (0.17/day)
    Thanks Received:
    70
    Location:
    US
    You may also have to setup port 20 on your router to be forwarded to your server.
     
  4. Cybrnook2002

    Cybrnook2002

    Joined:
    Nov 3, 2007
    Messages:
    937 (0.36/day)
    Thanks Received:
    146
    Yeah, my Music folder is his home directory.
     
  5. Cybrnook2002

    Cybrnook2002

    Joined:
    Nov 3, 2007
    Messages:
    937 (0.36/day)
    Thanks Received:
    146
    Already did, 20 and 21
     
  6. Flak

    Joined:
    Jul 7, 2008
    Messages:
    403 (0.17/day)
    Thanks Received:
    70
    Location:
    US
    you opened the range in your router and set it in filezilla server?
     
  7. Cybrnook2002

    Cybrnook2002

    Joined:
    Nov 3, 2007
    Messages:
    937 (0.36/day)
    Thanks Received:
    146
    I set two ranges, 20-21 for FTP in and out. And then 50000-51000 for connection with server.
     
  8. Flak

    Joined:
    Jul 7, 2008
    Messages:
    403 (0.17/day)
    Thanks Received:
    70
    Location:
    US
    the 50000-51000 you are using for pasv? Did you specify that range in filezilla server as well? After that I'm out of ideas, does your isp block ftp ports/traffic? If so try setting up filezilla for ftps, default port for that is 990.

    My current ISP (charter) says they don't block any ports (if that's true they definitely monitor traffic) so I was having your same problem until I setup filezilla for ftps.
    The only other time I've seen that with regular ftp is when port 20 isn't specified and pasv range isn't specified.

    Other then that I'm out of ideas now.
     
    Cybrnook2002 says thanks.
  9. Cybrnook2002

    Cybrnook2002

    Joined:
    Nov 3, 2007
    Messages:
    937 (0.36/day)
    Thanks Received:
    146
    Yeah, I port forwarded my router for those ranges, and in Filezilla server settings I set the range from 50000-51000 also using a dedicated IP, as my ISP gives me a dedicated. It sucks, I mean, I called him and said ok logon. My avg popped up saying "hey, somethings going on" , so i permanently allowed it. He connected, I saw him in the status box, then I saw him go passive. His client called a LIST, then he got nothing, a time out. How do I go FTPS?
     
  10. Cybrnook2002

    Cybrnook2002

    Joined:
    Nov 3, 2007
    Messages:
    937 (0.36/day)
    Thanks Received:
    146
    From my log:

    (000003) 12.08.2008 20:52:28 - (not logged in) (XXX.XXX.91.174)> USER XXXX
    (000003) 12.08.2008 20:52:28 - (not logged in) (XXX.XXX.91.174)> 331 Password required for XXXX
    (000003) 12.08.2008 20:52:28 - (not logged in) (XXX.XXX.91.174)> PASS **********
    (000003) 12.08.2008 20:52:28 - XXXX(XXX.XXX.91.174)> 230 Logged on
    (000003) 12.08.2008 20:52:28 - XXXX (XXX.XXX.91.174)> PWD
    (000003) 12.08.2008 20:52:28 - XXXX (XXX.XXX.91.174)> 257 "/" is current directory.
    (000003) 12.08.2008 20:52:28 - XXXX (XXX.XXX.91.174)> TYPE I
    (000003) 12.08.2008 20:52:28 - XXXX (XXX.XXX.91.174)> 200 Type set to I
    (000003) 12.08.2008 20:52:28 - XXXX (XXX.XXX.91.174)> PASV
    (000003) 12.08.2008 20:52:28 - XXXX (XXX.XXX.91.174)> 227 Entering Passive Mode (XX,XX,XX,XX,195,83)
    (000003) 12.08.2008 20:52:28 - XXXX (XXX.XXX.91.174)> LIST
    (000003) 12.08.2008 20:52:38 - XXXX (XXX.XXX.91.174)> 425 Can't open data connection.
    (000003) 12.08.2008 20:53:15 - XXXX (XXX.XXX.91.174)> disconnected.

    X's represent his IP and his user name. naturally I took them out for security reasons, second set to the right behind "Entering passive mode" was my ip, followed by two more sets of numbers


    EDIT: I just thought of this, But if we are running passive, then his pc also needs two sockets open (Command, and Data). Hes running the same router and AVG firewall as me. I probably should try configuring his router and firewall for port forwarding and allowances , huh?
     
    Last edited: Aug 12, 2008
  11. Flak

    Joined:
    Jul 7, 2008
    Messages:
    403 (0.17/day)
    Thanks Received:
    70
    Location:
    US
    Verify his avg isn't blocking it, he doesn't need to configure anything in his router if he's just connecting to you and downloading.

    FTPS is actually very simple with filezilla, not at home to walk you through it. But if you got this far I'm sure just playing with it you'll figure it out. Hardest part is setting up the generic certificate with filezilla, which is even very easy.

    The 425 can't open data connection is the error I get with my current ISP if I try to run a ftp server through the normal ports (20/21). I tried other ports, I can always connect but can never send a list. So I setup filezilla for ftps and it works great as usual.
     
    Cybrnook2002 says thanks.
  12. Cybrnook2002

    Cybrnook2002

    Joined:
    Nov 3, 2007
    Messages:
    937 (0.36/day)
    Thanks Received:
    146
    Maybe when you get home, through me a few detailed lines. Is it as easy as using the "force ssl" check box?
     
  13. Cybrnook2002

    Cybrnook2002

    Joined:
    Nov 3, 2007
    Messages:
    937 (0.36/day)
    Thanks Received:
    146
    Flak, where are you?????? How do I set up those certificates? :toast:
     
  14. Flak

    Joined:
    Jul 7, 2008
    Messages:
    403 (0.17/day)
    Thanks Received:
    70
    Location:
    US
    In Filezilla Server go to SSL/TLS Settings > Generate new certificate button > Fill out the prevelant information > tell it where to save the key and cert (it's a single file) > slap the generate certificate button

    still under SSL/TLS settings point private key and certificate to the same file, if they didn't automagically fill in after you generated the cert

    I have everything checked, as that seems to keep it working 100% for me with my ISP.

    You can also set the listen port for FTPS, default for me was 990 (at least I don't remember changing it)
     
    Cybrnook2002 says thanks.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page