1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Setup question

Discussion in 'Audio, Video & Home Theater' started by uklawcat, May 5, 2013.

  1. uklawcat New Member

    Joined:
    May 5, 2013
    Messages:
    3 (0.01/day)
    Thanks Received:
    0
    I want to say at the outset that I have just a basic knowledge on this stuff and would appreciate any help given. For years my grandfather had lots of hifi and when he died my mom inherited some of it. When she died I inherited some of her equipment. Presently I have a bunch of mixed parts and would like some advice what to keep, what to get rid of, and what I need if anything.

    Present setup. A 5.0 w Martin Logan sequel ii as fronts, a jbl lc1 center, and jbl l65 as rears.
    The ml's are being powered by mcintosh mc 7150 that has a preout hookup to my receiver which is a Yamaha rx v861 that's 105x 7. Unless I am doing something wrong the ml's won't even play if directly run to my receiver.

    In an attempt to give the system some semblance of uniformity i have ordered a set of jbl 890s to replace the ml's and match my center. They will be here in a couple of days. I considered totally starting over but for a variety of reasons, budget mostly, I have decided to go this route.

    I also inherited an adcom gfa 545 amp and a 555ii pre amp.

    My questions (again apologize for being ignorant but when I tried to read this stuff my head spins)

    1. With the 890s will I need either of the Amps in my setup?
    2. I realize the l65s are not ideal rears and don't match but is there anything necessarily wrong with using them in that capacity if I power them down (they are near mint and are beasts)
    3. This one is tricky but if you understand my present setup ( local audio guy hooked it up) for some reason in surround listening the ml's barely make any sound but very lows, but if I switch to pure direct mode or straight mode they sound great but the center and l65 rears kick off. Again if I run them straight to the receiver I get nothing. Why?
    4. I plan on selling at least the ml's and maybe the amps is eBay the way to go or is there a better vintage specific site?
    5. Is there anything else I need. I know maybe a sub.

    I know this is long and annoyingly/embarrassingly basic for most on this site but if you can help I appreciate it. Thanks in advance
  2. FR@NK

    FR@NK

    Joined:
    Apr 30, 2006
    Messages:
    558 (0.18/day)
    Thanks Received:
    89
    Keep the electrostats, im guessing they arent connected right.

    post some pictures!!!!
  3. uklawcat New Member

    Joined:
    May 5, 2013
    Messages:
    3 (0.01/day)
    Thanks Received:
    0
    See if this works

    Attached Files:

  4. uklawcat New Member

    Joined:
    May 5, 2013
    Messages:
    3 (0.01/day)
    Thanks Received:
    0
    And this one

    Attached Files:

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page