1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sound does not work during bioshock gameplay

Discussion in 'Games' started by Monkey_Business, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. Monkey_Business Guest

    I installed the original bioshock game on my computer, and I noticed that during the actual game play, there is no sound. I can't seem to fix this in the audio settings either. What can I do to solve this problem?

    Bioshock is a great game, but I kind of want to play it with sound....
  2. KingPing

    KingPing

    Joined:
    Aug 17, 2009
    Messages:
    823 (0.45/day)
    Thanks Received:
    273
    Location:
    Argentina (South America)
    your integrated sound is realtek?

    This happens only on bioshock?

    are the speakers set as "default device" in "playback devices"?

    try reinstaling audio drivers
  3. DaedalusHelios

    DaedalusHelios

    Joined:
    Feb 21, 2008
    Messages:
    4,920 (2.07/day)
    Thanks Received:
    812
    Location:
    Greensboro, NC, USA
    I have had the same issue before when one of my DirectX libraries got corrupted. I say install the latest DirectX and anything that got corrupted will be replaced by a perfect copy.
  4. sneekypeet

    sneekypeet Unpaid Babysitter Staff Member

    Joined:
    Apr 12, 2006
    Messages:
    21,526 (7.03/day)
    Thanks Received:
    6,046
    try setting the audio to 2 channel versus say 3.1 or 5.1
  5. 2wicked

    2wicked

    Joined:
    Jul 13, 2008
    Messages:
    261 (0.12/day)
    Thanks Received:
    94
    Location:
    Directly above the center of the Earth
    I had this problem also using realtek sound it only happened when running the game in dx10.
    Try changing directx version in the game menu.
  6. Kursah

    Kursah

    Joined:
    Oct 15, 2006
    Messages:
    7,689 (2.67/day)
    Thanks Received:
    1,611
    Location:
    Missoula, MT, USA
    I had this issue too with onboard years ago...trying to remember what the hell I did. Make sure EAX is not enabled for starters, then as suggested above if that doesn't work try 2ch, try reinstalling DX, etc. I know that onboard realtek supports some EAX features, but iirc in this game it pretty much muted/killed the in-game audio.

    :toast:
  7. Monkey_Business Guest

    If I disable EAX will I be able to play with sound? I have onboard realtek audio, how do I disable EAX, there isn't any option for that in the in-game settings.

    The last time I installed bioshock on my PC, years ago, I could only play it in windowed mode, but with sound. Now I can play it full-screen, but without sound. It seems that this game has nothing but bugs and errors with the PC.

    It was originally a console game.
    Last edited by a moderator: Apr 2, 2010

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Thread Status:
Not open for further replies.

Share This Page