1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sound keeps muting Ubuntu 10.10

Discussion in 'Linux / BSD / Mac OS X' started by $immond$, Oct 21, 2010.

  1. $immond$ New Member

    Joined:
    Nov 30, 2009
    Messages:
    394 (0.20/day)
    Thanks Received:
    22
    Location:
    Edmonton
    I just installed Ubuntu 10.10 and I have updated my system and installed my video drivers however the sound keeps muting especially while watching youtube videos or watching an AVI file.

    The sound icon goes red and it stops working. I have never had this problem with any of the previous Ubuntu distros and I cant seem to fix it. I have tried changing the audio settings under the hardware tab with no success and I have tried finding update for pulse audio with no luck.

    Any help would be greatly appreciated, I really want to give Ubuntu 10.10 a try without having to go back to 8.10 or 9.10 just have sound working.
     
  2. Easy Rhino

    Easy Rhino Linux Advocate

    Joined:
    Nov 13, 2006
    Messages:
    13,752 (4.41/day)
    Thanks Received:
    3,571
    that is strange. have you run alsamixer ?
     
  3. $immond$ New Member

    Joined:
    Nov 30, 2009
    Messages:
    394 (0.20/day)
    Thanks Received:
    22
    Location:
    Edmonton
    Yes I have the sound setting for "Front" is stuck on mute and I cant uncheck it. My sound-card is integrated and listed as Nvidia MCP77/78 HDMI IEC958 and IEC958 PCM are checked.

    Here are my system specs:

    AMD 630 @ 3.4Ghz
    ASUS M3A78-CM
    6Gb DDR2 @ 667mHZ
    3X 500Gb RAID 0
    2900 Pro

    I also have noticed when I the OS boots up fast but when I log in there is a huge delay and my system freezes temporarily I am not sure if it from my RAID array or if my system is trying to load the sound drivers.
     
    Last edited: Oct 22, 2010
  4. Chevalr1c

    Chevalr1c

    Joined:
    Sep 3, 2010
    Messages:
    3,389 (1.96/day)
    Thanks Received:
    1,597
    Location:
    NL, Europe
    Put the sound settings preferably on "analog stereo out", assuming you are using stereo speakers.
     
    Crunching for Team TPU
  5. $immond$ New Member

    Joined:
    Nov 30, 2009
    Messages:
    394 (0.20/day)
    Thanks Received:
    22
    Location:
    Edmonton
    Already have tried that, have also tried setting it to digital out and surround sound 5.1, 5.0, 4.0. 7.1 ect. All options seem to fail.
     
  6. $immond$ New Member

    Joined:
    Nov 30, 2009
    Messages:
    394 (0.20/day)
    Thanks Received:
    22
    Location:
    Edmonton
    /bump

    Am I going to need to buy a sound-card to make this work?
     
  7. Easy Rhino

    Easy Rhino Linux Advocate

    Joined:
    Nov 13, 2006
    Messages:
    13,752 (4.41/day)
    Thanks Received:
    3,571
    i am surprised. your chipset is supported and should work out of the box. there must be something you are missing.
     
  8. $immond$ New Member

    Joined:
    Nov 30, 2009
    Messages:
    394 (0.20/day)
    Thanks Received:
    22
    Location:
    Edmonton
    Well I tried switching from Pulse Audio to OSS and I cant initialize sound at all now. Ugh.. this is so irritating. I am not sure what I am missing I downloaded the ISO directly from the site and I installed all the updates and latest kernal.

    I even followed this: https://help.ubuntu.com/community/OpenSound

    and still I have no sound. :banghead:
     
  9. Chevalr1c

    Chevalr1c

    Joined:
    Sep 3, 2010
    Messages:
    3,389 (1.96/day)
    Thanks Received:
    1,597
    Location:
    NL, Europe
    OSS is a sound driver that is meant for older computers. What you could try is using ALSA, with only "Analogue stereo output" enabled, and any nVidia hdmi stuff disabled. I forgot to empohasize the latter in my previous post (my HD4850 is being recognised as a "HDMI sound card" and got in a sort of conflict with my integrated Realtek ALC sound chip).
    BTW, the VIA VT2020 integrated sound chip is supported according to the ALSA website.
     
    Crunching for Team TPU
  10. $immond$ New Member

    Joined:
    Nov 30, 2009
    Messages:
    394 (0.20/day)
    Thanks Received:
    22
    Location:
    Edmonton
    I have it fixed I had to switch some settings around with the Azalia Soundcard in the bios, everything works fine. :) :nutkick:

    ALL FIXED!
     
  11. Chevalr1c

    Chevalr1c

    Joined:
    Sep 3, 2010
    Messages:
    3,389 (1.96/day)
    Thanks Received:
    1,597
    Location:
    NL, Europe
    Good :)
     
    Crunching for Team TPU

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page