1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Soundblaster XFI Elite Breakout Box not working.

Discussion in 'General Hardware' started by columboid, Dec 25, 2010.

  1. columboid New Member

    Joined:
    Dec 3, 2010
    Messages:
    27 (0.02/day)
    Thanks Received:
    1
    Hello,

    I've just reinstalled my XFI Elite and its breakout box on 64 bit Windows 7.
    It's working fine apart from the breakout box is dead.
    I've uninstalled and reinstalled the driver, the floppy disk power connector is connected to the back of the card.
    Is there anything you have to do to activate/enable it or does anyone have any other suggestions.

    Cheers all
    Happy Christmas.
    C
     
  2. micropage7

    micropage7

    Joined:
    Mar 26, 2010
    Messages:
    6,603 (3.49/day)
    Thanks Received:
    1,582
    Location:
    Jakarta, Indonesia
    if you use add on soundcard you need to disable onboard sound, read the manual book of your motherboard, some just thru bios but the other by jumper
    if its right after booting the system will find new hardware and try to locate the driver
    make sure the driver run on your OS or update the driver from its official web

    if it undetected try to clean the contact area and the slot or slot in on other slot

    hope it works
     
  3. columboid New Member

    Joined:
    Dec 3, 2010
    Messages:
    27 (0.02/day)
    Thanks Received:
    1
    Thanks for your help.
    What it was was that there is a bit of plastic the seperates the pins of the floppy disk power connection at the end of the PCB (part of the sound card). It had slid forward and was not allowing the power connector to attatch fully.
    I just pushed the plastic bit all the way back and then put the connector on and it worked.
    Happy days.
    Cheers
    C
     
  4. micropage7

    micropage7

    Joined:
    Mar 26, 2010
    Messages:
    6,603 (3.49/day)
    Thanks Received:
    1,582
    Location:
    Jakarta, Indonesia
    i guess its coz something or setting
    thats nice you got it works:toast::toast:
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page