1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

The "MailBox" is dead. AKA my computer.

Discussion in 'General Hardware' started by TheMailMan78, Oct 14, 2009.

  1. Wile E

    Wile E Power User

    Joined:
    Oct 1, 2006
    Messages:
    24,324 (8.36/day)
    Thanks Received:
    3,778
    Didn't know you lost your job. That sucks balls man. I know what you mean about this month sucking tho. My furnace is broken, dryer broke, washer is on the way out, and somebody slashed my tires all in the past month.
     
  2. TheMailMan78

    TheMailMan78 Big Member

    Joined:
    Jun 3, 2007
    Messages:
    20,996 (7.88/day)
    Thanks Received:
    7,543
    Yeah no keyboard :laugh:

    Yeah Im working two jobs now to keep my girls in school. The LAST thing I needed is my computer to die. Im out of funds to do anything more to fix it. My only hope now is if the local store has one in stock I can pull the old switcharoo on. If not Erockers going to help me out if he can. I love TPU.
     
  3. pantherx12

    pantherx12 New Member

    Joined:
    Jan 2, 2009
    Messages:
    9,714 (4.66/day)
    Thanks Received:
    1,699
    Location:
    ENGLAND-LAND-LAND
    And I'm guessing the keyboard is in?

    D:

    Gawwd, this is going to be one of those tricky ones ha ha
     
  4. timta2

    Joined:
    Jan 16, 2008
    Messages:
    816 (0.33/day)
    Thanks Received:
    114
    Location:
    Milwaukee, Wisconsin, USA
    The "old switcheroo" is a crime called "Retail Fraud". You wouldn't want to add spending some time in the county lockup to your crappy month would ya? I hope you get it resolved and I know how you feel, there are a lot of us hurting right now.
     
  5. shevanel

    shevanel New Member

    Joined:
    Jul 27, 2009
    Messages:
    3,479 (1.85/day)
    Thanks Received:
    406
    Location:
    Leesburg, FL
    i smell bacon.
     
  6. <<Onafets>>

    <<Onafets>>

    Joined:
    Nov 8, 2008
    Messages:
    779 (0.36/day)
    Thanks Received:
    77
    Location:
    Sydney, Australia
    Did ye press teh pwr buttn with a bananananana?

    Sorry I had to...could something on you're HDD corrupted the BIOS on both boards like mine did?
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page