1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Turion64 x2 Clocks Down - Games Lag

Discussion in 'Overclocking & Cooling' started by hoax32, May 25, 2011.

  1. hoax32

    hoax32

    Joined:
    Aug 8, 2010
    Messages:
    489 (0.32/day)
    Thanks Received:
    48
    Location:
    TX
    Hi guys!
    My turion64 x2 1.90GHz has the AMD POWER NOW - feature, which clocks down the CPU when its not needed.
    And sometimes (actually often) when I play CoD or GTA, the CPU clocks down to 797MHz!!!! That makes it lag as #$%@ !!!! O_O
    IDK why it does that!!!

    I uninstalled the CPU drivers and now all works fine, but my battery pack lasts over %40 shorter now! :/

    Any idea, how to keep the "AMD Auto clocking" function on without any under clocking and lag in games?

    I appreciate any help!
    Thanks guys! :toast:
     
  2. 95Viper

    95Viper

    Joined:
    Oct 12, 2008
    Messages:
    4,415 (2.01/day)
    Thanks Received:
    1,614
    Location:
    στο άλφα έως ωμέγα
    You don't say which OS, but... have you tried going to your power option > advanced options > processor power management and set your min % and max %.

    I believe you should, also, have a tab or two in the power options panel to control the AMD PowerNow features...

    I don't believe the laptop has the options to dis-able it in the bios. I could be wrong.
     
    Last edited: May 25, 2011
    hoax32 says thanks.
  3. hoax32

    hoax32

    Joined:
    Aug 8, 2010
    Messages:
    489 (0.32/day)
    Thanks Received:
    48
    Location:
    TX
    Thanks ffor the rep forst of all!
    I use XP Prof SP3 all patched

    I cant find that power option!
    If I remember right, that was only under Vista and 7.
     
  4. 95Viper

    95Viper

    Joined:
    Oct 12, 2008
    Messages:
    4,415 (2.01/day)
    Thanks Received:
    1,614
    Location:
    στο άλφα έως ωμέγα
    Quote from AMD PowerNow!™ Technology:

    Enabling PowerNow!™

    Check whether the PowerNow!™ software is installed and enabled by going to Power Options under the Control Panel. If there is a PowerNow!™ section, then AMD PowerNow!™ Software is installed. Use the PowerNow!™ section to set your PowerNow!™ settings.

    Windows XP:

    AMD PowerNow!™ support is included with Windows XP. This means that under Windows XP the AMD PowerNow!™ Software should not be installed.

    IMPORTANT: As of the current release of Windows XP, you must go to http://www.windowsupdate.com and download the latest processor driver to enable PowerNow!.
     
    hoax32 says thanks.
  5. hoax32

    hoax32

    Joined:
    Aug 8, 2010
    Messages:
    489 (0.32/day)
    Thanks Received:
    48
    Location:
    TX
  6. OneMoar

    OneMoar

    Joined:
    Apr 9, 2010
    Messages:
    3,579 (2.16/day)
    Thanks Received:
    1,048
    Location:
    Rochester area
    overheating
     
    hoax32 says thanks.
  7. hoax32

    hoax32

    Joined:
    Aug 8, 2010
    Messages:
    489 (0.32/day)
    Thanks Received:
    48
    Location:
    TX
    You shure!?
    My temps hit 50C max! (after some hard core gaming) Igle is like 40C
    I disted and added silver thermal grease only a week ago! :/
     
  8. OneMoar

    OneMoar

    Joined:
    Apr 9, 2010
    Messages:
    3,579 (2.16/day)
    Thanks Received:
    1,048
    Location:
    Rochester area
    err take that back

    goto the power options and change from laptop/battery to desktop see if that solves it
     
    hoax32 says thanks.
  9. hoax32

    hoax32

    Joined:
    Aug 8, 2010
    Messages:
    489 (0.32/day)
    Thanks Received:
    48
    Location:
    TX
    Hey thanks!!!! :D
    Although ill have to go to the control panel and change the power option every time i play, its still better than lag! xD

    I really appreciate it!!!!
    I usually go into the bios and disable AMD power Now! but its always a pain in the a+s+s!
    Thanks mate! :toast:
     
  10. The Von Matrices

    The Von Matrices

    Joined:
    Dec 16, 2010
    Messages:
    1,336 (0.95/day)
    Thanks Received:
    441
    Could this have something to do with battery current limitations? Does it occur when plugged in or only when on battery power?
     
  11. hoax32

    hoax32

    Joined:
    Aug 8, 2010
    Messages:
    489 (0.32/day)
    Thanks Received:
    48
    Location:
    TX
    Bad news......<:^(
    The CPU still clocks down after 10 minutes gaming! :(
    idk why?
    Maybee the laptop is getting hot..... :confused: But how can 50C be too hot for a AMD?
    And about the battery:
    The laptop is always plugged in when i play games.
     
  12. Chevalr1c

    Chevalr1c

    Joined:
    Sep 3, 2010
    Messages:
    3,244 (2.15/day)
    Thanks Received:
    1,424
    Location:
    NL, Europe
    Plugged in with the battery removed I suppose? You should really do that because
    1) the massive and rapid chain of charging/discharging is not very healthy for the battery
    2) what The Von Matrices said
     
    Crunching for Team TPU
  13. hoax32

    hoax32

    Joined:
    Aug 8, 2010
    Messages:
    489 (0.32/day)
    Thanks Received:
    48
    Location:
    TX
    I dont really care about the battery health, since i still have 2 more spare batery packs NEW sealed in my closet! :rolleyes:

    Do you yhink, that remooving the battery will help? :/
     
  14. Chevalr1c

    Chevalr1c

    Joined:
    Sep 3, 2010
    Messages:
    3,244 (2.15/day)
    Thanks Received:
    1,424
    Location:
    NL, Europe
    It might.
     
    hoax32 says thanks.
    Crunching for Team TPU
  15. hoax32

    hoax32

    Joined:
    Aug 8, 2010
    Messages:
    489 (0.32/day)
    Thanks Received:
    48
    Location:
    TX
    OK! Will try!!!
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page