1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Ubuntu + MX 420 = 640x480 res (with the restricted drivers enabled!)

Discussion in 'Linux / BSD / Mac OS X' started by Error 404, Nov 7, 2008.

  1. Error 404

    Error 404 New Member

    Joined:
    Apr 14, 2008
    Messages:
    1,777 (0.78/day)
    Thanks Received:
    169
    Location:
    South Australia
    Well, my friend wanted his PCI FX 5200 back, so I had to put the MX 420 back into my Dell.
    It booted into 640x480, so I installed the restricted drivers.
    It installed fine, but no luck, its still stuck at 640x480.
    Does anyone know a way to force ubuntu to recognize that I have a 1440x900 display plugged in?
  2. DIBL New Member

    Joined:
    Nov 17, 2006
    Messages:
    126 (0.05/day)
    Thanks Received:
    12
    Location:
    Dayton, Ohio area
    No guarantees for that old card, but I would get out of X (i.e. Ctrl-Alt-F1 to a tty console and log in there), shut down the X server with
    Code:
    sudo /etc/init.d/gdm stop
    and then use the Nvidia X configuration utility to write a new xorg.conf file

    Code:
    sudo nvidia-xconfig
    Then try a startx and see what you get. If you get a decent screen but the wrong resolution, you can run
    Code:
    gksudo nvidia-settings
    and change the resolution. Sometimes running "detect displays" helps too -- then click the "Save to X Configuration File" button and save it.
  3. Error 404

    Error 404 New Member

    Joined:
    Apr 14, 2008
    Messages:
    1,777 (0.78/day)
    Thanks Received:
    169
    Location:
    South Australia
    I've created the second file, but "gksudo nvidia-settings" does not allow me to edit it. I've tried it in the terminal with X-window operating, and then in the Ctrl+Alt+F1 terminal. I got this response:
    Code:
    (gksodu:7520): Gtk-WARNING **: cannot open display:
    
    Would I be able to edit the file with the text editor?

    UPDATE:

    Never mind, I accidentally stumbled on the solution!
    Using the "sudo shutdown" command, I shut down the computer from terminal mode. It shut down to some sort of menu, and one of the options was "Fix xwindow" or something similar. I chose that, and it re-detected my hardware and monitor.
    Its working fine!
  4. DIBL New Member

    Joined:
    Nov 17, 2006
    Messages:
    126 (0.05/day)
    Thanks Received:
    12
    Location:
    Dayton, Ohio area
    Cool. It's using the "nv" driver, which is fine for that card. Just don't waste your time trying to run 3D stuff like Compiz, and it will do just fine. :)

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page