1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Unable to disable subtitles in Windows Media Player

Discussion in 'General Software' started by Mr McC, Aug 9, 2010.

  1. Mr McC

    Mr McC

    Joined:
    Apr 12, 2010
    Messages:
    1,253 (0.66/day)
    Thanks Received:
    326
    Hi folks,

    I rented Shutter Island last night and was unable to disable the subtitles in Windows Media Player. Is this something to do with regional playback protection? Does anybody have a workaround to fix this issue?

    Thanks in advance.
     
  2. hat

    hat Enthusiast

    Joined:
    Nov 20, 2006
    Messages:
    17,203 (5.46/day)
    Thanks Received:
    2,199
    Location:
    Ohio
    Try reinstalling your codec.
     
    Crunching for Team TPU
  3. Mr McC

    Mr McC

    Joined:
    Apr 12, 2010
    Messages:
    1,253 (0.66/day)
    Thanks Received:
    326
    I have no additional codecs installed: I only use WMP for DVD's and KMPlayer for everything else, and up to this point I have experienced no problems. I assume that I could tell KMPlayer to used the Windows DVD codecs, but if there is a way to fix this issue within WMP, I would prefer that and I would prefer not to install any third-party codecs.

    I should add that when I watch the film in Spanish, no subtitles are displayed, it is only when I change the language to English that I am unable to deactivate subtitles.
     
  4. twilyth Guest

    I don't know what the laws are where you are, but a dvd ripper (like AnyDVD by Slysoft) should remove any region restrictions. That would technically be illegal in the US so I'm not advising you do this, it's just FYI.
     
  5. Mr McC

    Mr McC

    Joined:
    Apr 12, 2010
    Messages:
    1,253 (0.66/day)
    Thanks Received:
    326
    I'm in Spain, so there is no problem there. However, I'm trying to avoid installing any additional third-party software or codecs and I'm hoping that there is a way to configure Windows Media Player. It is ridiculous that I am unable to play an original DVD without subtitles in the latest version of Microsoft's Media Player.
     
  6. naoan New Member

    Joined:
    Jul 12, 2009
    Messages:
    304 (0.14/day)
    Thanks Received:
    62
    sorry if this sound stupid but have you disabled subtitle inside the dvd menu?
     
  7. Mr McC

    Mr McC

    Joined:
    Apr 12, 2010
    Messages:
    1,253 (0.66/day)
    Thanks Received:
    326
    No offence taken: yes I have tried to disable, the subtitles simply remain.
     
  8. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    15,475 (3.80/day)
    Thanks Received:
    12,832
    maybe the subtitles are part of the movie ? are they rendered at desktop resolution or at movie resolution?
     
  9. Mr McC

    Mr McC

    Joined:
    Apr 12, 2010
    Messages:
    1,253 (0.66/day)
    Thanks Received:
    326
    Are you saying that on the DVD released for the Spanish market they are forcing users to display subtitles when English is chosen as the language? I hope that is not the case.


    The subtitles are poorly rendered, it looks like the font is oversized.
     
  10. Tatty_One

    Tatty_One Senior Moderator Staff Member

    Joined:
    Jan 18, 2006
    Messages:
    17,516 (5.07/day)
    Thanks Received:
    3,290
    Location:
    Worcestershire, UK
    Is there not an icon on the taskbar that you can right click to disable subtitles? I assume you have also tried "Ctrl > Shift > C"
     
  11. Mr McC

    Mr McC

    Joined:
    Apr 12, 2010
    Messages:
    1,253 (0.66/day)
    Thanks Received:
    326
    I'll try the icon later on, yes, I tried Ctrl + Shift + C.
     
  12. WhiteLotus

    WhiteLotus

    Joined:
    Jul 30, 2007
    Messages:
    6,566 (2.27/day)
    Thanks Received:
    862
    Yea sounds like the subs are part of the movie. Shame, good film.
     
  13. slyfox2151

    slyfox2151

    Joined:
    Jan 14, 2009
    Messages:
    2,620 (1.11/day)
    Thanks Received:
    526
    Location:
    Brisbane, Australia
    if u want to be certain if the subtitles can be disabled...

    download and install VLC, run the dvd and start the movie. then click "Video", Subtitles and then hit disable... if there still there then they are HARD CODED into the movie and cannot easily be removed. (removing them is difficalt and will resualt in blurry patches where they used to be in the movie.)
     
  14. Mr McC

    Mr McC

    Joined:
    Apr 12, 2010
    Messages:
    1,253 (0.66/day)
    Thanks Received:
    326
    I downloaded VLC and the issue repeats: no subtitles in Spanish, but some genius has embedded the subtitles when the original English version is selected.

    It was a very good film WhiteLotus, and undoubtedly better without those damn subtitles, but the entire plot seems to be taken directly from The Ninth Configuration.

    Thanks for helping me get to the bottom of this.
     
  15. twilyth Guest

    I don't understand. How can they be hardcoded if they don't always show up? I thought hard-coded in this context meant that the subtitles are actually a part of each frame of the movie as opposed to merely being overlaid during playback.
     
  16. Mr McC

    Mr McC

    Joined:
    Apr 12, 2010
    Messages:
    1,253 (0.66/day)
    Thanks Received:
    326
    I have no idea either: in Spanish, no subtitles appear, change to English and the subtitles are always on and given that I have tried to deactivate them in 3 different media players, the logical conclusion is that a certain Einstein decided that Spanish audiences simply shouldn't be given the choice of viewing in English without subtitles.
     
  17. It sounds like the moron who did that is racist :banghead:
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page