1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Unable to update Mint 15

Discussion in 'Linux / BSD / Mac OS X' started by thebluebumblebee, Jul 23, 2014.

  1. thebluebumblebee

    thebluebumblebee

    Joined:
    Jul 2, 2008
    Messages:
    3,105 (1.35/day)
    Thanks Received:
    1,629
    Here's what I get:
    Specific error example:
    Is this because the update server is down or because this is version 15 and support has ended?
     
    Last edited: Jul 23, 2014
    Crunching for Team TPU
  2. Chevalr1c

    Chevalr1c

    Joined:
    Sep 3, 2010
    Messages:
    3,246 (2.15/day)
    Thanks Received:
    1,424
    Location:
    NL, Europe
    I think the latter, but I am not sure. It is time nonetheless for Mint to use their own frigging repos.

    Anyway, did you run
    Code:
    sudo apt-get update
    in the terminal?
     
    thebluebumblebee says thanks.
    Crunching for Team TPU
  3. thebluebumblebee

    thebluebumblebee

    Joined:
    Jul 2, 2008
    Messages:
    3,105 (1.35/day)
    Thanks Received:
    1,629
    Yes, but that generated a lot of errors. Basically the same errors as in the OP.
    I installed 17.
     
    Chevalr1c says thanks.
    Crunching for Team TPU
  4. Jstn7477

    Jstn7477

    Joined:
    Aug 30, 2009
    Messages:
    3,881 (2.06/day)
    Thanks Received:
    1,560
    Location:
    Sarasota, Florida, USA
    I think the older Ubuntu repositories must be offline, as I have the same issue with an Ubuntu 13.04 machine.
     
    Chevalr1c says thanks.
    Crunching for Team TPU More than 25k PPD
  5. Frick

    Frick Fishfaced Nincompoop

    Joined:
    Feb 27, 2006
    Messages:
    10,789 (3.41/day)
    Thanks Received:
    2,345
    This is what is most annoying with Linux, or if it's just *buntu. The new updates can be applied to your current system as well, but everything is moved to a new repository so you have to add that rep manually.
     
  6. blobster21

    blobster21

    Joined:
    Oct 24, 2004
    Messages:
    326 (0.09/day)
    Thanks Received:
    81
    Location:
    Vandoeuvre - France
    Just as Frick said, since Ubuntu 13.04 and derivative distros are no longer supported, you have to edit your sources.list manually, quote the former lines, and add the following instead :

    Code:
    ## Updated repositories list for Ubuntu 13.04 "Raring Ringtail" and/or Mint 15 "Olivia"
    deb http://old-releases.ubuntu.com/ubuntu/dists/ raring main restricted universe multiverse
    deb http://old-releases.ubuntu.com/ubuntu/dists/ raring-updates main restricted universe multiverse
    deb http://old-releases.ubuntu.com/ubuntu/dists/ raring-backports main restricted universe multiverse
    deb http://old-releases.ubuntu.com/ubuntu/dists/ raring-proposed main restricted universe multiverse
    deb http://old-releases.ubuntu.com/ubuntu/dists/ raring-security main restricted universe multiverse
    
    ## The following repository is specific to Linux Mint 15 and should be
    ## uncommented if needed. The path didn't change and should be good to go.
    # deb http://packages.linuxmint.com/ olivia main upstream import
    
    ## Enabling Canonical Partner repository give you access to more
    ## programs and features that are not available by default.
    ##
    ## Though the path is correct, updating this repository may not work properly in 2014.
    deb http://archive.canonical.com/ubuntu/ pool partner
    
    ## The following repository is not part of Ubuntu, it was offered by third-party
    ## developers who wanted to ship their latest software.
    ## It's been discarded when 13.04 reached end-of-life and must
    ## be commented to avoid unecessary 404 errors when updating repos
    #   deb http://extras.ubuntu.com/ubuntu/ raring main
     
    Last edited: Jul 25, 2014
    Jstn7477 and thebluebumblebee say thanks.
  7. Jstn7477

    Jstn7477

    Joined:
    Aug 30, 2009
    Messages:
    3,881 (2.06/day)
    Thanks Received:
    1,560
    Location:
    Sarasota, Florida, USA
    Thanks, I may use these sources on my Mint 15 machines too unless I choose to upgrade.
     
    Crunching for Team TPU More than 25k PPD
  8. Chevalr1c

    Chevalr1c

    Joined:
    Sep 3, 2010
    Messages:
    3,246 (2.15/day)
    Thanks Received:
    1,424
    Location:
    NL, Europe
    It is only an issue on distros that do not have a rolling release system.
     
    Crunching for Team TPU

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page