1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

What's your history with GPUs? Which one have you owned?

Discussion in 'Graphics Cards' started by _33, Aug 27, 2006.

  1. _33

    _33 New Member

    Joined:
    Mar 25, 2006
    Messages:
    1,248 (0.41/day)
    Thanks Received:
    31
    Location:
    Quebec
    Hi all! I was wondering which GPU / graphics card everyone here had in their past, including the one they are using today. I think in the field of computer science, that the field of graphics chips really took off more than everything else in the last few years, as newer graphics cards come out, we all go in the "oldies" bin eventually.

    So here goes:

    1990 - ATI 512K VGA graphics adapter (on 286 12mhz system)
    1997 - ATI Rage 2+ with 4MB (on Pentium MMX 200 system)
    2001 - Nvidia Geforce 200MX 32MB GDDR (on AMD K7 1.2ghz)
    2002 - ATI Radeon 8500LE 64MB GDDR (on AMD XP 1800+)
    2006 - ATI X800GTO2 DUAL DVI VIVO 256MB GDDR3 (on AMD 64 3000+)
    2007(?)ATI X1950XTX 512MB GDDR4 (on AMD X2 or Opteron :p )

    :D

    As you can see, I never went for "top of the line". But maybe I'll change that next year, who knows!

    EDIT: I just want to add that in 2001, if I have bought the Geforce 3 TI model of that time, I would probably have never switched card in 2002. Thoe, my old 8500LE @ 270/285 was a pretty decent card, yet missed an extra 64MB. The Rage 2+ sucked and didn't have a lot of support. Only the Rage Pro was a half decent card, but came out only few months after I bought the 2+ and was a little mad about the ATI folks.
    Last edited: Aug 27, 2006
  2. Alec§taar New Member

    Joined:
    May 15, 2006
    Messages:
    4,677 (1.54/day)
    Thanks Received:
    94
    Location:
    Someone who's going to find NewTekie1 and teach hi
    Ah, ok... here we go:

    486 era, ISA bus on mobos:
    ========================================


    • 1991-1992: Trident 256k SVGA (486 Sx/25 - 486 Dx/4 133mhz I upgraded it to)
    • 1992-1993: Diamond Stealth 24 ISA 1mb Windows Accelerator card (486 Sx/25 - 486 Dx/4 133mhz I upgraded it to)

    486 era, VLB bus on mobos:
    ========================================


    • 1993-1994: Diamond SpeedStar VLB 2mb Windows Accelerator card (486 Sx/25 - 486 Dx/4 133mhz I have now as a replica of one I had then, too, circa that period, & runs Windows NT 3.51 here now still even, pretty well too mind you)

    Pentium I/II era, PCI bus on mobos:
    ========================================


    • 1996-1997: Voodoo I (Pentium I)
    • 1997-1998: Voodoo II(Pentium I (duallie/SMP))
    • 1998-1999: Voodoo III(Pentium I 200mmx (duallie/SMP))
    • 1999-2000: Voodoo V 5500 (Pentium I 233mmx (duallie/SMP))

    AMD first era for me, PCI bus on mobos:
    ========================================


    • 1998-1999: GeForce III (on AMD K6-III @450mhz iirc because Voodoo V 5500 was "funny" on its "Super-7" mobo (L1-L2-L3 cache design, cool, like Pentium Pro was))

    Pentium III/IV era, PCI - AGP bus on mobos:
    ========================================


    • 2002-2003: GeForce IV (Dual Pentium III 1ghz SMP rig I had w/ AGP on it)

    • 2003-2005: ATI 9800 XT (AGP same machine as below)

    • 2004-2005: GeForce 6800 GT OC AGP (currently in machine #2 here P4 3.2ghz)

    AMD second era for me - PCI-e bus current mobo:
    ========================================


    • 2006- current: GeForce 7900 GTX OC PCI-Express.

    :)

    APK

    P.S.=> For most part? SHOULD BE ACCURATE, on dates @ least & cards used I can remember & machines they were in... hardest part for me to recall is some of the bustypes used, especially around 21st start (PCI/AGP transition)... apk
    Last edited: Aug 27, 2006
  3. giorgos th.

    giorgos th. New Member

    Joined:
    Nov 10, 2005
    Messages:
    1,543 (0.48/day)
    Thanks Received:
    117
    Location:
    Athens - Hellas
    Asus FX5200
    Albatron 6600GT
    Sapphire X800GTO2 @ X850XT PE
    XFX 7900GT Extreme Edition.
  4. DanTheBanjoman Señor Moderator

    Joined:
    May 20, 2004
    Messages:
    10,553 (2.81/day)
    Thanks Received:
    1,383
    I've used various crap cards in my 386 (before that everything was onboard), some wang card with 512K (could be 259K, not sure) I've had trident cards due to VESA support needed eventually. When I went up I've had a real Weitek 9000 (still have it lying around) also known as the Viper PCI, I've had some S3 chips and my first real 3D chip was a Voodoo Banshee, which I later swapped for an AGP version when I get my P2.
    After that I've had a Kyro a 9500 and now a 6800le. When I upgrade in a few months I'll get something new, not sure what yet.
  5. Frick

    Frick Fishfaced Nincompoop

    Joined:
    Feb 27, 2006
    Messages:
    10,514 (3.38/day)
    Thanks Received:
    2,160
    I've ALWAYS been slow on upgrades and I ALWAYS buy cheap things. No high-end for me. ;) That's mainly because I'm not a hardcore gamer (I tend to buy games 2 years after the realease, when the low-price-versions are released :)) and I mostly use it to write.

    The first card I bought was a Voodoo for my PII 266Mhz-system. I used that and tinkered with until everything got crazy and I got, for free, a bunch of various of 440BX-motherboards and several PII/PIII/Celeron CPU's. I bought a TNT2 M64 from a friend of mine and used that with an PIII 400Mhz OC'd to 600Mhz.:wtf: Abit BE6 owned teh world. :D

    I used that system for a while until I bought a Radeon 9000. A year later I bought an ABIT Nf7-s 2.0, AXP 2500+ and 512MB's of RAM and in 2004, I think, I bought a Radeon 9600PRO. Januari 2006 it was time for the card I have now.

    The system I have now is probably the most "recent" system I've ever had. I like it. There's nothing bottlenecking it and everything I use the computer for runs extremely well. It feels very good. :D I might buy a DX10 mid-card, but I don't know.. It depends on the price/performance ratio.
  6. HookeyStreet

    HookeyStreet Eat, sleep, game!

    Joined:
    Aug 29, 2004
    Messages:
    7,136 (1.95/day)
    Thanks Received:
    523
    Location:
    Great Yarmouth, England
    nVIDIA GeFORCE MX440 :cry:
    Jetway GeFORCE 5200 (128mb) :roll:
    ATi Radeon 9800 Pro (128mb) :)
    Club3D GeFORCE 6800GT (256mb) ;)
    ASUS X850XT (256mb) :cool:
    Sapphire X1800XT (256mb) :rockout:
  7. cadaveca

    cadaveca My name is Dave

    Joined:
    Apr 10, 2006
    Messages:
    13,867 (4.53/day)
    Thanks Received:
    6,944
    Location:
    Edmonton, Alberta
    S3 Virge
    Voodoo3
    MX440, MX4000, 7800GTX x2
    ATI Rage, Rage Pro, 9000, 9200, 9600, 9600Pro, 9700, 9800SE, 9800PRO, 9800XT, X800Pro, X800XT, X850XT x3, X850XT PE x2, X1800XL, X1800XT, X1900XT, X1900XTX, X1900Crossfire.
  8. Anarion New Member

    Joined:
    May 24, 2005
    Messages:
    485 (0.14/day)
    Thanks Received:
    0

    do you have any built-in memory chip or else , whatever....
  9. Anarion New Member

    Joined:
    May 24, 2005
    Messages:
    485 (0.14/day)
    Thanks Received:
    0
    hereicome;)

    ----

    Trident

    3DImage 9750 PCI/AGP (4mb)
    Cyber9386 Video Accelerator (!?)
    ProVIDIA 9685 (2mb to 4 mb)
    TGUI9680 GUI Accelerator (2mb to 4mb)
    TGUI9440 DGi GUI Accelerator (512kb)
    TGUI9682 Multimedia Accelerator (2mb)

    ----

    SiS(IGP)

    SiS300/SiS305 GUI Accelerator+3D (OEM Yuan Yuan )
    SiS 630

    ----

    nVIDIA

    NV5 TNT2/ Pro
    NVM64 TNT2 Model 64/ Pro

    NV10 GeForce 256

    NV11 GeForce 2 MX 400
    NV15 DDR GeForce2

    NV17 GeForce 4 MX 460
    NV17GL Quadro 4 550 XGL

    NV25 GeForce 4 Ti 4200

    NV34 GeForce FX 5200

    NV40 GeForce 6800 GT
    NV40 GeForce 6800 Ultra
    NV40/BR02 Quadro FX 4000

    ----

    3Dfx InterActive

    Voodoo Banshee PCI SGRAM Velocity 100
    OEM Diamond Multimedia Systems : Monster Fusion
    OEM Quantum 3D Inc Raven PCI

    ----

    S3

    86C240 ViRGE/MXC
    86C260 ViRGE/M3/MX
    86C260 ViRGE/M5/MX
    86C359 ViRGE/GX2+
    86C365 Trio3D
    86C765 Trio64V+
    86C988 ViRGE/VX
    TrioV Family 8903

    + An Unkown (IGP) (Can't Remember)
    ----

    ATI

    RV350AQ Radeon 9600 SE
    OEM Giga-Byte Technology Giga-Byte GV-R96128D Primary

    ----

    VIA (IGP)

    S3/VIA UniChrome pro
  10. cjoyce1980 New Member

    Joined:
    Apr 8, 2006
    Messages:
    715 (0.23/day)
    Thanks Received:
    11
    some S3 4mb card
    voodoo 2
    geforce 4mx
    ATI 9250
    ATI x1600 currently in lan rig
    6800LE in the pc im using now
  11. g12rxz New Member

    Joined:
    Apr 9, 2006
    Messages:
    293 (0.10/day)
    Thanks Received:
    0
    Location:
    Illinois
    hmm.. can't even remember what the first was... some 64 meg thing that fit in my PCI slots, was the first form of "SLI" I believe... was running in my 633mhz celeron at the time :p.

    BFG 5600256mb
    ASUS 5700256mb
    BBA X700Pro AGP
    BBA X700Pro PCI-E
    C3D X800GTO PCI-E ( currently own this, and I don't especially miss the 1800 or 1900)
    C3D X1800GTO
    HIS X1900GT
  12. trog100 New Member

    Joined:
    Dec 18, 2005
    Messages:
    4,420 (1.39/day)
    Thanks Received:
    237
    i wont do too far back.. but i once owned the infamous cyrix 200+ teamed up with a permedia 2 and voodoo one grfx cards..

    voodoo 2 after that..

    geforce 200 mmx..

    geforce 3..

    radion 9700 pro..

    radion x800gto2 at xt pe speeds..

    radion 1900xtx..

    a few odd things in between but for while i will stick where i am..

    before the cyrix i gamed on an amiga machine.. plus an atari.. not consoles just not PCs..

    trog
  13. JC316

    JC316 Knows what makes you tick

    Joined:
    Jan 24, 2006
    Messages:
    9,362 (2.98/day)
    Thanks Received:
    903
    1999-2001
    Voodoo 3 3000 16MB PCI
    Geforce 2 MX400 (I still say this was the best card I ever owned)

    2001- 2002
    Geforce 4 MX420 (The Geforce 2 ran faster)

    2002-2005
    Geforce FX 5900 (Are we noticing an Nvidia fan boy pattern yet?)

    2005-2006
    Ati radeon X850 Pro

    2006-?
    Ati Radeon X1800GTO

    Some of my dates may be off, I can't really remember. I knwo the Geforce 2 played Morrowind, and the Geforce 4 was bought to get the shiny water, which it didn't do. The FX 5900 was bought to finally get the damned shiny water, which looked like liquid metal anyway.
  14. WakeUpDead New Member

    Joined:
    Nov 26, 2005
    Messages:
    15 (0.00/day)
    Thanks Received:
    2
    Location:
    T-Ville KY
    Lets see what I can remember:

    nVidia cards: Voodoo3, MX440, GF4200, GF FX5200, XFX6800GT
    Now, XFX 2 x 7800GT's in SLI on DFI nF4 Expert rig.

    ATI Cards:Rage Pro, ATI 9000, ATI 9200, Diamond 9250 128mb, Sapp. 9250 256mb, ATI 9800, Sapp. x800xt, Sapp. x850 GTO2, ATI x1800xt, Sapp. x1800xtx
    Now Sapp. x1900xtx + Sapp. x1900xtCF in Crossfire on DFI CFX3200 rig.


    I think thats right, may be a few more here and there. Hell, I cant remember from day to day the things my wife tells me!
  15. stealthfighter

    stealthfighter New Member

    Joined:
    Aug 5, 2006
    Messages:
    557 (0.19/day)
    Thanks Received:
    1
    Location:
    at my pc
    I had...

    16MB Onboard Bunk/ 233mhz PII/ 64MB SDRAM
    then
    32MB Onboard Bunk/ 2.0GHZ Celeron 400fsb 256k l2/ 512MB DDR Value RAM
    then... (like 2 weeks later)
    Some 32MB video card, dunno anything else about it/ same 2.0 ghz/ same RAM
    then...
    Nvidia GeForce FX 5200 ultra 325/650/ same 2.0ghz.../ same RAM
    then...
    Same video card/ same processor/ newer ram, 512MB Kingston DDR333 I think
    then...
    same video card/ 2.8ghz PIV 533fsb 1MB l2/ same RAM
    then...
    same video card/ same processor/ new RAM, 1GB Ballistix DDR400
    now...
    same as above, only sound blaster audigy sound card
  16. Lt_JWS

    Lt_JWS

    Joined:
    Feb 3, 2006
    Messages:
    913 (0.29/day)
    Thanks Received:
    60
    Location:
    Virginia, USA
    nvidia cards: FX5200, FX5600, FX5950U, 2x6800GS , 2X7800GTX

    ATI cards: 9600pro, X800GTO, X800Pro vivo, X1800XT 512mb, X1900XT
  17. technicks

    technicks

    Joined:
    Apr 23, 2006
    Messages:
    3,560 (1.17/day)
    Thanks Received:
    257
    Location:
    Enschede, The Netherlands
    I had:

    GPU:

    Intel pentium 4 @ 2.4 ghz
    AMD Athlon 64 3500+ @ 2.2 ghz
    And now AMD Athlon 64 3700+ @ 2.27 ghz

    Cards:

    ATI Radeon 9000
    ATI Radeon X300 Why? I dont know.
    Nvidia XFX 6600
    ATI Radeon X800 XL
    Nvidia EVGA 7900 GT CO
    And now ATI Radeon X1900 GT.
  18. POGE

    POGE New Member

    Joined:
    Oct 28, 2005
    Messages:
    1,724 (0.53/day)
    Thanks Received:
    35
    Location:
    In banjo's Goats.
    Neomagic 256av
    FX5200
    6200
    x1900xtx
  19. magibeg

    magibeg

    Joined:
    May 9, 2006
    Messages:
    2,000 (0.66/day)
    Thanks Received:
    203
    ATI Rage Pro 8mb (p2 300)
    Voodoo 2 12mb (p2 300)
    Ati x800se (p4 3.4ghz)


    Alec i noticed you have a ton of the Voodoo cards. Don't they kick ass? 3dfx = magic
  20. trog100 New Member

    Joined:
    Dec 18, 2005
    Messages:
    4,420 (1.39/day)
    Thanks Received:
    237
    the voodoo five was interesting.. five voodoo one chips all stuck on the same board i think.. the last desperate attempt by 3dfx to stay in the game..

    but they did start it all.. and when i played the original quake on a voodo 1 my eyes popped.. nothing since has made em pop quite so much..

    trog
  21. JC316

    JC316 Knows what makes you tick

    Joined:
    Jan 24, 2006
    Messages:
    9,362 (2.98/day)
    Thanks Received:
    903
    Exactly, voodoo was the best and the reason that I bought Nvidia alot. Until that damned 5900 anyway.
  22. noneed4me2 New Member

    Joined:
    Oct 29, 2005
    Messages:
    620 (0.19/day)
    Thanks Received:
    9
    Location:
    San Bernardino CA
    My first 3d card was a Diamond Stealth s220 I got at a PC trade show which I regretably put into a 486 PC for my dad that has since disappeared(I would have like to keep that one for sentimental reasons. Got cause of the kick ass rating in Boot magazine), I got windows 2000 to work on that p133 with 64mb ram, took like 8 hours to load but ran great all things considered, it was just to serf the net and email which it did fine. Owned a few Voodoos one still in a pentium 200 packard bell that still works that I keep around for the kids. Its a dual boot setup Win98/Win2000 with 128mb ram, I paid 400 for it back in the day (just the ram!). A TNT2 Nvidia 8mb. My First ATI card was a 32mb Radeon AIW that worked great as a PVR before cable went all digital. I have a X800 GTO by C3D modded of course and i am still debating getting some form of x1900 or waiting till DX10 cards come out.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page