1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Win 7 logon is 'preparing desktop' rather than showing 'welcome' screen

Discussion in 'General Software' started by newconroer, Feb 28, 2010.

  1. newconroer

    newconroer

    Joined:
    Jun 20, 2007
    Messages:
    3,159 (1.18/day)
    Thanks Received:
    340
    [SOLVED] Win 7 logon is 'preparing desktop' rather than showing 'welcome' screen

    [[Issue is now solved, see reply post]]


    Just to be clear, I am not having any loops, hangs or BSODs.

    Rather it's that Vista (and my previous Win 7 Beta versions) would boot, flash a quick welcome of about two seconds and then drop into the desktop.

    On this retail Win 7 copy(which I have made near a clone to my Beta version in terms of startup/services/group policy etc.), I get to the welcome screen yet it shows a quick flash of something about starting group policy service, then about a three second delay where it says 'Preparing Your Desktop.'

    Now logically speaking, since I have folders with saved settings for their layout and etc. then I suppose 'preparing' the desktop would make sense. However it doesn't explain why it's different from past versions.

    It's almost as if each time I boot, it's having to rebuild my profile to some extent.

    I currently have Administrators, Guest Account and HomeGroup disabled, leaving my personal(part of Administrators and HomeGroup) enabled, with no password, and automatic login set.

    Getting annoyed with it; unless I've missed something about changes they've made to the O/S, I just want it to stop preparing my desktop everytime I login.

    Any ideas?
     
    Last edited: Mar 9, 2010
  2. newconroer

    newconroer

    Joined:
    Jun 20, 2007
    Messages:
    3,159 (1.18/day)
    Thanks Received:
    340
    I found the solution through my own digging, but here is a more detailed run-down with multiple methods to a resolution.

    http://www.vistax64.com/tutorials/188324-detailed-status-messages-logon-logoff-shutdown.html
    [If this link at some point becomes invalid then read below]

    In regedit, go to:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    *Note that VerboseStatus may already exist, if it does, skip to step part "C"
    A) In the right pane, right click on an empty area and click on New and DWORD (32-bit) Value.

    B) Type VerboseStatus and press Enter.

    C) Right click on VerboseStatus and click on Modify.

    D) Type the number 1 and click on OK. This creates a setting of 1 or "true."

    Close the regedit and reboot.

    The quick messages like "Group Policy" settings and "Preparing Your Desktop" are now gone, replaced by "Welcome" only.
    If however, you are facing the issue of "Preparing Your Desktop" which leads to you Desktop with a bubble notification in the task tray stating that you are using a temporary profile, then your profile has been corrupted and a solution to that would be found mainly on the Vista/7 tech-net forums.
     
    Last edited: Mar 9, 2010
    heky, DirectorC and crush3r say thanks.
  3. DirectorC

    DirectorC New Member

    Joined:
    Nov 4, 2009
    Messages:
    1,624 (0.89/day)
    Thanks Received:
    268
    Location:
    Florizy
    Very high level of netiquette coming back and posting the solution :toast:
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page