1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

WIn7 Network File Sharing issues again !

Discussion in 'General Software' started by RuskiSnajper, Jan 30, 2011.

  1. RuskiSnajper

    RuskiSnajper

    Joined:
    Feb 18, 2009
    Messages:
    1,608 (0.75/day)
    Thanks Received:
    231
    Location:
    slovenia , europe
    WIn7 Network File Sharing issues again![Solved - Advanced Solution!]

    Okay now that i have a third win7 PC coming right up ... well it already is running up , clean , and just doing the networking part (probably going to continue in morning so i made this thread)

    PC1 = my own PC (july 2010)
    PC2 = FEB 2010 win7 PC
    PC3 = low end office PC



    And now , i forogot much of what the heck i did , but i did reinstall my own WIN7 after the first win7.

    Ah before it was like like hell with the stupid homegroup so i disabled everything , but stuff is under there and now it's making me a weird problem , the PC2 has still stuff underneath , a lot of homegroup edits , tweaks , whatever , plus it's not as updated as my own PC is because i usually forgot to apply the same settings on another PC , shame on me but .. oh well.


    Now , i made some changes to my "Advanced Sharing Settings" and they were a bit weird what i used to have before , weird by that because "homegroup" was selected but i have homegroups totally disabled in services , i also got Password protected file sharing on , not sure why but okay , Public Files sharing was off (other's were ON (file and discovery) , media streaming off)

    Simple Sharing Wizard is of course off. The shared folders are only "Public Documents" hardcode = Public\Documents , nothing else.

    Now , the weird thing is , both computers (one or more in a network imo) have to have the same settings for a feature to work properly, but here's the catch , it doesn't work properly with same settings , I (PC1) can't access PC2 shared folder (generic no access error) but PC2 can access my (PC1) folder /move copy edit/ , settings same , homegroups disabled , both seen from each other, source folder permissions are the same , sharing permissions the same.
    The settings in netowork are:
    PC1 & PC2: Discovery and File Sharing ON, Public File sharing Off , 128 bit , Password OFF , User Accounts and Pass words (not homegroup)


    The combination it worked just before(for moths): (Warning: Stupid windows behavior ahead)
    PC2: D&F ON , Public File Sharing ON , 128 bit , Password OFF , Users&Password (not HG)
    PC1: D&F ON , Public File Sharin OFF , 128 bit , Passwords ON , Homegroup (but it is FUCKING disabled)
    >>Both PCs Disabled Homegroups in services , disabled simple file sharing wizard in folder options.


    Result: Advanced File Sharing works fine , no homegroups , All access Fine , no password requirements (i think it was asking for initially but i set to automatic , don't recall much) , no access problems nothing , same permission settings all(default + sharing "everyone" > full control)

    Issues (in connection with another recent thread here): It was weirdly taking long to display users in network (PC1) ,and my own pc failed to detect it self for a longer than usual period, detects instantly whith revised (normalized settings, no homegroup radio button)

    EXPLAIN to me how can a COOKY totally nonsense settings work , this is total bullcrap.

    [​IMG]




    PC3 i will tell what's about it later , i need to have 2 PCs okay then i'll add the third one , but it's really mixed you know , it asks for password for one , but the other doesn't need pasword it just doesn't aloow when opening shared folder , it's a clusterfuck and you don't know what the fuck settings work or what the heck is set how , these stupid radio buttons , may i get some more advanced advice and some more "ADVANCED" options than just the stupid windows UI - 5 settings lol.


    I remember there was a path somewhere in wins and some reg keys to forcefully leave homegroups , but i forgot it , may need to search archives of bookmarks, anyone so nice finding trying to help find it again , on google there is ?

    EDIT:

    THIS ABOVE POST IS OUTDATED / OBSOLETE , IT'S A CLUSTERMIX OF WEIRD SETTINGS AND SOME STUPID COMPUTER MAGIC. IT IS TRUE BUT DON'T TAKE THOSE SETTINGS - IT WONT WORK

    Admin please rename this thread to solved.

    Or better , "Advanced Win7 Network File Share Guide" - :)
    Already made another one for consideration.
     
    Last edited: Jan 31, 2011
  2. RuskiSnajper

    RuskiSnajper

    Joined:
    Feb 18, 2009
    Messages:
    1,608 (0.75/day)
    Thanks Received:
    231
    Location:
    slovenia , europe
    same setting everyone

    It either doesn't connect , (asks for credentials but that's expected)

    Or it doesn't have access to the shared folder

    I have an image , didn't put together yet.


    Please help! I've ran out of options , but for i will only try to hack source folders them self and also Windows authority policy , but that's not a good way to do it , atleast not safe.


    EDIT: here's what i found , http://social.answers.microsoft.com/Forums/en/w7network/thread/14c9cf97-ac52-48bc-a730-284de284d353

    One thing bother's me:
    - This is unacceptable , im not going to edit all of them , im not the sole user of the 3 pcs , only my own , are all filepaths going to update ,all registry , all 3 PCs , all 3 PCs same account name and same password , this is complete and utter bullshit.


    I thought for a second Win7 network might just be better than Vista's , turns out , it's exactly what i've been saying before when i had XPs because i passed Vista after using it for 2 , yes, 2 days, win7 is just a 300$ service pack.

    Those MS fanboys have so much fun explaining MS versioning , it's really there , it makes sense , Win NT 6.0 = Vista , Win NT 6.1 = Win7.
     
    Last edited: Jan 30, 2011
  3. streetfighter 2

    streetfighter 2 New Member

    Joined:
    Jul 26, 2010
    Messages:
    1,658 (1.03/day)
    Thanks Received:
    732
    Location:
    Philly
    Let's have a look at that process shall we?

    All your computers already have a common account called, "Everyone", which doesn't have a password and reminds me of the village bicycle :D. But "Everyone" isn't explicitly linked to all your folders. So let's fix that...

    How to manually share a folder with "Everyone" account

    1) Share your folder
    Right click and go to Properties->Sharing Tab->Advanced Sharing->Check Share This Folder->Apply->Apply
    [​IMG]

    2) Add "Everyone" to folder permissions
    Right click and go to Properties->Security Tab->Edit->Add...->Enter Object "Everyone"->Check Names->Ok->Apply->Apply
    [​IMG]

    3) Folder is now shared with "Everyone" account
    Make margaritas.
     
    RuskiSnajper says thanks.
  4. RuskiSnajper

    RuskiSnajper

    Joined:
    Feb 18, 2009
    Messages:
    1,608 (0.75/day)
    Thanks Received:
    231
    Location:
    slovenia , europe
    Lol , i thought it said i need to make all user LOGON accounts the same , the word's context is kind of weird.
     
  5. RuskiSnajper

    RuskiSnajper

    Joined:
    Feb 18, 2009
    Messages:
    1,608 (0.75/day)
    Thanks Received:
    231
    Location:
    slovenia , europe
    Okay , here it goes: Win7 Ultimate x64


    Goal: I want to share "Public Documents" folder in Public user. Or any other folder ,

    First: (you obviously are "administrator user" from the get go/ not the hidden account)
    Second: All computers must have these same settings below, exactly.

    *** All computers must be in the same "Workgroup" , default is "WORKGROUP"
    You can change this in system settings under "Computer Name" , do not use domains if you don't know what they are for and how to use them.



    1 - Disable "Simple file sharing"(XP) / "File Sharing Wizard"(Win7) in Folder Options

    2* - Disable Windows Firewall service (i only use router firewall)
    2* - Disable Homegroup Provider and Homegroup Listener service (useless junk)
    2* - Completely Disable UAC in User Account Control (useless junk) (it will nag you throughout the whole process)



    4 - Home And Work Advanced Network Sharing Options:

    -Turn ON network discovery
    -Turn ON file and printer sharing
    -Turn ON sharing in the Public folder sharing section
    -Turn ON password protected sharing
    -Select 128 bit
    -Select "users and passwords" - no homegroup.



    4* - You may want to disable sharing of "Users" folder after you confirm these options , disable it since it's not the right way, the solution suggest enabling "sharing in the Public folder section" but it's working weird, you may also try not even turning on "sharing in public folders" , but i used this just maybe it may do something else to some who knows where permissions or what, anyways i don't think it's needed since it's visible action is completely wrong (it shares every user , not just public)



    5 - search for "netplwiz" in start menu , run it and remove any Homegroup's ($Homegroup_User$) that may be existing, also edit your own account to remove "HomeGroup$". Select your account to be in "Administrators" group radio button.
    You don't need to deselect "Users must enter a user name and password to use this computer" - leave that selected since it makes your computer to log in your account automatically - plus it's not needed to make networking share work.



    - restart the computer-s




    6 - Create Shared folders using this: Also make sure , there is FULL control under both "Everyone" - in the share permissions and the source folder permissions.

    --- Make sure "Public Documents" (or any other "Public ...") folder has "Everyone" permissions (full control)


    - restart computer-s



    7 - Open network and try to open all other found users except your self , (YOU MUST DO THIS ON ALL COMPUTERS , EACH WITH EVERYONE ELSE) - this is the stupid context part - it will ask you for credentials , user and password , but it makes it sound like it requires a user and pass from the current PC > no , you must enter the other User's username and Password that you're connecting to (not hidden admin account) , and choose "Save credentials" , you must know the passwords of all of the computers (or ask those people to type it for you) , once you authenticated everybody with everyone , saved credentials , it's done.

    **- If you don't detect some users before making the "7" point above , this is expected network behavior it's bugged and that's how it works before it's all done , so you need to type "\\[Example_Computer_Name]" (without quotes) of the user that does not "detect" (in the bar above the window) , not really, they're there, the network window has hard time refreshing and displaying them - stupid code :)

    - With this full access it will no longer take ages to display/refresh computers in network , thank god.
    Remember , no homegroup , it is very easy to share a printer this way , im really sick of microsofts braggings and dumbings down , ofcourse *everyone* makes homegroup since it's in the installer as "the best way to share" blah , you have full control and overlooknig , homegroup is stupid with it's "password" and it does not work if the clocks aren't synced (a problem that lost an afternoon of my life :mad: ) - plus the options never solidify, homegroup just tunes up what will share and there's always stupid music and picture folders everywhere because homegroup forces them to share.. whatever.


    If there's a need for more images , ask.


    Sources: (obsolete/outdated)

    http://social.answers.microsoft.com/Forums/en/w7network/thread/14c9cf97-ac52-48bc-a730-284de284d353
     
    streetfighter 2 says thanks.
  6. streetfighter 2

    streetfighter 2 New Member

    Joined:
    Jul 26, 2010
    Messages:
    1,658 (1.03/day)
    Thanks Received:
    732
    Location:
    Philly
    A few things I'd change. . .

    1:
    Don't disable "Simple file sharing" in XP. It's Win7 that is the problem.

    2*:
    Don't Disable Windows Firewall service (unless you're using another firewall)
    You will need to make sure that file and printer sharing is allowed in Windows Firewall if it's enabled.

    4:
    -Turn OFF network discovery (optional, it'll just use the XP style netbios search)
    -Turn ON file and printer sharing
    -Turn ON sharing in the Public folder sharing section
    -Turn OFF password protected sharing (you cannot use the "Everyone" account if this is on because it doesn't have a password!!)
    -Select 128 bit
    -Select "users and passwords" - no homegroup.

    4*:
    This sounds like French to me. What the hell??

    5:
    You don't need to delete $Homegroup_User$, it's not harming anything. I wouldn't recommend elevating your account to an Administrator unless you are a power user. Most of Windows 7 account protections are disabled if you change yourself to an Administrator account. For the record, I always run under an Admin account. :D

    -restart computer- ? Why? There aren't any "RunOnce" or "Run" changes needed to set up manual sharing in Win7. It's just a waste of time. If you did decide to delete $Homegroup_User$ it still has no baring on any of the other settings you're changing.

    6:
    If you give "Everyone" full control in share+folder permissions you'll be letting people modify/write your shared folders. I consider that to be inadvisable and a significant security risk. I usually just give read permissions. Up to your discretion though...

    -restart computer- ? Why? There aren't any "RunOnce" or "Run" changes needed to set up manual sharing in Win7. It's just a waste of time.

    7:
    Try launching shares using the run dialog. For instance win key+'r', then type: "\\RuskiSnajper\Public" or "\\<name of computer>\<name of share>"
    The folder should pop-up fairly quickly and without asking for credentials (because it will automatically use "Everyone"). If it does ask for credentials it's because you enabled password protected sharing in Step 4.
     
    Last edited: Jan 31, 2011

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page