1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Win7 svchost.exe (DcomLaunch) avg 45% load help

Discussion in 'General Software' started by puma99dk|, Jan 28, 2010.

  1. puma99dk|

    puma99dk|

    Joined:
    Aug 29, 2005
    Messages:
    3,288 (1.02/day)
    Thanks Received:
    724
    when i check resource monitor i see that svchost.exe (DcomLaunch) is using avg. 45% of my cpu how can i fix that?

    [​IMG]

    my pc has only been running for about 21hours from my last reboot.

    and then i type tasklist /svc in cmd i get this:

    Code:
    Image Name                     PID Services
    ========================= ======== ============================================
    System Idle Process              0 N/A
    System                           4 N/A
    smss.exe                       328 N/A
    csrss.exe                      448 N/A
    wininit.exe                    524 N/A
    csrss.exe                      536 N/A
    services.exe                   580 N/A
    lsass.exe                      596 KeyIso, SamSs
    lsm.exe                        604 N/A
    winlogon.exe                   640 N/A
    svchost.exe                    764 DcomLaunch, PlugPlay, Power
    nvvsvc.exe                     820 nvsvc
    svchost.exe                    860 RpcEptMapper, RpcSs
    svchost.exe                    936 Audiosrv, Dhcp, eventlog,
                                       HomeGroupProvider, lmhosts, wscsvc
    svchost.exe                    992 AudioEndpointBuilder, CscService, hidserv,
                                       HomeGroupListener, Netman, PcaSvc, SysMain,
                                       TrkWks, UxSms, wudfsvc
    svchost.exe                   1032 Browser, gpsvc, IKEEXT, iphlpsvc,
                                       LanmanServer, MMCSS, ProfSvc, Schedule,
                                       SENS, ShellHWDetection, Themes, Winmgmt,
                                       wuauserv
    audiodg.exe                   1124 N/A
    svchost.exe                   1188 EventSystem, fdPHost, netprofm, nsi,
                                       WdiServiceHost
    svchost.exe                   1296 CryptSvc, Dnscache, LanmanWorkstation,
                                       NlaSvc
    nvvsvc.exe                    1356 N/A
    spoolsv.exe                   1448 Spooler
    svchost.exe                   1496 BFE, DPS, MpsSvc
    httpd.exe                     1732 Apache2.2
    dwm.exe                       1760 N/A
    taskhost.exe                  1784 N/A
    avp.exe                       1808 AVP
    explorer.exe                  1816 N/A
    httpd.exe                     1920 N/A
    svchost.exe                   1932 FDResPub, SSDPSRV
    mysqld-nt.exe                 1560 mysql
    nvSCPAPISvr.exe               2100 Stereo Service
    TeamViewer_Service.exe        2160 TeamViewer5
    svchost.exe                   2976 PolicyAgent
    jusched.exe                   3020 N/A
    SearchIndexer.exe             3248 WSearch
    UnlockerAssistant.exe         3280 N/A
    avp.exe                       3400 N/A
    PDVD9Serv.exe                 3432 N/A
    brs.exe                       3456 N/A
    vsnpstd3.exe                  3508 N/A
    DTLite.exe                    3544 N/A
    NMIndexStoreSvr.exe           3552 N/A
    RocketDock.exe                3560 N/A
    Skype.exe                     3576 N/A
    NMIndexingService.exe         3820 NMIndexingService
    wmpnetwk.exe                  4008 WMPNetworkSvc
    Rainlendar2.exe               2220 N/A
    msnmsgr.exe                   2376 N/A
    Rainmeter.exe                 2600 N/A
    SetPointII.exe                2792 N/A
    KHALMNPR.exe                  2392 N/A
    skypePM.exe                   3500 N/A
    svchost.exe                   2560 pimsvc, psvc, PNRPsvc
    wlcomm.exe                    4856 N/A
    taskmgr.exe                   5136 N/A
    RealTemp.exe                  5664 N/A
    utorrent.exe                  5696 N/A
    mirc.exe                      5724 N/A
    svchost.exe                   4188 WinDefend
    svchost.exe                   4080 Akamai
    svchost.exe                   4084 SDRSVC
    winamp.exe                    6052 N/A
    firefox.exe                   5952 N/A
    klwtblfs.exe                  1728 N/A
    perfmon.exe                   5864 N/A
    cmd.exe                       5504 N/A
    conhost.exe                   1628 N/A
    tasklist.exe                  1832 N/A
    WmiPrvSE.exe                  4800 N/A
    

    Attached Files:

  2. Easo

    Easo

    Joined:
    May 19, 2009
    Messages:
    823 (0.44/day)
    Thanks Received:
    78
    Location:
    Latvia
    wmpnetwk.exe 4008 WMPNetworkSvc

    I would turn off this service usually (it has bad habbit of eating like 20% in regular spikes), but this is not a case.
    One week ago i let the trojan slip into system in such way (dont ask), that KIS was unable to block it, and it caused high CPU usage, cause KIS was skanning the infected process all the time...
  3. Black Panther

    Black Panther Senior Moderator™ Staff Member

    Joined:
    May 30, 2007
    Messages:
    8,558 (3.29/day)
    Thanks Received:
    1,911
    Scan your pc. It's highly likely it's a virus.
  4. puma99dk|

    puma99dk|

    Joined:
    Aug 29, 2005
    Messages:
    3,288 (1.02/day)
    Thanks Received:
    724
    i usually don't have virus' and spyware only cookies :laugh:

    oki thx Easo i will try turn it off
  5. Fourstaff

    Fourstaff Moderator Staff Member

    Joined:
    Nov 29, 2009
    Messages:
    9,154 (5.43/day)
    Thanks Received:
    1,958
    Location:
    Home
    Reformat! :D

    Just like nuking a mosquito :roll:
  6. puma99dk|

    puma99dk|

    Joined:
    Aug 29, 2005
    Messages:
    3,288 (1.02/day)
    Thanks Received:
    724
    no thx you, but i am still looking for some fix for this...

    and i installed this about 25-26days ago so i won't do that, there most be a fix around for this kind of problem....
    Last edited: Jan 28, 2010
  7. puma99dk|

    puma99dk|

    Joined:
    Aug 29, 2005
    Messages:
    3,288 (1.02/day)
    Thanks Received:
    724
    turns out that the same services was hosting Power, PlugPlay and DcomLaunch so it splitted them up, and now i found out that it was Plug'n'Play that caused me high cpu usage 'cause today only about 5mins ago it's started to use 50% cpu usage and i haven't plugged anything in, so i killed the services and Win7 wanted a reboot xD

    so anyone know how i can fix this problemo? plz ^^
  8. puma99dk|

    puma99dk|

    Joined:
    Aug 29, 2005
    Messages:
    3,288 (1.02/day)
    Thanks Received:
    724
    i reinstall my Win7 05-02-2010 and now 10days later after 2days, 18hours and 33mins turned on svchost.exe (DcomLaunch) starts to use a average of 46-47% of my cpu again, the first 1week i was online without a problem, and the lastest program i installed is PowerDVD9, can it be something in PowerDVD that cause my svchost.exe to use a average cpu usage of 46-47% ?

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page