1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Winamp Next Track Hotkey

Discussion in 'General Software' started by OrbitzXT, Dec 27, 2010.

  1. OrbitzXT

    OrbitzXT New Member

    Joined:
    Mar 22, 2007
    Messages:
    1,969 (0.73/day)
    Thanks Received:
    59
    Location:
    New York City
    I installed Windows XP tonight, I had been using Windows 7. I have a Microsoft Natural Ergonomic Keyboard 4000 with Back/Forward buttons that can be programmed to be next/previous track. They work fine with Windows Media Player, but I like Winamp better, though I'm having an odd issue.

    The button works for next track, but will not work again until the song is exactly 10 seconds into it. Pushing the button does nothing, but once 10 seconds has passed I can skip to the next track. This is pretty annoying and I figure has something to do with Winamp settings considering the buttons work fine for other media players. Does anyone know what the issue might be?
  2. scaminatrix

    scaminatrix

    Joined:
    Mar 1, 2010
    Messages:
    3,578 (2.19/day)
    Thanks Received:
    794
    Location:
    By the Channel Tunnel, Kent, England
    Does Winamp have the crossfading feature? If so, make sure it's turned off. 10 seconds is a long time for crossfading though.
  3. entropy13

    entropy13

    Joined:
    Mar 2, 2009
    Messages:
    4,915 (2.46/day)
    Thanks Received:
    1,193
    Yeah, you might have crossfade turned on, but the default is only 5 seconds. Might be something else then. I'll try replicating your parameters.

    EDIT1: Having crossfade turned on and then going to the next track (only replicating two of your conditions) does not produce the same effect. Also winamp's crossfade only works with the DirectSound plugin apparently; for other plugins you'll have to have another separate crossfade plugin...but within DirectSound you can change fade length and fades will still happen even without crossfade turned on. Hmm...

    Maybe the plugin's settings were fiddled with? I'm checking if changing options with the default nullsoft DirectSound plugin gets a similar result.

    EDIT2: Increasing the buffer length to 6000ms and the fade length to 6000ms as well does not disable going to the next track; the next track would still start and fade in very slowly while the previous track would stop very slowly.

    Retaining buffer length of 6000ms while decreasing fade length to 3000ms only makes the fade happen quicker.
    Last edited: Dec 27, 2010

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page