1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Windows 98 phantom floppy drive preventing real floppy drive from functioning

Discussion in 'General Hardware' started by Red_Machine, Feb 6, 2012.

  1. Red_Machine

    Red_Machine

    Joined:
    Oct 1, 2010
    Messages:
    1,732 (1.17/day)
    Thanks Received:
    380
    Location:
    Marlow, ENGLAND
    Kay guys, another werid issue here.

    I recently took posession of a Toshiba Libretto 70CT, which is a mid-90s palmtop Pentium machine built for Windows 95 with a PCMCIA floppy drive. With the machine as it came, the floppy drive wouldn't function in Windows but worked fine in DOS, so I figured it was a software issue. I formatted and reinstalled 98 (bit of a faff with no CD drive, but got there in the end), but it installed a floppy drive that isn't physically there. I got the drivers installed for the PCMCIA drive, but the phantom drive seems to be stopping the external drive from being recognised. When I try to access the A:\ drive, the machine locks up and I have to hard reset.
    I booted into safe mode, removed all reference to floppies and restarted. I checked My Computer, but the phantom drive was still listed. I installed the PCMCIA drivers again and plugged the drive in, but it still won't recognise it.

    Anyone have a clue how I can fix this? I'm pretty stumped...
     
  2. xfire

    xfire New Member

    Joined:
    Nov 22, 2007
    Messages:
    1,395 (0.55/day)
    Thanks Received:
    193
    Location:
    Hyderabad,India
    Did you try changing the the drive letter assigned to it? Also try disabling floppy drive in bios.
     
  3. Solaris17

    Solaris17 Creator Solaris Utility DVD

    Joined:
    Aug 16, 2005
    Messages:
    17,263 (5.14/day)
    Thanks Received:
    3,600
    Location:
    Florida
    how about finding it in device manager and showing hidden devices then disable it?
     
  4. Red_Machine

    Red_Machine

    Joined:
    Oct 1, 2010
    Messages:
    1,732 (1.17/day)
    Thanks Received:
    380
    Location:
    Marlow, ENGLAND
    There's no way of disabling it in BIOS, as it has no floppy controller on the motherboard.

    I can't change the drive letter, as the laptop locks up when I try to right-click on the floppy drive.
     
  5. Solaris17

    Solaris17 Creator Solaris Utility DVD

    Joined:
    Aug 16, 2005
    Messages:
    17,263 (5.14/day)
    Thanks Received:
    3,600
    Location:
    Florida
    reinstall with PCMCIA OUT delete floppy controller if it appears and then install PCMCIA card?

    try windows 2000?
     
  6. Red_Machine

    Red_Machine

    Joined:
    Oct 1, 2010
    Messages:
    1,732 (1.17/day)
    Thanks Received:
    380
    Location:
    Marlow, ENGLAND
    That's what I'm doing now. Formatting the C: drive as bootable and will copy the Win98 disc to the drive externally. Floppy won't be plugged in till after it's installed.

    I don't think 2k will take kindly to 32MB RAM...
     
  7. Red_Machine

    Red_Machine

    Joined:
    Oct 1, 2010
    Messages:
    1,732 (1.17/day)
    Thanks Received:
    380
    Location:
    Marlow, ENGLAND
    No joy, even after installing with no floppy drive it still has one listed.
     
  8. ThE_MaD_ShOt

    ThE_MaD_ShOt

    Joined:
    Nov 29, 2011
    Messages:
    4,932 (4.65/day)
    Thanks Received:
    3,526
    Location:
    Hi! I'm from the Internet
    Win 98 will install a floppy drive by default whether there's one there or not. Have you tried installing the pcmcia drive drive b:? Also there is a way to uninstall the floppy in 98 but I can't remember right now. I will dig into it and let you know
     
    Crunching for Team TPU
  9. Depth

    Joined:
    Aug 7, 2009
    Messages:
    590 (0.31/day)
    Thanks Received:
    132
    As mentioned, did you try the device manager?

    You could (god forbid) contact Microsoft support, if you're lucky they'll have a 1998 veteran available.
     
  10. Red_Machine

    Red_Machine

    Joined:
    Oct 1, 2010
    Messages:
    1,732 (1.17/day)
    Thanks Received:
    380
    Location:
    Marlow, ENGLAND
    I have tried device manager, it's not listed. Whenever I install the PCMCIA floppy drivers, I plug the drive in and it configures it, but the drive doesn't appear in My Computer. In Device Manager, the icon has a yellow exclamation mark on it and it says the device isn't working properly.
     
  11. ThE_MaD_ShOt

    ThE_MaD_ShOt

    Joined:
    Nov 29, 2011
    Messages:
    4,932 (4.65/day)
    Thanks Received:
    3,526
    Location:
    Hi! I'm from the Internet
    Here try this

    Safe Mode

    Start Windows in Safe mode and try to access the floppy disk drive. To start Windows 95 in Safe mode, restart your computer, press the F8 key when you see the "Starting Windows 95" message, and then choose Safe Mode from the Startup menu. To start Windows 98 in Safe mode, restart your computer, press and hold down the CTRL key after your computer completes the Power On Self Test (POST), and then choose Safe Mode from the Startup menu.

    If you can access the floppy disk drive, follow these steps:

    Use the right mouse button to click My Computer, then click Properties on the menu that appears.
    Click the Device Manager tab.
    Double-click Floppy Disk Controllers.
    Click the floppy disk controller for the drive you are having problems with, then click Properties.
    In Windows 95, click the Original Configuration (Current) check box to clear it. In Windows 98, click the Disable In This Hardware Profile check box to select it. This disables the Windows protected-mode driver for the floppy disk drive controller.
    Click OK.

    Restart Windows normally.


    If you can access the floppy disk drive successfully after following the above steps, the following conditions may be true:
    The floppy disk drive controller may not be supported in protected mode.
    There are drivers loading in the Config.sys or AUTOEXEC.BAT file that may be necessary for protected-mode access.
    There are drivers loading in the CONFIG.SYS or AUTOEXEC.BAT file that may be causing conflicts in Windows and need to be disabled.

    If you still cannot access the floppy disk drive after following steps 1-7, follow these steps:

    Use the right mouse button to click My Computer, then click Properties on the menu that appears.
    Click the Device Manager tab.
    Double-click Floppy Disk Controllers.
    Click the floppy disk controller, and then click Remove to remove the controller.
    Click OK.
    In Control Panel, double-click Add New Hardware.
    Click Next, and then click Yes to allow Windows to detect the hardware in your computer.
    When the Add New Hardware Wizard is finished, restart the computer and try to access the floppy disk drive again.
    Redetecting the floppy disk controller should resolve any addressing problems with the controller by detecting the correct address range. If the floppy disk controller is not detected correctly, there may be a problem with the floppy disk controller. If the floppy disk controller is redetected but you still cannot access the floppy disk drive, there may be a problem with the floppy disk.
     
    Red_Machine says thanks.
    Crunching for Team TPU
  12. Red_Machine

    Red_Machine

    Joined:
    Oct 1, 2010
    Messages:
    1,732 (1.17/day)
    Thanks Received:
    380
    Location:
    Marlow, ENGLAND
    Okay, I got it working in safe mode and followed your advice to disable it in this hardware profile, but it did the same in normal mode and Device Manager said it was disabled and recommended I enable it again. This did nothing, and it still has the yellow exclamation mark, giving error code 10.

    My AUTOEXECT.BAT and CONFIG.SYS are empty (except CONFIG-SYS has something related to a Toshiba device not related to the PCMCIA system).

    Removing and redetecting the floppy controller didn't help either. I shall try it in another system as soon as I am able.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page