1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Windows XP Service Pack 3 Release to Web (RTW) Delayed

Discussion in 'News' started by malware, Apr 29, 2008.

  1. malware New Member

    Joined:
    Nov 7, 2004
    Messages:
    5,476 (1.59/day)
    Thanks Received:
    956
    Location:
    Bulgaria
    Windows XP Service Pack 3 was supposed to land today for mass download, but I'm afraid this won't happen. Microsoft today explained what's the main reason behind this last moment delay:
    I suppose many of you already know about the leaked Windows XP SP3 download link, but I prefer to post only legit links here. Microsoft is working on fixing the problem and should release Windows XP SP3 to web very soon.

    Source: Microsoft TechNet Forums
    Last edited: Apr 29, 2008
  2. EastCoasthandle

    EastCoasthandle New Member

    Joined:
    Apr 21, 2005
    Messages:
    6,889 (2.10/day)
    Thanks Received:
    1,505
    This sounds pretty vague. In any case it doesn't appear to be an issue that requires a whole lot of man hours to fix.
  3. Kovoet

    Kovoet

    Joined:
    Mar 9, 2008
    Messages:
    843 (0.38/day)
    Thanks Received:
    172
    Damn was waiting for this damn
  4. Kreij

    Kreij Senior Monkey Moderator Staff Member

    Joined:
    Feb 6, 2007
    Messages:
    13,881 (5.28/day)
    Thanks Received:
    5,610
    Location:
    Cheeseland (Wisconsin, USA)
    It's working fine for me. I downloaded it this morning.
  5. PVTCaboose1337

    PVTCaboose1337 Graphical Hacker

    Joined:
    Feb 1, 2006
    Messages:
    9,513 (3.17/day)
    Thanks Received:
    1,142
    Location:
    San Antonio, Texas
    I'm gonna wait about a week before I get this so all glitches go away...
  6. p_o_s_pc

    p_o_s_pc F@H&WCG addict

    Joined:
    May 2, 2007
    Messages:
    13,007 (5.11/day)
    Thanks Received:
    2,183
    Location:
    Newark ohio
    i have been using SP3 for some time now as soon as i could get SP3 i downloaded it and the only problem i have is the onboard sound doesn't work. :wtf:
    Crunching for Team TPU
  7. ShadowXP New Member

    Joined:
    Aug 22, 2006
    Messages:
    126 (0.05/day)
    Thanks Received:
    6
    Location:
    Larvik, Norway
    Installed it on one test-comp at work today, and then on my personal work-comp afterwards. No issues, glitches or bugs that I noticed, system functioned a-ok, install went cool and everything was as it should. The only noticeable difference I've found so far is that the system properties says "ServicePack 3" instead of "Servicepack 2".

    There are times when I love my Technet Plus-subscription :p
  8. ..'Ant'..

    ..'Ant'.. New Member

    Joined:
    Apr 16, 2008
    Messages:
    294 (0.13/day)
    Thanks Received:
    163
    Location:
    █♣█

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page