1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Wireless Mouse Install Problem.

Discussion in 'General Hardware' started by Castiel, Dec 25, 2008.

  1. Castiel

    Castiel

    Joined:
    May 5, 2008
    Messages:
    3,319 (1.40/day)
    Thanks Received:
    310
    I just got a new wireless mouse the "Swiss Gear Wireless Optical mini mobile mouse Panter 2".
    And for install it says:
    1.Plug in USB Receiver
    2. While USB receiver is plugged in, press button on the top of the reciever.
    3.Click mouse "CONNECT" button once on bottom of mouse within 5 seconds after clicking the "CONNECT" button one the receiver.
    4. Reveiver LED will start blinking, when connection is established.
    Move the mouse around to test if successful.
    If the synchronization is not successful:
    a. Remove Batteries and unplug receiver.
    b.Wait 20 seconds and try steps 1 to 5 again.

    Now I did all that correctly and it does connect, because when I move the mouse around the LED on the receiver blinks, but the pointer doesn't move. Now when it windows says it looks for a device driver it finds it but it cant install it and this is what I get.
    [​IMG]

    And I tried to install a default driver that Vista has and it says it fails when it trys to install that way to.

    So what is my problem? What can I do? And I cant find a driver from the website for this mouse.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page