1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

X-Fi only controls front speaker's volume.

Discussion in 'General Hardware' started by Polaris573, May 17, 2008.

  1. Polaris573

    Polaris573 Senior Moderator

    Joined:
    Feb 26, 2005
    Messages:
    4,279 (1.25/day)
    Thanks Received:
    709
    Location:
    Little Rock, USA
    My X-Fi extreme music is only controlling the volume of my front two speakers and not the volume of the rear two. I can't use the Windows volume controls either. I used to be able to control the volume of all four speakers via software and not have to mess with the knobs on the actual devices. This problem occurs if I try to use newer versions of the drivers. Does anyone else experience this or know of any solutions?

    Don't tell me to revert to older drivers, that's an obvious solution that I will probably have to choose, but humor me and try to come up with something different.
  2. imperialreign

    imperialreign New Member

    Joined:
    Jul 19, 2007
    Messages:
    7,043 (2.76/day)
    Thanks Received:
    909
    Location:
    Sector ZZ₉ Plural Z Alpha
    if your running the newer drivers, first check your audio control panel


    go to Start>Control Panel>Sounds and Audio devices>

    (can't remember for Vista) there should be a button labeled "speaker volume" - hit that, and make sure all your channels are normal.

    The new drivers allow for individual channel volume control, and sometimes a couple of the sliders get out of place for some reason . . . also, make sure with the newer drivers that in the audio console, output is set to the correct number of channels - volume will sound muted, or nothing at all, if it's accidentally set to headphones or 2.1
  3. Polaris573

    Polaris573 Senior Moderator

    Joined:
    Feb 26, 2005
    Messages:
    4,279 (1.25/day)
    Thanks Received:
    709
    Location:
    Little Rock, USA
    It's definitely set to 4 channels and the Volume control is control panel are where they should although there are only two sliders. Shouldn't there be four?

    Update on what I've figured out. If I go into the creative volume panel and adjust the "Wave" volume slider it adjusts all four speaker volumes but the "master volume" control for both windows and creative volume control panel only adjust the front two. Trashy and clunky. I want to get everything balanced and then have a true master volume control instead of having to adjust two volume controls every time I want to turn my music up or down.
  4. imperialreign

    imperialreign New Member

    Joined:
    Jul 19, 2007
    Messages:
    7,043 (2.76/day)
    Thanks Received:
    909
    Location:
    Sector ZZ₉ Plural Z Alpha
    I thought there would be 4 as well, at least - even with only a 2.1 channel hookup, I still have controls for all 8 channels . . . odd :confused: Perhaps it's different with the Vista drivers, not sure . . .



    I can say this as to the new drivers, and I'm not sure about the Vista variety, but I've noticed that the volume control (the icon that sits on the task bar, and is opened with one click) no longer seems to be connected with the audio console (what opens when you double click the icon). It isn't unusual for me to find the audio console set at 35%, and the volume control set at 100%, or the other way around.

    I've found, though, that if you switch from one mode to another and then back, they re-synch themselves. I don't know of any other work around yet, I think it's a bug with the new drivers and the software.

    it might be worth keeping an eye on if the problem arises again, also. Volume controls with the new drivers are rather odd :ohwell:
  5. Polaris573

    Polaris573 Senior Moderator

    Joined:
    Feb 26, 2005
    Messages:
    4,279 (1.25/day)
    Thanks Received:
    709
    Location:
    Little Rock, USA
    I'm not using Vista right now, I'm using XP. I don't know if the problem occurs in Vista or not, maybe I should fire that up.
  6. btarunr

    btarunr Editor & Senior Moderator Staff Member

    Joined:
    Oct 9, 2007
    Messages:
    28,201 (11.41/day)
    Thanks Received:
    13,573
    Location:
    Bangalore, India
    Make sure you have the latest driver installed,

    Run sndvol32. You can manually adjust each channel from here. In the pic, I had my headphones connected, the driver mute other channels.

    [​IMG]

    Oh, and remember, when the soft volume is at 50%, the hardware signal is at its 100%. Beyond 50% soft-volume, the signal is amplified, so the best signal is at 50%.

    Important: check that "move all sliders" checkbox.
  7. Polaris573

    Polaris573 Senior Moderator

    Joined:
    Feb 26, 2005
    Messages:
    4,279 (1.25/day)
    Thanks Received:
    709
    Location:
    Little Rock, USA
    I just have two sliders there. Should I not have more since I have four speakers?
  8. Wile E

    Wile E Power User

    Joined:
    Oct 1, 2006
    Messages:
    24,324 (8.55/day)
    Thanks Received:
    3,777
    D_K drivers maybe? Just a thought.
  9. Polaris573

    Polaris573 Senior Moderator

    Joined:
    Feb 26, 2005
    Messages:
    4,279 (1.25/day)
    Thanks Received:
    709
    Location:
    Little Rock, USA
    D_K is that the full name? I'm not aware of any third party drivers for the X-Fi on Windows XP. Just drivers to restore full functionality for Vista users.
  10. Wile E

    Wile E Power User

    Joined:
    Oct 1, 2006
    Messages:
    24,324 (8.55/day)
    Thanks Received:
    3,777
    He Daniel_K does the XP drivers as well. If you grab the full installation package (in .iso format, iirc), it's for both XP and Vista.
  11. Polaris573

    Polaris573 Senior Moderator

    Joined:
    Feb 26, 2005
    Messages:
    4,279 (1.25/day)
    Thanks Received:
    709
    Location:
    Little Rock, USA
    It's worth a try.
  12. btarunr

    btarunr Editor & Senior Moderator Staff Member

    Joined:
    Oct 9, 2007
    Messages:
    28,201 (11.41/day)
    Thanks Received:
    13,573
    Location:
    Bangalore, India
    You should have all sliders available at all times. Click on the 'default' button in all three modes' consoles. It will reset all registry data. After that, set your speaker-mode to 4.1 channels, get back to these sliders.
  13. imperialreign

    imperialreign New Member

    Joined:
    Jul 19, 2007
    Messages:
    7,043 (2.76/day)
    Thanks Received:
    909
    Location:
    Sector ZZ₉ Plural Z Alpha
    and from my understand, at least as far as Vista is concerned, they work better than the official drivers . . .

    not sure about XP, though - still worth a shot for those with odd problems


    BTW, Polaris, double check in the Creative control panel that "synchronize with control panel" is checked as well.
  14. Polaris573

    Polaris573 Senior Moderator

    Joined:
    Feb 26, 2005
    Messages:
    4,279 (1.25/day)
    Thanks Received:
    709
    Location:
    Little Rock, USA
    Synchronize with control panel is checked. btarunr I still just have two sliders.
  15. btarunr

    btarunr Editor & Senior Moderator Staff Member

    Joined:
    Oct 9, 2007
    Messages:
    28,201 (11.41/day)
    Thanks Received:
    13,573
    Location:
    Bangalore, India
    Is this the driver you're using?
    [​IMG]
  16. Polaris573

    Polaris573 Senior Moderator

    Joined:
    Feb 26, 2005
    Messages:
    4,279 (1.25/day)
    Thanks Received:
    709
    Location:
    Little Rock, USA
    Actually. I guess I didn't have the latest drivers. I've formatted my computers so many times recently that I must have been thinking of a different time. No matter, updating the drivers made things worse since I no longer can hear anything out of the rear speakers. Although I do have all the sliders now.
  17. btarunr

    btarunr Editor & Senior Moderator Staff Member

    Joined:
    Oct 9, 2007
    Messages:
    28,201 (11.41/day)
    Thanks Received:
    13,573
    Location:
    Bangalore, India
    Ah, at this point click default in all three consoles, specify your speaker config again.


    Just asking, are the speakers connected to the right jacks? :eek:
    Polaris573 says thanks.
  18. imperialreign

    imperialreign New Member

    Joined:
    Jul 19, 2007
    Messages:
    7,043 (2.76/day)
    Thanks Received:
    909
    Location:
    Sector ZZ₉ Plural Z Alpha
    curious . . .


    Polaris - how exactly have you been removing or rolling back your drivers? It's starting to sound like a driver wasn't removed correctly, or remnants were left after a driver uninstall . . .
    Polaris573 says thanks.
  19. Polaris573

    Polaris573 Senior Moderator

    Joined:
    Feb 26, 2005
    Messages:
    4,279 (1.25/day)
    Thanks Received:
    709
    Location:
    Little Rock, USA
    Haha. Fair enough question since I didn't have the latest drivers installed when I told you I did, but yes that is one thing I'm sure of.

    Everything appears to be good now. I guess that one driver version between the latest and the first drivers was just extraordinarily buggy.

    I've been reading on the creative forums. I found several people who were experiencing the same difficulty as me. The problem appears to occur when you use windows update to update your drivers. This both accounts for why I thought I had the latest drivers and possible driver corruption. I had installed the latest drivers from creative's website but windows update told me there were newer ones out. So in my haste I grabbed those and have been using headphones for the past several weeks and didn't notice my rear speaker trouble.

    Lesson? Don't be lazy and use windows update.

    I'm pretty stingy with using the thanks button, but both of you guys get one for pointing out my rookie mistake of not having the right drivers. Many thanks and goodnight.
  20. imperialreign

    imperialreign New Member

    Joined:
    Jul 19, 2007
    Messages:
    7,043 (2.76/day)
    Thanks Received:
    909
    Location:
    Sector ZZ₉ Plural Z Alpha
    not a big supported or MS update myself, I've caught it trying to install updates that I don't want . . . :mad:


    glad you've got it figured out, though :toast:

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page