1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

X58 AHCI drivers?

Discussion in 'General Hardware' started by aquax, Jun 21, 2009.

  1. aquax New Member

    Joined:
    Aug 5, 2008
    Messages:
    141 (0.06/day)
    Thanks Received:
    13
    Hi guys, I have WD 1TB Black, and I noticed it is using UDMA5 and it should support UDMA6, in the bios, the Sata is set to [IDE] by default, I changed it to [AHCI], windows booted fine, but there is 2 question mark in device manager "Standard IDE controller" appeared and windows can't find driver for it and also still HDD working @ UDM5, I'm not able to find driver for the AHCI, I tried the intel matrix manager, but it says can't be installed. any ideas?

    Thanks
     
  2. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,897 (13.07/day)
    Thanks Received:
    14,304
    Motherboard CD?
     
  3. Laurijan

    Laurijan

    Joined:
    Feb 10, 2007
    Messages:
    2,251 (0.79/day)
    Thanks Received:
    352
    Location:
    Oulu, Finland
  4. siLc New Member

    Joined:
    Jun 28, 2008
    Messages:
    10 (0.00/day)
    Thanks Received:
    0
    Location:
    Tallinn, Estonia
  5. aquax New Member

    Joined:
    Aug 5, 2008
    Messages:
    141 (0.06/day)
    Thanks Received:
    13
    Thanks for the help but I already have the latest Intel Chipset Inf installed, the IATA doesn't want to install, it say something about system doesn't meet requirement
     
  6. 95Viper

    95Viper

    Joined:
    Oct 12, 2008
    Messages:
    4,442 (1.99/day)
    Thanks Received:
    1,623
    Location:
    στο άλφα έως ωμέγα
    Where do you have the drive connected on the MB?

    OK, that's great, glad you solved it!:)
     
    Last edited: Jun 21, 2009
  7. aquax New Member

    Joined:
    Aug 5, 2008
    Messages:
    141 (0.06/day)
    Thanks Received:
    13
    it is fixed guys

    here is what I did "If you installed Vista with the BIOS set to IDE make sure you do the below before you enable AHCI:
    Type regedit in the start box. Go to HKEY_LOCAL_MACHINE, SYSTEM, ControlSet001, Services, msahci.
    In the name panel to the right select start, right click and select modify from the drop down. Under it set the value data to 0. Select OK.
    Restart. Go into the BIOS and enable AHCI. When Vista boots it should install Vista's AHCI driver"
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page