1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

XFX 5870 bios ISO from XFX support, just burn it & reboot?

Discussion in 'AMD / ATI' started by poohbear, Jan 13, 2011.

  1. poohbear New Member

    Joined:
    Dec 31, 2010
    Messages:
    27 (0.02/day)
    Thanks Received:
    2
    Hey all, so XFX support emailed me the latest bios for my 5870 XXX edition (587AZN3B) in an ISO format. The ISO includes the Bootup disc and the bios itself according to ISObuster (a program that reads the contents of an ISO). They told me to just burn the ISO and flash from the CD.

    I burned a CD w/ the ISO, but the CD is all blank? Is this normal with a bootable CD with the VGA BIOS on it? I thought i could see the files on the CD? I checked if their hidden files but not, the CD is just blank.:( Just wanna be extra careful that this is normal? i.e. bootable discs with BIOS' on em are blank when opened? Sorry if i sound like a complete noob, first time flashing a VGA bios.

    Just wanna quickly confirm here as XFX support takes a couple of days to respond.:( Thanks a ton in advance!
     
  2. Qed New Member

    Joined:
    Dec 29, 2010
    Messages:
    102 (0.07/day)
    Thanks Received:
    3
    Extract the iso with any program (like 7-zip) and check if there are fiels inside.
     
  3. poohbear New Member

    Joined:
    Dec 31, 2010
    Messages:
    27 (0.02/day)
    Thanks Received:
    2
    yes like i said there is a "boot disc" file (consists of 2 files: BootImage.img & BootCatalog.cat) and the 587AZN3B.bin Bios file. There is no flash utility that i can see, but this can just be automated in the "bootdisc". The problem is when i burn to CD, the CD is empty. Is this normal for a boot disc?
     
  4. brandonwh64

    brandonwh64 Addicted to Bacon and StarCrunches!!!

    Joined:
    Sep 6, 2009
    Messages:
    18,584 (10.10/day)
    Thanks Received:
    6,091
    Location:
    Chatsworth, GA
    I posted this in another thread. all you have to do after following those steps is to set press the boot key while the system is booting (like F2 or F12) and select your flash drive. then it should boot into dos were you can flash your card
     
    Crunching for Team TPU
  5. poohbear New Member

    Joined:
    Dec 31, 2010
    Messages:
    27 (0.02/day)
    Thanks Received:
    2
    brandon, XFX already gave me an ISO with a boot disc and the bios on it, so i dont need to create a boot disc. im just confirming if its normal that the CD be empty when i burned the ISO to it? Boot discs usually dont display any files, or am i doing something wrong?
     
  6. Qed New Member

    Joined:
    Dec 29, 2010
    Messages:
    102 (0.07/day)
    Thanks Received:
    3
    No, boot disks have files in it, the only thing you cant see is the boot sector and i dont even this it is possible to store so much information, like a bios and a flashing program, in it.
     
  7. poohbear New Member

    Joined:
    Dec 31, 2010
    Messages:
    27 (0.02/day)
    Thanks Received:
    2
    hmmmm, strange then. The ISO file is 2.86 mb, does that sound about right for a boot disc & VGA bios?
     
  8. I see SPY!

    I see SPY! New Member

    Joined:
    Sep 29, 2009
    Messages:
    334 (0.18/day)
    Thanks Received:
    73
    Location:
    Porto, Portugal
    Why don't you use virtualbox to see if the cd has whetever it needs and boots correctly?
     
  9. poohbear New Member

    Joined:
    Dec 31, 2010
    Messages:
    27 (0.02/day)
    Thanks Received:
    2
    i see, and what would that involve? I'm downloading it now, 75mb, but what would i do with it exactly?
     
  10. Qed New Member

    Joined:
    Dec 29, 2010
    Messages:
    102 (0.07/day)
    Thanks Received:
    3
    Yes, it's is plausible. Do what i asked you if you want further help.
     
  11. Qed New Member

    Joined:
    Dec 29, 2010
    Messages:
    102 (0.07/day)
    Thanks Received:
    3
    There are many tools not even booting from Virtualbox. Useless test.
     
  12. poohbear New Member

    Joined:
    Dec 31, 2010
    Messages:
    27 (0.02/day)
    Thanks Received:
    2
    In my first post i said used ISObuster to view the contents of the ISO, it has the boot disc files and the VGA bios .bin file. Its when i burn the ISO to the CD that i have problems: the CD is just blank.:( so maybe this is a cd burning issue and not an ISO issue then?
     
  13. I see SPY!

    I see SPY! New Member

    Joined:
    Sep 29, 2009
    Messages:
    334 (0.18/day)
    Thanks Received:
    73
    Location:
    Porto, Portugal
    Just install it, create a new machine, attach the iso and boot it up.

    clicky
     
  14. Qed New Member

    Joined:
    Dec 29, 2010
    Messages:
    102 (0.07/day)
    Thanks Received:
    3
    Ok, use a non trash program to extract the iso then.
     
  15. poohbear New Member

    Joined:
    Dec 31, 2010
    Messages:
    27 (0.02/day)
    Thanks Received:
    2
    Qed what's a non-trash program? Sorry im not following.

    k will give this a shot, maybe its safer than throwing the CD in and trying it for real.
     
  16. Qed New Member

    Joined:
    Dec 29, 2010
    Messages:
    102 (0.07/day)
    Thanks Received:
    3
    As i wrote

     
    poohbear says thanks.
  17. poohbear New Member

    Joined:
    Dec 31, 2010
    Messages:
    27 (0.02/day)
    Thanks Received:
    2
    lol ok i get it, u mean ISObuster is a trash program?:p ok used 7zip to view the ISO & it has all the files displayed, its a full on boot disk with ATIflash and my VGA bios, basicly its all i need. But why can't i see the files on the CD when i burn the ISO image?

    Is MagicISO another trash program for burning ISOs? what's a better program for burning ISOs?
     
  18. Qed New Member

    Joined:
    Dec 29, 2010
    Messages:
    102 (0.07/day)
    Thanks Received:
    3
    ISO can have different options for the extraction/creation and these small programs are plain awful. To burn iso use Nero or Windows 7 build in function to burn files.
     
    poohbear says thanks.
  19. poohbear New Member

    Joined:
    Dec 31, 2010
    Messages:
    27 (0.02/day)
    Thanks Received:
    2
    ok cool, i'll tinker around some other programs. 7zip showed me that the ISO is'nt empty and its the real deal, so i'll sort out the CD burning stuff. Cheers mate and thanks for your help!

    PS burned it successfully, guess "test burn" should be off when burning!lol i feel like such a noob!

    trie das CD it in my test rig w/ integrated graphics and it said "adapter not found" when booting from CD, so yes guess its working or trying to flash vid card (despite not displaying any files on the boot cd). thanks folks.
     
    Last edited: Jan 13, 2011

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page