• We've upgraded our forums. Please post any issues/requests in this thread.

Search results

  1. S

    ASUS 7870 underperforming?? Am i bottlenecking??

    Switch PSU connectors I would try to switch the connectors used on your PSU to the VGA. I had similar issues with my XFX 7870 Black Edition. It were connected to the default cable-tree with two 6 pin connectors. On my cable select PSU I had two spare plugs stating PCIe and these and maybe only...
  2. S

    XFX HD 5970 Boot Issues

    Hi, I am not sure if this may help you out, but I expierenced a heavy difference by changing the wires that were attached to my 7870. Before I had used the two 6pins (leaving the additional 2 pin spared) that were hard attached to my PSU - by now I guess these were reserved for the CPU or...
  3. S

    Ati HD 5970 running slower than ussual?

    Dedicated PCIe PSU Cable Hi, I am not sure if this may help you out, but I expierenced a heavy difference by changing the wires that were attached to my 7870. Before I had used the two 6pins (leaving the additional 2 pin spared) that were hard attached to my PSU - by now I guess these were...
  4. S

    [Fixed] XFX Radeon HD7870 Black Edition / Bios Flash Gone Wrong / Adapter not found

    Hi Folks, as there are many wrong-flashed cards out there and I fixed mine with the solution by wizard I would say thank you wizard :respect: it helped me to restore my card when all other options were gone. Before was: - wrong flashed card (Tahiti LE bios on a Pitcairn card) - adapter...