• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

2x D5 pump in single loop constant 'splash' noise

Joined
Sep 5, 2009
Messages
108 (0.04/day)
Likes
4
System Name D.e.l.i.f.i.o.n
Processor Intel i7 930 @ 4.3GHz 1.312 vcore
Motherboard Gigabyte GA EX58-UD5 + EK FB-KIT GA X58
Cooling EK Supreme HF
Memory Dominator GT 3x2GB 1866C7
Video Card(s) EVGA GTX 480 + EK Waterblock
Storage G.Skill Falcon 128
Display(s) Acer X243H
Case Thermaltake Armor Plus
Power Supply Enermax 1250w
Software Win 7 Pro x64
#1
Hi,

I changed my reservoir to ek multi option 250 (I used EK bay res before).
Everything seems to be working just fine, but the pump is making a 'splash' noise now. It did make the noise when I bleed it for the first time. Sounds like air bubble trapped in the pump???
 
Joined
May 22, 2010
Messages
2,516 (0.90/day)
Likes
680
Location
Canada
System Name m1dg3t | DeathBox | HairPi 3
Processor 3570k @ 4.0 1.15v BIOS | q9550 @ 3.77 1.325v BIOS
Motherboard Asrock z77e iTX | p5q Dlx 2301 BIOS
Cooling Custom Water | D-14 & HR-03gt | Passive HSF
Memory Samsung MV-3V4G3D 4g x 2 @ 1866 1.35v | OcZ RpR 2g x 4 @ 1067 2.2v
Video Card(s) MSi 7950 tf3 @1000 / 1350 | Asus 5870 V2 @ 900 / 1275
Storage Adata sx900 256Gb / WD 2500 HHTZ | WD 1001 FALS x 2
Display(s) BenQ gw2750hm | 46" Sharp Quatron
Case BitFenix Prodigy - m0dd3d | Antec Fusion Remote MAX
Audio Device(s) Onboard Toslink > Yamaha HTR 6290 | Xonar HDAV1.3 > Yamaha DSP z7
Power Supply Ocz mXp700w | Ocz zx850w | Cannakit 5v 2.5a
Mouse Logitech G700s | Logitech G9x - Cable Repaired
Keyboard TT Meka G1 - Black w Cherry Blacks| Logitech G11
Software Win7 Home | Xp sp3 & Vista ultimate | Raspbian
Benchmark Scores Epeen!! Who needs epeen??
#2
How long has it been running for? Sometime's bleeding can take a lil' longer than expected. Patience is key here i think....