• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

6900XT Liquid Devil Issues (Maybe?)

Joined
Jan 23, 2011
Messages
353 (0.09/day)
Location
St. Louis, MO
System Name Alienware 17R4 / Desktop
Processor Intel Core i7-6820HK @ 3.6 Ghz / AMD Ryzen 9 5900X
Motherboard Alienware 17R4 / ASUS X570-F
Cooling Laptop Cooling / EK-Velocity D-RGB
Memory 32GB Crucial Ballistix LT DDR4-2400 / 32GB Crucial Ballistix DDR4-3600
Video Card(s) Nvidia Geforce 1070 GTX (Internal) / Powercolor Liquid Devil 6900XT
Storage 500GB WD Black NVMe / 1TB Inland Premium / 1TB WD Black SN850 / 2TB Inland Premium
Display(s) ASUS TUF VG279QM
Case Alienware 17R4 / Lian-Li Dynamic 011 XL ROG
Audio Device(s) Logitech G933 Artemis / EVGA Nu Audio Pro w/ Beyerdynamic DT 990 Pro Red Dragon GM300 Microphone
Power Supply 330W Dell PSU / EVGA P2 1200W Platinum
Mouse Logitech M600 / Logitech G903 / Razer Viper Chroma / Razer Naga Infinity
Keyboard Logitech G613 /Razer Huntsman Elite / Tartarus Pro
Welp I got my 6900XT Liquid Devil and apparently my 850W Power Supply didn't like it..... so I have a 1200W now......

Either something in my loop is messed up, my fans aren't that good, or something is up with this card.... it is pegging at 84C on the core and the hot spot hits 114C.....

My CPU hits around 70C now...... Would this card put out that much more heat than a 2080 Super to elevate my CPU temps about 10C??? I don't appear to have any thermal throttling, my card isn't hot to the touch.....

Would some slight kinks in the loop that were there before make that much of a different now??? I can get some pictures.... I use 10mm/16mm soft tubing. Each radiator has a bit of a tight bend.
 
Joined
Feb 6, 2021
Messages
721 (3.18/day)
Location
Germany
Processor AMD Ryzen 9 5950X (and a LOT of other CPUs)
Motherboard MSI B550 Tomahawk
Cooling Corsair H150i RGB Pro XT
Memory G.Skill Trident Z Neo 3600 Mhz CL16 (2x16GB)
Video Card(s) All Ampere, two 6900XTs and other RDNA2, all Turing, all Pascal, Vegas, 980 Tis and older.
Storage Corsair MP 600 Pro 1TB, 2x Samsung 870 QVO 4TB, Samsung 870 Evo 500GB (Backup)
Display(s) Samsung Odyssey G7 32"
Case Fractal Design Meshify S2 White TG / Noctua NF-A14 iPPC-3000RPM Fans
Audio Device(s) Bose Companion Series 2 III, Sennheiser GSP600 running through a SoundblasterX G6
Power Supply bequiet! Dark Power Pro 12 1200w Titanium
Mouse Glorious PC Gaming Race Model O, G903 Hero, G502 Hero SE, Deathadder V2, EC2-A
Keyboard ASUS ROG Strix Scope TKL DLX, Corsair K95, Logitech G815
VR HMD Oculus Rift S
114°C on the hotspot is over 15°C higher than my Nitro + runs at almost 400W (~390W, 400W Limit)
and that's on air with the (pretty underwhelming) lightweight stock heatsink.
 
Joined
Jan 23, 2011
Messages
353 (0.09/day)
Location
St. Louis, MO
System Name Alienware 17R4 / Desktop
Processor Intel Core i7-6820HK @ 3.6 Ghz / AMD Ryzen 9 5900X
Motherboard Alienware 17R4 / ASUS X570-F
Cooling Laptop Cooling / EK-Velocity D-RGB
Memory 32GB Crucial Ballistix LT DDR4-2400 / 32GB Crucial Ballistix DDR4-3600
Video Card(s) Nvidia Geforce 1070 GTX (Internal) / Powercolor Liquid Devil 6900XT
Storage 500GB WD Black NVMe / 1TB Inland Premium / 1TB WD Black SN850 / 2TB Inland Premium
Display(s) ASUS TUF VG279QM
Case Alienware 17R4 / Lian-Li Dynamic 011 XL ROG
Audio Device(s) Logitech G933 Artemis / EVGA Nu Audio Pro w/ Beyerdynamic DT 990 Pro Red Dragon GM300 Microphone
Power Supply 330W Dell PSU / EVGA P2 1200W Platinum
Mouse Logitech M600 / Logitech G903 / Razer Viper Chroma / Razer Naga Infinity
Keyboard Logitech G613 /Razer Huntsman Elite / Tartarus Pro
These are what I would think are the two areas that could be restricting flow.
 

Attachments

  • A159C9FA-66B1-4885-A8B7-94D169DC6D41.jpeg
    A159C9FA-66B1-4885-A8B7-94D169DC6D41.jpeg
    1.3 MB · Views: 62
  • AA0F4630-9A65-421C-B1E6-C8C181C35BC6.jpeg
    AA0F4630-9A65-421C-B1E6-C8C181C35BC6.jpeg
    1.2 MB · Views: 56
Joined
Oct 26, 2008
Messages
2,171 (0.46/day)
System Name Budget AMD System
Processor Threadripper 1900X @ 4.025Ghz (100x40.25 @ 1.325V)
Motherboard Gigabyte X399 Aorus Gaming 7
Cooling EKWB X399 Monoblock
Memory 4x8GB GSkill TridentZ RGB 12-12-13-32 CR1 @ 3200
Video Card(s) XFX Radeon RX Vega₆⁴ Liquid @ 1,800Mhz Core, 1100 HBM2
Storage 1x ADATA SX8200 NVMe, 1x Segate 2.5" FireCuda 2TB SATA, 1x 500GB HGST SATA
Display(s) Vizio 22" 1080p 60hz TV (Samsung Panel)
Case Corsair 570X
Audio Device(s) Onboard
Power Supply Seasonic X Series 850W KM3
Software Windows 10 Pro x64
Do you have a general overview pic of your whole system? Kinda give us an idea as to flow pattern etc?
 
Joined
Jan 23, 2011
Messages
353 (0.09/day)
Location
St. Louis, MO
System Name Alienware 17R4 / Desktop
Processor Intel Core i7-6820HK @ 3.6 Ghz / AMD Ryzen 9 5900X
Motherboard Alienware 17R4 / ASUS X570-F
Cooling Laptop Cooling / EK-Velocity D-RGB
Memory 32GB Crucial Ballistix LT DDR4-2400 / 32GB Crucial Ballistix DDR4-3600
Video Card(s) Nvidia Geforce 1070 GTX (Internal) / Powercolor Liquid Devil 6900XT
Storage 500GB WD Black NVMe / 1TB Inland Premium / 1TB WD Black SN850 / 2TB Inland Premium
Display(s) ASUS TUF VG279QM
Case Alienware 17R4 / Lian-Li Dynamic 011 XL ROG
Audio Device(s) Logitech G933 Artemis / EVGA Nu Audio Pro w/ Beyerdynamic DT 990 Pro Red Dragon GM300 Microphone
Power Supply 330W Dell PSU / EVGA P2 1200W Platinum
Mouse Logitech M600 / Logitech G903 / Razer Viper Chroma / Razer Naga Infinity
Keyboard Logitech G613 /Razer Huntsman Elite / Tartarus Pro
This might help. I have a distribution plate for my case.
 

Attachments

  • D5296E99-9972-435D-88F2-3FF4C4279986.jpeg
    D5296E99-9972-435D-88F2-3FF4C4279986.jpeg
    1.3 MB · Views: 73
Joined
Nov 11, 2016
Messages
1,830 (1.03/day)
System Name The de-ploughminator
Processor I7 9900K @ 5.1Ghz
Motherboard Gigabyte Z370 Gaming 5
Cooling Custom Watercooling
Memory 4x8GB G.Skill Trident Neo 3600mhz 15-15-15-30
Video Card(s) RTX 3090 + Bitspower WB
Storage Plextor 512GB nvme SSD
Display(s) LG OLED CX48"
Case Lian Li 011D Dynamic
Audio Device(s) Creative AE-5
Power Supply Corsair HX850
Mouse Razor Viper Ultimate
Keyboard Corsair K75
Software Win10
do you still have the manual for your distro plate? your watercooling loop order is looking rather weird to me and I have the Sedna 011 Distro plate in the LianLi 011D case
 
Joined
Oct 26, 2008
Messages
2,171 (0.46/day)
System Name Budget AMD System
Processor Threadripper 1900X @ 4.025Ghz (100x40.25 @ 1.325V)
Motherboard Gigabyte X399 Aorus Gaming 7
Cooling EKWB X399 Monoblock
Memory 4x8GB GSkill TridentZ RGB 12-12-13-32 CR1 @ 3200
Video Card(s) XFX Radeon RX Vega₆⁴ Liquid @ 1,800Mhz Core, 1100 HBM2
Storage 1x ADATA SX8200 NVMe, 1x Segate 2.5" FireCuda 2TB SATA, 1x 500GB HGST SATA
Display(s) Vizio 22" 1080p 60hz TV (Samsung Panel)
Case Corsair 570X
Audio Device(s) Onboard
Power Supply Seasonic X Series 850W KM3
Software Windows 10 Pro x64
This might help. I have a distribution plate for my case.
Is that how you have the flow setup?

I am also echoing what nguyen is saying.. I'd have to see the distro plate manual to see flow. Something just doesn't seem right because if you got a rad up top and below.. that shouldn't be running that hot.
 

Attachments

  • D5296E99-9972-435D-88F2-3FF4C4279986.jpeg
    D5296E99-9972-435D-88F2-3FF4C4279986.jpeg
    1.9 MB · Views: 39
Joined
Jan 23, 2011
Messages
353 (0.09/day)
Location
St. Louis, MO
System Name Alienware 17R4 / Desktop
Processor Intel Core i7-6820HK @ 3.6 Ghz / AMD Ryzen 9 5900X
Motherboard Alienware 17R4 / ASUS X570-F
Cooling Laptop Cooling / EK-Velocity D-RGB
Memory 32GB Crucial Ballistix LT DDR4-2400 / 32GB Crucial Ballistix DDR4-3600
Video Card(s) Nvidia Geforce 1070 GTX (Internal) / Powercolor Liquid Devil 6900XT
Storage 500GB WD Black NVMe / 1TB Inland Premium / 1TB WD Black SN850 / 2TB Inland Premium
Display(s) ASUS TUF VG279QM
Case Alienware 17R4 / Lian-Li Dynamic 011 XL ROG
Audio Device(s) Logitech G933 Artemis / EVGA Nu Audio Pro w/ Beyerdynamic DT 990 Pro Red Dragon GM300 Microphone
Power Supply 330W Dell PSU / EVGA P2 1200W Platinum
Mouse Logitech M600 / Logitech G903 / Razer Viper Chroma / Razer Naga Infinity
Keyboard Logitech G613 /Razer Huntsman Elite / Tartarus Pro
Is that how you have the flow setup?

Yes, that is how I have it setup. The bottom is in, the top is out.

I have attached my manual. It appears to be in order, but a fresh set of eyes never hurts.
 

Attachments

  • EK-IM-3831109822128.pdf
    997 KB · Views: 34
Joined
Oct 26, 2008
Messages
2,171 (0.46/day)
System Name Budget AMD System
Processor Threadripper 1900X @ 4.025Ghz (100x40.25 @ 1.325V)
Motherboard Gigabyte X399 Aorus Gaming 7
Cooling EKWB X399 Monoblock
Memory 4x8GB GSkill TridentZ RGB 12-12-13-32 CR1 @ 3200
Video Card(s) XFX Radeon RX Vega₆⁴ Liquid @ 1,800Mhz Core, 1100 HBM2
Storage 1x ADATA SX8200 NVMe, 1x Segate 2.5" FireCuda 2TB SATA, 1x 500GB HGST SATA
Display(s) Vizio 22" 1080p 60hz TV (Samsung Panel)
Case Corsair 570X
Audio Device(s) Onboard
Power Supply Seasonic X Series 850W KM3
Software Windows 10 Pro x64
Yes, that is how I have it setup. The bottom is in, the top is out.

I have attached my manual. It appears to be in order, but a fresh set of eyes never hurts.

Im looking over the manual now. I don't run a distro plate in my setup. Mine is just a basic EK D5 PWM, rad and CPU block. GPU is the V64 Liquid.

I honestly don't see anything wrong with your plumbing. Its pretty simple and I don't see anything wrong placement wise. Its really a good setup.

My best guess, maybe the block's diffusion plate wasn't put in right? Because if your CPU temp went up that could mean a flow restriction in the block?
 
Joined
Nov 11, 2016
Messages
1,830 (1.03/day)
System Name The de-ploughminator
Processor I7 9900K @ 5.1Ghz
Motherboard Gigabyte Z370 Gaming 5
Cooling Custom Watercooling
Memory 4x8GB G.Skill Trident Neo 3600mhz 15-15-15-30
Video Card(s) RTX 3090 + Bitspower WB
Storage Plextor 512GB nvme SSD
Display(s) LG OLED CX48"
Case Lian Li 011D Dynamic
Audio Device(s) Creative AE-5
Power Supply Corsair HX850
Mouse Razor Viper Ultimate
Keyboard Corsair K75
Software Win10
Loop order looks correct, but 84C on the GPU is way too high for watercooling.
First try running the pump at maximum speed
Second use an IR Thermometer to check the water temp before entering the GPU and after exiting the GPU (point the IR thermometer at the fittings)

As a point of reference my GPU is running around 10C hotter than the water temp (water temp ~38C and GPU ~48C at maximum load), if your water temp is in the 40C and GPU running at 80C then the WB is not making good contact with the silicon.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
32,199 (6.20/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Contact TUL

What is your ambient temperature?
 
Joined
Jan 23, 2011
Messages
353 (0.09/day)
Location
St. Louis, MO
System Name Alienware 17R4 / Desktop
Processor Intel Core i7-6820HK @ 3.6 Ghz / AMD Ryzen 9 5900X
Motherboard Alienware 17R4 / ASUS X570-F
Cooling Laptop Cooling / EK-Velocity D-RGB
Memory 32GB Crucial Ballistix LT DDR4-2400 / 32GB Crucial Ballistix DDR4-3600
Video Card(s) Nvidia Geforce 1070 GTX (Internal) / Powercolor Liquid Devil 6900XT
Storage 500GB WD Black NVMe / 1TB Inland Premium / 1TB WD Black SN850 / 2TB Inland Premium
Display(s) ASUS TUF VG279QM
Case Alienware 17R4 / Lian-Li Dynamic 011 XL ROG
Audio Device(s) Logitech G933 Artemis / EVGA Nu Audio Pro w/ Beyerdynamic DT 990 Pro Red Dragon GM300 Microphone
Power Supply 330W Dell PSU / EVGA P2 1200W Platinum
Mouse Logitech M600 / Logitech G903 / Razer Viper Chroma / Razer Naga Infinity
Keyboard Logitech G613 /Razer Huntsman Elite / Tartarus Pro
My ambient temperature is between 20C and 22C. I like to keep my home a bit chilly.
 
Joined
Jul 16, 2018
Messages
63 (0.05/day)
Processor Intel Core i7-6700K 4.0GHz Quad-Core Processor
Motherboard MSI Z170I GAMING PRO AC
Cooling Corsair Hydro Series™ H100i GTX Extreme Performance Liquid CPU Cooler
Memory Corsair Dominator® Platinum Series 16GB (2 x 8GB) DDR4 DRAM 3000MHz C15 Memory Kit
Video Card(s) EVGA GeForce GTX 1070 FTW GAMING
Storage Corsair Neutron Series™ XT 240GB SATA 3 6Gb/s SSD (2015 Edition) x2 RAID 0
Display(s) ASUS ROG Swift PG279Q x2
Case Obsidian Series® 250D Mini ITX PC Case
Audio Device(s) Corsair VOID RGB Wireless Premium Gaming Headset
Power Supply Corsair RMi Series RM850i High-Performance ATX Power Supply
Mouse Corsair SCIMITAR RGB Optical MOBA/MMO Gaming Mouse
Keyboard Corsair STRAFE RGB Mechanical Gaming Keyboard — CHERRY® MX Silent
Software Microsoft Windows 10 PRO
That kink on the 120 mm radiator is a bit problematic. Collapsing will reduce the inner tube diameter and restrict the flow. Also I suggest to use the pump at 100% at all times.

Did you check the tightness of the GPU block before installation? or did you remove the GPU block from the card for any reason?
 
Joined
Nov 25, 2019
Messages
341 (0.51/day)
Location
Taiwan
Processor i5-9600K
Motherboard Gigabyte Z390 Gaming X
Cooling Scythe Mugen 5
Memory Micron Ballistix Sports LT 3000 8G*4
Video Card(s) MSI 2070 Ventus
Storage Adata SX6000 Pro 512G, Kingston A2000 1T
Display(s) Gigabyte M32Q
Case Phanteks Eclipse P350X
Audio Device(s) Edifier C3X
Power Supply Super Flower Leadex Gold 650W
Mouse Razer Basilisk V2
Keyboard Ducky ONE Horizon
Well if your CPU is heating up as well then you should reconsider if your radiators are dissipating the heat properly, check if their airflow is limited.
 
Joined
May 31, 2016
Messages
2,942 (1.52/day)
Location
Currently Norway
System Name Bro2
Processor Ryzen 5800X
Motherboard Gigabyte X570 Aorus Elite
Cooling Corsair h115i pro rgb
Memory 16GB G.Skill Flare X 3200 CL14
Video Card(s) Powercolor 6900 XT Red Devil 1.1v@2400Mhz
Storage M.2 Samsung 970 Evo Plus 500MB/ Samsung 860 Evo 1TB
Display(s) LG 27UD69 UHD / LG 27GN950
Case Fractal Design G
Audio Device(s) Realtec 5.1
Power Supply Corsair AXi 760W / Seasonic 750W GOLD
Mouse Logitech G402
Keyboard Logitech slim
Software Windows 10 64 bit
What temp you get when you run the system at idle? Does the temp rise exponentially even at idle state? I understand the liquid flow is there and there is no problem with it. It would suggest that maybe the heat sinks on the GPU and CPU are not correctly mounted. Also there's the heat dissipation matter and how is that being taken care off.
 
Joined
Jan 23, 2011
Messages
353 (0.09/day)
Location
St. Louis, MO
System Name Alienware 17R4 / Desktop
Processor Intel Core i7-6820HK @ 3.6 Ghz / AMD Ryzen 9 5900X
Motherboard Alienware 17R4 / ASUS X570-F
Cooling Laptop Cooling / EK-Velocity D-RGB
Memory 32GB Crucial Ballistix LT DDR4-2400 / 32GB Crucial Ballistix DDR4-3600
Video Card(s) Nvidia Geforce 1070 GTX (Internal) / Powercolor Liquid Devil 6900XT
Storage 500GB WD Black NVMe / 1TB Inland Premium / 1TB WD Black SN850 / 2TB Inland Premium
Display(s) ASUS TUF VG279QM
Case Alienware 17R4 / Lian-Li Dynamic 011 XL ROG
Audio Device(s) Logitech G933 Artemis / EVGA Nu Audio Pro w/ Beyerdynamic DT 990 Pro Red Dragon GM300 Microphone
Power Supply 330W Dell PSU / EVGA P2 1200W Platinum
Mouse Logitech M600 / Logitech G903 / Razer Viper Chroma / Razer Naga Infinity
Keyboard Logitech G613 /Razer Huntsman Elite / Tartarus Pro
I have attached my current idle temps. The system has been on for about 30 minutes. My current ambient temp is 21C. The temps do not rise while sitting idle.

That kink on the 120 mm radiator is a bit problematic. Collapsing will reduce the inner tube diameter and restrict the flow. Also I suggest to use the pump at 100% at all times.

Did you check the tightness of the GPU block before installation? or did you remove the GPU block from the card for any reason?

I did not modify or other disassemble the card prior to installation. This is out it is out of the box. I have all of my fans and pump at 100%. I have been bleeding the system for air and the reservoir has dropped about 1 inch since I filled it yesterday. I want to say I have a majority of the air out.

With this same setup I had the 2080 Super in my system prior and during gaming it never went over 50C and the CPU would bounce between 50C-60C depending on boost and load.

According to Powercolor's website, if you take the cooler off or make any modifications to the card, the warranty is void.

Loop order looks correct, but 84C on the GPU is way too high for watercooling.
First try running the pump at maximum speed
Second use an IR Thermometer to check the water temp before entering the GPU and after exiting the GPU (point the IR thermometer at the fittings)

As a point of reference my GPU is running around 10C hotter than the water temp (water temp ~38C and GPU ~48C at maximum load), if your water temp is in the 40C and GPU running at 80C then the WB is not making good contact with the silicon.

30C Into the block
20C Out of the block
 

Attachments

  • Capture.PNG
    Capture.PNG
    26.2 KB · Views: 23
Last edited:
Joined
Mar 10, 2009
Messages
148 (0.03/day)
Location
Mexico
System Name HTPC
Processor Intel Core i7-4790
Motherboard Gigabyte GA-H87N-WiFi Rev. 2.0
Cooling CoolerMaster MasterLiquid Pro 240
Memory Corsair 16Gb (2x8Gb) DDR3
Video Card(s) Sapphire RX5700XT Nitro+
Storage TOSHIBA 2Tb / ADATA SSD 240Gb
Display(s) BenQ EX2780Q
Case Corsair 250D
Audio Device(s) Realtek ALC892
Power Supply EVGA SuperNOVA 850 P2
Mouse Logitech G900
Keyboard Corsair Gaming K95 RGB
Software Microsoft Windows 10 Pro
Joined
Jan 23, 2011
Messages
353 (0.09/day)
Location
St. Louis, MO
System Name Alienware 17R4 / Desktop
Processor Intel Core i7-6820HK @ 3.6 Ghz / AMD Ryzen 9 5900X
Motherboard Alienware 17R4 / ASUS X570-F
Cooling Laptop Cooling / EK-Velocity D-RGB
Memory 32GB Crucial Ballistix LT DDR4-2400 / 32GB Crucial Ballistix DDR4-3600
Video Card(s) Nvidia Geforce 1070 GTX (Internal) / Powercolor Liquid Devil 6900XT
Storage 500GB WD Black NVMe / 1TB Inland Premium / 1TB WD Black SN850 / 2TB Inland Premium
Display(s) ASUS TUF VG279QM
Case Alienware 17R4 / Lian-Li Dynamic 011 XL ROG
Audio Device(s) Logitech G933 Artemis / EVGA Nu Audio Pro w/ Beyerdynamic DT 990 Pro Red Dragon GM300 Microphone
Power Supply 330W Dell PSU / EVGA P2 1200W Platinum
Mouse Logitech M600 / Logitech G903 / Razer Viper Chroma / Razer Naga Infinity
Keyboard Logitech G613 /Razer Huntsman Elite / Tartarus Pro
Given the thoughts here, I am going to disassemble the card and check the paste and block out. If I can’t resolve it, I can return the card to Microcenter.

Seeing as how any load causes the temperature to immediately spike, I am thinking that there is a thermal issue from the card to the block. Or possibly the diffusion plate wasn’t installed right.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
32,199 (6.20/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Given the thoughts here, I am going to disassemble the card and check the paste and block out. If I can’t resolve it, I can return the card to Microcenter.

Seeing as how any load causes the temperature to immediately spike, I am thinking that there is a thermal issue from the card to the block. Or possibly the diffusion plate wasn’t installed right.

Do not disassemble it, get it exhanged at MC.
 
Joined
Feb 23, 2019
Messages
2,910 (3.10/day)
Location
Poland
Processor Ryzen 7 3700X
Motherboard Gigabyte X570 Aorus Elite
Cooling BeQuiet Dark Rock 4
Memory 2x16 GB Crucial Ballistix 3600 CL16 Rev E
Video Card(s) EVGA 1060 6GB SSC
Storage SX8200 Pro 1 TB, Plextor M6Pro 256 GB, WD Blue 2TB
Display(s) Acer XB273GP
Case SilverStone Primera PM01 RGB
Power Supply SeaSonic Focus Plus Gold 750W
Mouse SteelSeries Rival 300
Keyboard MK Typist (Kailh Box White)
Given the thoughts here, I am going to disassemble the card and check the paste and block out. If I can’t resolve it, I can return the card to Microcenter.

Seeing as how any load causes the temperature to immediately spike, I am thinking that there is a thermal issue from the card to the block. Or possibly the diffusion plate wasn’t installed right.
Ditch the card.
 
Joined
Oct 30, 2008
Messages
1,901 (0.40/day)
Processor 5930K
Motherboard MSI X99 SLI
Cooling WATER
Memory 16GB DDR4 2132
Video Card(s) EVGAY 2070 SUPER
Storage SEVERAL SSD"S
Display(s) Catleap/Yamakasi 2560X1440
Case D Frame MINI drilled out
Audio Device(s) onboard
Power Supply Corsair TX750
Mouse DEATH ADDER
Keyboard Razer Black Widow Tournament
Software W10HB
Benchmark Scores PhIlLyChEeSeStEaK
Can you rotate and move the system while the pump is running? It would appear you have several air bubbles in your loop that will not leave till the system is moved while running...the more parts, plates, the more air will hide in the system.
 
Joined
Feb 17, 2010
Messages
818 (0.19/day)
System Name Borg Cube
Processor R5 3600
Motherboard X470 Taichi
Cooling Water
Memory 32GB @3800CL16
Video Card(s) RX Vega 64
Storage Silicon Power A80 1TB x2
Display(s) Samsung UE590
Case HAF XB
Audio Device(s) Logitech Z623
Power Supply LEADEX III
Mouse Cooler Master MM710
Keyboard Logi G105
Software 10 Pro
Benchmark Scores https://hwbot.org/user/damric/
Yeah it sounds like an air bubble is trapped. Is the pump making a gurgle noise?
 
Joined
Aug 27, 2011
Messages
810 (0.22/day)
Processor Intel core i9 10900k @5.5ghz
Motherboard Asus Maximus XII APEX
Cooling Custom loop 3*360 45mm thick+ 3 x mo-ra3 420 +Dual D5 pump and dual ddc pump
Memory 2x16gb Gskillz Trident Z 4600mhz cl16
Video Card(s) EVGA FTW3 ULTRA RTX 3090
Storage 1TB Samsung 860Evo,2*2tb Samsung 970Evo Plus, 1tb Intel 660p nvme
Display(s) LG Ultragear 27" IPS 1440P 144HZ
Case Dynamic XL
Audio Device(s) Creative Omni 5.1 usb sound card
Power Supply Corsair AX1600i
Mouse Model O-
Keyboard Hyper X Alloy Origin Core
Buy a flow and thermal sensor for your loop. Probably a bad mount on a gpu block or your water temp is too high.
 
Joined
Jan 23, 2011
Messages
353 (0.09/day)
Location
St. Louis, MO
System Name Alienware 17R4 / Desktop
Processor Intel Core i7-6820HK @ 3.6 Ghz / AMD Ryzen 9 5900X
Motherboard Alienware 17R4 / ASUS X570-F
Cooling Laptop Cooling / EK-Velocity D-RGB
Memory 32GB Crucial Ballistix LT DDR4-2400 / 32GB Crucial Ballistix DDR4-3600
Video Card(s) Nvidia Geforce 1070 GTX (Internal) / Powercolor Liquid Devil 6900XT
Storage 500GB WD Black NVMe / 1TB Inland Premium / 1TB WD Black SN850 / 2TB Inland Premium
Display(s) ASUS TUF VG279QM
Case Alienware 17R4 / Lian-Li Dynamic 011 XL ROG
Audio Device(s) Logitech G933 Artemis / EVGA Nu Audio Pro w/ Beyerdynamic DT 990 Pro Red Dragon GM300 Microphone
Power Supply 330W Dell PSU / EVGA P2 1200W Platinum
Mouse Logitech M600 / Logitech G903 / Razer Viper Chroma / Razer Naga Infinity
Keyboard Logitech G613 /Razer Huntsman Elite / Tartarus Pro
Can you rotate and move the system while the pump is running? It would appear you have several air bubbles in your loop that will not leave till the system is moved while running...the more parts, plates, the more air will hide in the system.
Yeah it sounds like an air bubble is trapped. Is the pump making a gurgle noise?

I have been tilting the case back and holding it for a bit while the pump runs. I have seen some bubbles move from the blocks and through the radiators into the distribution plate. I should probably tilt it the other way and try to get more out. Seems like a logical step aside from draining and starting again.

I haven’t heard the pump making any gurgling noise. It is whisper quiet.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
32,199 (6.20/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I have been tilting the case back and holding it for a bit while the pump runs. I have seen some bubbles move from the blocks and through the radiators into the distribution plate. I should probably tilt it the other way and try to get more out. Seems like a logical step aside from draining and starting again.

I haven’t heard the pump making any gurgling noise. It is whisper quiet.

Contact Tul for help/RMA or exhange it at MC,
 
Top