• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

6950 black screen while gaming

Joined
Aug 17, 2009
Messages
1,577 (0.51/day)
Likes
461
Location
Los Angeles/Orange County CA
System Name Vulcan
Processor i6 6600K
Motherboard GIGABYTE Z170X UD3
Cooling Thermaltake Frio Silent 14
Memory 16GB Corsair Vengeance LPX 16GB (2 x 8GB)
Video Card(s) ASUS Strix GTX 970
Storage Mushkin Enhanced Reactor 1TB SSD
Display(s) QNIX 27 Inch 1440p
Case Fractal Design Define S
Audio Device(s) On Board
Power Supply Cooler Master V750
Software Win 10 64-bit
#1
I have this sapphire hd 6950 2gb for about 18 months and it just started doing this.

Went into a game and got a black screen. System would not respond to Ctrl-Alt-Del, Atl-Tab, reset button or anything. Had to force power down.

Had a mild overclock on, but now it's reset and still doing it. Tried a different game, 3dmark11, same thing. After a few minutes black screen.

Going to reinstall catalyst, but I'm pretty sure something else is going on. GPU, PSU, memory, motherboard...don't know which.

Any ideas would be appreciated.

ADD:

Forgot that I'm running a 4.8GHz overclock, so testing at default and so far looking good. Perhaps it wasn't as stable as I thought at that speed, but still not sure yet.
 
Last edited:
Joined
Jan 24, 2010
Messages
3,578 (1.23/day)
Likes
1,918
Location
Oregon, USA
System Name GLaDOS
Processor AMD Phenom II X6 1055T 2.8 ghz
Motherboard MSI 990FXA-GD65
Cooling Corsair H50
Memory Corsair DDR3 1333Mhz (2 x 4GB)
Video Card(s) MSI R7970
Storage 2 WD Blue 500GBs, 1 WD 1TB
Display(s) 2 Acer S231HL 23" LED backlit LCD's on a Dual LCD stand
Case Corsair 600T White edition
Audio Device(s) Onboard
Power Supply Corsair 850HX 850W
Software Microsoft Windows 7 Ultimate 64-bit
#2
I'd do testing with Furmark, if it get's the same, try different drivers, if still the same, I'd say there's something wrong with your system or the card.
 
Last edited:
Joined
Aug 17, 2009
Messages
1,577 (0.51/day)
Likes
461
Location
Los Angeles/Orange County CA
System Name Vulcan
Processor i6 6600K
Motherboard GIGABYTE Z170X UD3
Cooling Thermaltake Frio Silent 14
Memory 16GB Corsair Vengeance LPX 16GB (2 x 8GB)
Video Card(s) ASUS Strix GTX 970
Storage Mushkin Enhanced Reactor 1TB SSD
Display(s) QNIX 27 Inch 1440p
Case Fractal Design Define S
Audio Device(s) On Board
Power Supply Cooler Master V750
Software Win 10 64-bit
#3
Ok, been testing with furmak and now back at 4.6GHz on the CPU and running the card at stock. All is well.

I also was trying different monitors and didn't have any trouble on the others. But I think the real trick was reseating the card.

Now going to oc the gpu again and see what happens.
 
Joined
Jan 24, 2010
Messages
3,578 (1.23/day)
Likes
1,918
Location
Oregon, USA
System Name GLaDOS
Processor AMD Phenom II X6 1055T 2.8 ghz
Motherboard MSI 990FXA-GD65
Cooling Corsair H50
Memory Corsair DDR3 1333Mhz (2 x 4GB)
Video Card(s) MSI R7970
Storage 2 WD Blue 500GBs, 1 WD 1TB
Display(s) 2 Acer S231HL 23" LED backlit LCD's on a Dual LCD stand
Case Corsair 600T White edition
Audio Device(s) Onboard
Power Supply Corsair 850HX 850W
Software Microsoft Windows 7 Ultimate 64-bit
#4
Stock cooling/thermal paste?
 
Joined
Aug 17, 2009
Messages
1,577 (0.51/day)
Likes
461
Location
Los Angeles/Orange County CA
System Name Vulcan
Processor i6 6600K
Motherboard GIGABYTE Z170X UD3
Cooling Thermaltake Frio Silent 14
Memory 16GB Corsair Vengeance LPX 16GB (2 x 8GB)
Video Card(s) ASUS Strix GTX 970
Storage Mushkin Enhanced Reactor 1TB SSD
Display(s) QNIX 27 Inch 1440p
Case Fractal Design Define S
Audio Device(s) On Board
Power Supply Cooler Master V750
Software Win 10 64-bit
#5
It is water cooled, and doesn't go over 60c usually. Didn't anything out of the ordinary with the temps.

But since reseating the card I have not had the same issue of the screen going black and the system hanging. Even put back my modest oc on the GPU.

Here's hoping that's all it was.