• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

A770DE+ no sound after reinstal win 10

fantomix

New Member
Joined
Apr 16, 2018
Messages
4 (0.03/day)
Likes
4
#1
A few days ago there was sound,
but today I can not install drivers,tried all version
but there is no sound.


sorry for bad language
google translator
please help
 
Joined
Feb 19, 2006
Messages
6,135 (1.34/day)
Likes
1,764
Location
New York
System Name http://www.heatware.com/eval.php?id=73751
Processor Tracer II 15 VR800 I7 7700HQ/GTX1070 16GB DDR4/2133MHz /ASUS GL553VW GTX 960M 4GB i56300HQ 8GB DDR4
Motherboard i7-920 CO@4.2GHZ/Asus P6T Deluxe Intel X58
Cooling Asetek Liquid CPU Cooling System
Memory CORSAIR DOMINATOR 6GB (3 x 2GB) DDR3 1600
Video Card(s) 2X ATI Radeon HD 4870 X2 2GB DDR5 PCI-Express
Storage (RAID-0) with 4 Identical Hard Drives (1.28TB (320GBx4)
Display(s) LG 50" 50PK550 1080p 600Hz Plasma/37 Inch WestingHouse @1920x1080
Case Thermaltake M9 (I hate it its like trying to live in a 1 inch box)
Power Supply ThermalTake ToughPower 1200 Watt
Software Windows 7 professional 64
#2
please provide full system specs of the computer in question. Thank you and welcome to TPU.:lovetpu:
 

fantomix

New Member
Joined
Apr 16, 2018
Messages
4 (0.03/day)
Likes
4
#3
Asrock a770de+
Amd athlon phenom 2 x6
8gb ddr2
Nvidia gforce gtx 650
Sound card on board
Sory, i am 12 years old and i am noob for this
 
Joined
Feb 19, 2006
Messages
6,135 (1.34/day)
Likes
1,764
Location
New York
System Name http://www.heatware.com/eval.php?id=73751
Processor Tracer II 15 VR800 I7 7700HQ/GTX1070 16GB DDR4/2133MHz /ASUS GL553VW GTX 960M 4GB i56300HQ 8GB DDR4
Motherboard i7-920 CO@4.2GHZ/Asus P6T Deluxe Intel X58
Cooling Asetek Liquid CPU Cooling System
Memory CORSAIR DOMINATOR 6GB (3 x 2GB) DDR3 1600
Video Card(s) 2X ATI Radeon HD 4870 X2 2GB DDR5 PCI-Express
Storage (RAID-0) with 4 Identical Hard Drives (1.28TB (320GBx4)
Display(s) LG 50" 50PK550 1080p 600Hz Plasma/37 Inch WestingHouse @1920x1080
Case Thermaltake M9 (I hate it its like trying to live in a 1 inch box)
Power Supply ThermalTake ToughPower 1200 Watt
Software Windows 7 professional 64
#4
Joined
Feb 19, 2006
Messages
6,135 (1.34/day)
Likes
1,764
Location
New York
System Name http://www.heatware.com/eval.php?id=73751
Processor Tracer II 15 VR800 I7 7700HQ/GTX1070 16GB DDR4/2133MHz /ASUS GL553VW GTX 960M 4GB i56300HQ 8GB DDR4
Motherboard i7-920 CO@4.2GHZ/Asus P6T Deluxe Intel X58
Cooling Asetek Liquid CPU Cooling System
Memory CORSAIR DOMINATOR 6GB (3 x 2GB) DDR3 1600
Video Card(s) 2X ATI Radeon HD 4870 X2 2GB DDR5 PCI-Express
Storage (RAID-0) with 4 Identical Hard Drives (1.28TB (320GBx4)
Display(s) LG 50" 50PK550 1080p 600Hz Plasma/37 Inch WestingHouse @1920x1080
Case Thermaltake M9 (I hate it its like trying to live in a 1 inch box)
Power Supply ThermalTake ToughPower 1200 Watt
Software Windows 7 professional 64
#6
Ty you very very much,yo are the best.
this first>>> AMD all in 1 driver ver:8.631_W7_logo
REBOOT
THIS SECOND >> VIA high definition audio driver ver:v7500F_HDMI
You will probably need to try the windows 7 64 bit OS drivers for your Windows 10 OS;)
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
22,489 (5.53/day)
Likes
6,908
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#7
select your OS and down load all the mobo drivers starting with the chipset first and reboot ...install the rest of your mobo drivers...reboot retest.
https://www.asrock.com/mb/AMD/A770DE+/index.asp#Download
Ty you very very much,yo are the best.
Here is some Further information, make sure you didnt dislodge your plugs from the audio jacks by accident, check physical connections first.

If you still have your Manual, read it on how to access the Basic-Input-Output-System (BIOS) and how to navigate it, to ensure the HD Audio/AC-97 Audio chip wasn't disabled.
If you do not have your manual, it is here
http://asrock.pc.cdn.bitgravity.com/Manual/A770DE+.pdf

If you are unsure about anything have a computer geek friend of yours help you out on this.

Here are screenshots from your motherboard manual that pertain to your audio ports. @DRDNA this board is a DDR2 unit that supported Windows Vista- vintage bro.

Screenshot_2018-04-16-21-42-40.png

Screenshot_2018-04-16-21-43-05.png


Screenshot_2018-04-16-21-47-27.png


I hope this helps and is not overwhelming for you.

Welcome to TechPowerUp.
 
Joined
Oct 17, 2012
Messages
8,647 (4.05/day)
Likes
10,917
Location
Massachusetts
System Name Americas cure is the death of Social Justice & Political Correctness
Processor i5 8600k
Motherboard Asrock Z370 Extreme 4
Cooling Corsair H-110i GTX
Memory 2x 4Gb Crucial Sport LT
Video Card(s) MSI GTX 980 Gaming
Storage Samsung 850 evo 250Gb
Display(s) Dell Ultra Sharp Widescreen 24" 1200P
Case Fractal Design Meshify-C
Power Supply Seasonic Focus+ 750 Gold
Mouse Logitech G502 spectrum
Keyboard AZIO MRGB Kaith Blue
Software Win 10 Professional 64 bit
Benchmark Scores Congrats USA!! on the Travel Ban.....
#9
i just noticed now my left front speaker is almost totally inaudible since a recent win10 install:banghead:, i can JUST barely hear sound from it. I tried checking if it was the speaker or the plug that was broken, switched the plugs and speakers around, STILL only the left, no matter what speaker, so it isnt the speaker, it isnt the plugs, there is no audio enhancements, nothing.im totally stumped.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
22,489 (5.53/day)
Likes
6,908
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#10
i just noticed now my left front speaker is almost totally inaudible since a recent win10 install:banghead:, i can JUST barely hear sound from it. I tried checking if it was the speaker or the plug that was broken, switched the plugs and speakers around, STILL only the left, no matter what speaker, so it isnt the speaker, it isnt the plugs, there is no audio enhancements, nothing.im totally stumped.
Remove and Reinstall the driver, check bios settings too, hopefully an OS update or hardware failure did not occur. I just use Soundcards myself lol
 
Joined
Oct 17, 2012
Messages
8,647 (4.05/day)
Likes
10,917
Location
Massachusetts
System Name Americas cure is the death of Social Justice & Political Correctness
Processor i5 8600k
Motherboard Asrock Z370 Extreme 4
Cooling Corsair H-110i GTX
Memory 2x 4Gb Crucial Sport LT
Video Card(s) MSI GTX 980 Gaming
Storage Samsung 850 evo 250Gb
Display(s) Dell Ultra Sharp Widescreen 24" 1200P
Case Fractal Design Meshify-C
Power Supply Seasonic Focus+ 750 Gold
Mouse Logitech G502 spectrum
Keyboard AZIO MRGB Kaith Blue
Software Win 10 Professional 64 bit
Benchmark Scores Congrats USA!! on the Travel Ban.....
#11
Remove and Reinstall the driver, check bios settings too, hopefully an OS update or hardware failure did not occur. I just use Soundcards myself lol
Ive tried that, no luck. Ill have to go at it again tomorrow, i was watching Dexter on netflix, and lost track of time, its 0130 and im tired aF.

I dis notice a new bios Ver for my MoBo, but iirc there was no mention of audio adjustments, & i usually only update a bios to fix a issue the update is intended for, but ill likely try it if nothing pans out. I also noticed an audio update in the Asrock driver app, but the install doesnt take, it shows a newer Ver, it does the install, but once it successfully completes, the same update remains available & my starting older Ver of RT driver remains. Ill get fresh eyes on after some sleep.

Good night man
 
Joined
Feb 8, 2012
Messages
2,922 (1.23/day)
Likes
2,132
Location
Zagreb, Croatia
System Name Windows 7 64-bit Core i5 3570K
Processor Intel Core i5 3570K @ 4.2 GHz, 1.26 V
Motherboard Gigabyte GA-Z77MX-D3H
Cooling Scythe Katana 4
Memory 4 x 4 GB G-Skill Sniper DDR3 @ 1600 MHz
Video Card(s) Gainward NVIDIA GeForce GTX 970 Phantom
Storage Western Digital Caviar Blue 1 TB, Seagate Baracuda 1 TB
Display(s) Dell P2414H
Case CoolerMaster Silencio 550
Audio Device(s) VIA HD Audio
Power Supply Corsair TX v2 650W
Mouse Steelseries Sensei
Keyboard CM Storm Quickfire Pro, Cherry MX Reds
Software MS Windows 7 Enterprise 64-bit SP1
#12
I tried checking if it was the speaker or the plug that was broken, switched the plugs and speakers around, STILL only the left, no matter what speaker, so it isnt the speaker, it isnt the plugs, there is no audio enhancements, nothing.im totally stumped.
Happened to me once with potentiometer for volume control, it got a little dirty/rusty inside and contacts wasn't picking up both channels at all volume positions ... that's one more thing for you to check :laugh:
 
Joined
Feb 19, 2006
Messages
6,135 (1.34/day)
Likes
1,764
Location
New York
System Name http://www.heatware.com/eval.php?id=73751
Processor Tracer II 15 VR800 I7 7700HQ/GTX1070 16GB DDR4/2133MHz /ASUS GL553VW GTX 960M 4GB i56300HQ 8GB DDR4
Motherboard i7-920 CO@4.2GHZ/Asus P6T Deluxe Intel X58
Cooling Asetek Liquid CPU Cooling System
Memory CORSAIR DOMINATOR 6GB (3 x 2GB) DDR3 1600
Video Card(s) 2X ATI Radeon HD 4870 X2 2GB DDR5 PCI-Express
Storage (RAID-0) with 4 Identical Hard Drives (1.28TB (320GBx4)
Display(s) LG 50" 50PK550 1080p 600Hz Plasma/37 Inch WestingHouse @1920x1080
Case Thermaltake M9 (I hate it its like trying to live in a 1 inch box)
Power Supply ThermalTake ToughPower 1200 Watt
Software Windows 7 professional 64
#13
Ive tried that, no luck. Ill have to go at it again tomorrow, i was watching Dexter on netflix, and lost track of time, its 0130 and im tired aF.

I dis notice a new bios Ver for my MoBo, but iirc there was no mention of audio adjustments, & i usually only update a bios to fix a issue the update is intended for, but ill likely try it if nothing pans out. I also noticed an audio update in the Asrock driver app, but the install doesnt take, it shows a newer Ver, it does the install, but once it successfully completes, the same update remains available & my starting older Ver of RT driver remains. Ill get fresh eyes on after some sleep.

Good night man
plug your speakers into your smartphone and test to see if it is a plug issue
first.
 
Joined
Oct 17, 2012
Messages
8,647 (4.05/day)
Likes
10,917
Location
Massachusetts
System Name Americas cure is the death of Social Justice & Political Correctness
Processor i5 8600k
Motherboard Asrock Z370 Extreme 4
Cooling Corsair H-110i GTX
Memory 2x 4Gb Crucial Sport LT
Video Card(s) MSI GTX 980 Gaming
Storage Samsung 850 evo 250Gb
Display(s) Dell Ultra Sharp Widescreen 24" 1200P
Case Fractal Design Meshify-C
Power Supply Seasonic Focus+ 750 Gold
Mouse Logitech G502 spectrum
Keyboard AZIO MRGB Kaith Blue
Software Win 10 Professional 64 bit
Benchmark Scores Congrats USA!! on the Travel Ban.....
#14
plug your speakers into your smartphone and test to see if it is a plug issue
first.
Issue is present on phone. Ill have to yank the whole system out & check the wiring now. I just don't get it because I switched the speakers, I switched the plugs the speakers are plugged into, I switched everything around last night ,and although the issue was replicated ,it wasn't specific to a speaker ,it was specific to the left channel .
 
Joined
Feb 19, 2006
Messages
6,135 (1.34/day)
Likes
1,764
Location
New York
System Name http://www.heatware.com/eval.php?id=73751
Processor Tracer II 15 VR800 I7 7700HQ/GTX1070 16GB DDR4/2133MHz /ASUS GL553VW GTX 960M 4GB i56300HQ 8GB DDR4
Motherboard i7-920 CO@4.2GHZ/Asus P6T Deluxe Intel X58
Cooling Asetek Liquid CPU Cooling System
Memory CORSAIR DOMINATOR 6GB (3 x 2GB) DDR3 1600
Video Card(s) 2X ATI Radeon HD 4870 X2 2GB DDR5 PCI-Express
Storage (RAID-0) with 4 Identical Hard Drives (1.28TB (320GBx4)
Display(s) LG 50" 50PK550 1080p 600Hz Plasma/37 Inch WestingHouse @1920x1080
Case Thermaltake M9 (I hate it its like trying to live in a 1 inch box)
Power Supply ThermalTake ToughPower 1200 Watt
Software Windows 7 professional 64
#15
Issue is present on phone. Ill have to yank the whole system out & check the wiring now. I just don't get it because I switched the speakers, I switched the plugs the speakers are plugged into, I switched everything around last night ,and although the issue was replicated ,it wasn't specific to a speaker ,it was specific to the left channel .
Yes Sir that's what I figured, now to track down the fault....maybe the plug maybe the wire...maybe the internal amp...maybe maybe maybe....AT least you don't have to poke around Windows now tho ;)...
 
Joined
Oct 17, 2012
Messages
8,647 (4.05/day)
Likes
10,917
Location
Massachusetts
System Name Americas cure is the death of Social Justice & Political Correctness
Processor i5 8600k
Motherboard Asrock Z370 Extreme 4
Cooling Corsair H-110i GTX
Memory 2x 4Gb Crucial Sport LT
Video Card(s) MSI GTX 980 Gaming
Storage Samsung 850 evo 250Gb
Display(s) Dell Ultra Sharp Widescreen 24" 1200P
Case Fractal Design Meshify-C
Power Supply Seasonic Focus+ 750 Gold
Mouse Logitech G502 spectrum
Keyboard AZIO MRGB Kaith Blue
Software Win 10 Professional 64 bit
Benchmark Scores Congrats USA!! on the Travel Ban.....
#16
Yes Sir that's what I figured, now to track down the fault....maybe the plug maybe the wire...maybe the internal amp...maybe maybe maybe....AT least you don't have to poke around Windows now tho ;)...

im pissed, it seems to be at the Plug or further in the woofer. its a Z333 Logitech. the problem port is the blue one. I plugged the "working" right side speaker into that port and Nothing, i tried the other way around, and the left side speaker works. Im a bit Grumpy, when i bought the speakers, they are listed as having a 2 year warranty , but after submitting a claim with Logitech, it shows a 1 year warranty on the logitech site, which would put them Just out of warranty. i just dont get it, these thnigs are NEVER moved, or touched...how in the F@ck did the port get guffed up! :banghead:

Capture.PNG
 
Last edited:
Joined
Feb 19, 2006
Messages
6,135 (1.34/day)
Likes
1,764
Location
New York
System Name http://www.heatware.com/eval.php?id=73751
Processor Tracer II 15 VR800 I7 7700HQ/GTX1070 16GB DDR4/2133MHz /ASUS GL553VW GTX 960M 4GB i56300HQ 8GB DDR4
Motherboard i7-920 CO@4.2GHZ/Asus P6T Deluxe Intel X58
Cooling Asetek Liquid CPU Cooling System
Memory CORSAIR DOMINATOR 6GB (3 x 2GB) DDR3 1600
Video Card(s) 2X ATI Radeon HD 4870 X2 2GB DDR5 PCI-Express
Storage (RAID-0) with 4 Identical Hard Drives (1.28TB (320GBx4)
Display(s) LG 50" 50PK550 1080p 600Hz Plasma/37 Inch WestingHouse @1920x1080
Case Thermaltake M9 (I hate it its like trying to live in a 1 inch box)
Power Supply ThermalTake ToughPower 1200 Watt
Software Windows 7 professional 64
#17
im pissed, it seems to be at the Plug or further in the woofer. its a Z333 Logitech. the problem port is the blue one. I plugged the "working" right side speaker into that port and Nothing, i tried the other way around, and the left side speaker works. Im a bit Grumpy, when i bought the speakers, they are listed as having a 2 year warranty , but after submitting a claim with Logitech, it shows a 1 year warranty on the logitech site, which would put them Just out of warranty. i just dont get it, these thnigs are NEVER moved, or touched...how in the F@ck did the port get guffed up! :banghead:

View attachment 99924
Yeah sorry man, but you could probably just order the part and solder it faster than their RMA process, but any ways good luck!
 
Joined
Feb 8, 2012
Messages
2,922 (1.23/day)
Likes
2,132
Location
Zagreb, Croatia
System Name Windows 7 64-bit Core i5 3570K
Processor Intel Core i5 3570K @ 4.2 GHz, 1.26 V
Motherboard Gigabyte GA-Z77MX-D3H
Cooling Scythe Katana 4
Memory 4 x 4 GB G-Skill Sniper DDR3 @ 1600 MHz
Video Card(s) Gainward NVIDIA GeForce GTX 970 Phantom
Storage Western Digital Caviar Blue 1 TB, Seagate Baracuda 1 TB
Display(s) Dell P2414H
Case CoolerMaster Silencio 550
Audio Device(s) VIA HD Audio
Power Supply Corsair TX v2 650W
Mouse Steelseries Sensei
Keyboard CM Storm Quickfire Pro, Cherry MX Reds
Software MS Windows 7 Enterprise 64-bit SP1
#18
how in the F@ck did the port get guffed up!
Some component in the left channel circuit burned out ... quite possibly part of the amp since you do hear the left channel very very quietly
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
22,489 (5.53/day)
Likes
6,908
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Oct 17, 2012
Messages
8,647 (4.05/day)
Likes
10,917
Location
Massachusetts
System Name Americas cure is the death of Social Justice & Political Correctness
Processor i5 8600k
Motherboard Asrock Z370 Extreme 4
Cooling Corsair H-110i GTX
Memory 2x 4Gb Crucial Sport LT
Video Card(s) MSI GTX 980 Gaming
Storage Samsung 850 evo 250Gb
Display(s) Dell Ultra Sharp Widescreen 24" 1200P
Case Fractal Design Meshify-C
Power Supply Seasonic Focus+ 750 Gold
Mouse Logitech G502 spectrum
Keyboard AZIO MRGB Kaith Blue
Software Win 10 Professional 64 bit
Benchmark Scores Congrats USA!! on the Travel Ban.....
#20
what im most angry about is that when i bought this setup, the product page said it had a 2 year warranty, but when i went on logitechs site lasnight, it says it only holds a 1 year warranty. im guessing the Logitech site is most likely the accurate one, but thats just false advertising on Newegg's behalf.


neweggs product page

1111111.PNG



logitechs page


22222222222222222.PNG
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
22,489 (5.53/day)
Likes
6,908
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#21
Hold newegg accountable for the false information, show them that page. Have them give you another. After that do not shop through newegg, they are being ran by communists anyway.
 
Joined
Oct 17, 2012
Messages
8,647 (4.05/day)
Likes
10,917
Location
Massachusetts
System Name Americas cure is the death of Social Justice & Political Correctness
Processor i5 8600k
Motherboard Asrock Z370 Extreme 4
Cooling Corsair H-110i GTX
Memory 2x 4Gb Crucial Sport LT
Video Card(s) MSI GTX 980 Gaming
Storage Samsung 850 evo 250Gb
Display(s) Dell Ultra Sharp Widescreen 24" 1200P
Case Fractal Design Meshify-C
Power Supply Seasonic Focus+ 750 Gold
Mouse Logitech G502 spectrum
Keyboard AZIO MRGB Kaith Blue
Software Win 10 Professional 64 bit
Benchmark Scores Congrats USA!! on the Travel Ban.....
#22
Hold newegg accountable for the false information, show them that page. Have them give you another. After that do not shop through newegg, they are being ran by communists anyway.
they screwed up a few years back, i used to buy SO much from NE that i had a Support assistant girl that I could call or email whenever i had a issue, i didnt need to go through the motions ,etc, just straight pipeline to the supervisor girl. Then their support, and practices went to Sh!t, and I actually warned them it was happening, and then told them i was taking my business elsewhere, they are aware of the sh!t show they are running, but apparently couldnt care less. I no longer buy from them unless it suites me , or is a item i dont need quickly. Mainly amazon, B&H photo, SuperBiz, are my current stores, but now i buy much less, and only rarely need items. but i do avoid them like the plague. I found it SO funny when i found out your not allowed to use words like "Amazon" in the product reviews on newegg:laugh: , they treat it like a terroristic threat, and flag your post, that shows their awareness, and lack of concern.


I just hope i can get out of having to buy a new speaker setup, ad this one is barely 1&1/2 years old, and in perfect shape other than the faulty components.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
22,489 (5.53/day)
Likes
6,908
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#23
they screwed up a few years back, i used to buy SO much from NE that i had a Support assistant girl that I could call or email whenever i had a issue, i didnt need to go through the motions ,etc, just straight pipeline to the supervisor girl. Then their support, and practices went to Sh!t, and I actually warned them it was happening, and then told them i was taking my business elsewhere, they are aware of the sh!t show they are running, but apparently couldnt care less. I no longer buy from them unless it suites me , or is a item i dont need quickly. Mainly amazon, B&H photo, SuperBiz, are my current stores, but now i buy much less, and only rarely need items. but i do avoid them like the plague. I found it SO funny when i found out your not allowed to use words like "Amazon" in the product reviews on newegg:laugh: , they treat it like a terroristic threat, and flag your post, that shows their awareness, and lack of concern.


I just hope i can get out of having to buy a new speaker setup, ad this one is barely 1&1/2 years old, and in perfect shape other than the faulty components.
Bro, cut ties with newegg permanently, save yourself the headache. I never shopped with them because I could find better pricing elsewhere. For Newegg to sensor what you say just proves that they are communists.
 
Joined
Oct 17, 2012
Messages
8,647 (4.05/day)
Likes
10,917
Location
Massachusetts
System Name Americas cure is the death of Social Justice & Political Correctness
Processor i5 8600k
Motherboard Asrock Z370 Extreme 4
Cooling Corsair H-110i GTX
Memory 2x 4Gb Crucial Sport LT
Video Card(s) MSI GTX 980 Gaming
Storage Samsung 850 evo 250Gb
Display(s) Dell Ultra Sharp Widescreen 24" 1200P
Case Fractal Design Meshify-C
Power Supply Seasonic Focus+ 750 Gold
Mouse Logitech G502 spectrum
Keyboard AZIO MRGB Kaith Blue
Software Win 10 Professional 64 bit
Benchmark Scores Congrats USA!! on the Travel Ban.....
#24
I'm currently waiting in line with chat support on Newegg hopefully they'll take responsibility for the false advertising , & help me out, but i have a feeling this one isnt gonna go my way:fear:
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
22,489 (5.53/day)
Likes
6,908
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#25
I'm currently waiting in line with chat support on Newegg hopefully they'll take responsibility for the false advertising , & help me out, but i have a feeling this one isnt gonna go my way:fear:
Any luck?

If its not for good, I'd rate them poorly.
 
Top