• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

AMD E-450 Driver Help

Status
Not open for further replies.

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,874 (3.68/day)
Location
Concord, NH
System Name Apollo
Processor Intel Core i9 9880H
Memory 64GB DDR4-2667
Video Card(s) AMD Radeon Pro 5600M, 8GB HBM2
Storage 1TB Apple NVMe, 4TB External
Display(s) Laptop @ 3072x1920 + 2x LG 5k Ultrafine TB3 displays
Case MacBook Pro (16", 2019)
Power Supply 96w Power Adapter
Mouse Logitech G602
Software MacOS 10.15.6
It doesn't matter. I don't need DX12 support on it, but damn playback of some stupid video is certainly something I'd expect from a GPU. It has a HD6000 series GPU on it. It ain't THAT old no matter what.

Sure it's weak for gaming, but if it was barely able to decode 4K before, and now I can't even play 480p, what does that tell you?
It tells us you're running the generic Windows driver. Go install an older version as other's have suggested. Windows 10 doesn't require WDDM 2.0 drivers IIRC. Cool you jets and listen to what people are telling you. No one likes a person who's so worked up they can't pay attention to the recommendations being made. Also 4 years old is a while for how under-powered the E-450 was even when it came out but, that's beside the point. Just try using the same version drivers you had before you upgraded.
 
Joined
Oct 2, 2004
Messages
13,791 (2.34/day)
Then what the hell is the point of "generic" drivers if they do nothing other than paste a stupid name in the Device Manager!? I don't care how "weak" and "underpowered" it was when it came out. It works like absolute junk TODAY on 10 times less demanding things than it did in the past. Why is WU even bothering installing a huge driver if it then does NOTHING to ANY performance!? It doesn't just go backwards with logic, it goes 1000 kilometers backwards.
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,874 (3.68/day)
Location
Concord, NH
System Name Apollo
Processor Intel Core i9 9880H
Memory 64GB DDR4-2667
Video Card(s) AMD Radeon Pro 5600M, 8GB HBM2
Storage 1TB Apple NVMe, 4TB External
Display(s) Laptop @ 3072x1920 + 2x LG 5k Ultrafine TB3 displays
Case MacBook Pro (16", 2019)
Power Supply 96w Power Adapter
Mouse Logitech G602
Software MacOS 10.15.6
Then what the hell is the point of "generic" drivers if they do nothing other than paste a stupid name in the Device Manager!? I don't care how "weak" and "underpowered" it was when it came out. It works like absolute junk TODAY on 10 times less demanding things than it did in the past. Why is WU even bothering installing a huge driver if it then does NOTHING to ANY performance!? It doesn't just go backwards with logic, it goes 1000 kilometers backwards.
So you can use your f**king computer. Would you rather it booted with no video support and zero ability to do anything? Without any ability to install video drivers because a half-decent generic one doesn't exist? Just quit your whining and install an old version already. Now all you're doing is being a winey little s**t. I'm astonished this thread hasn't been closed like the other by now.

People were willing to help you and you're willing to keep ranting, that's reason enough to close this thread. You don't want help, you want an audience to rant to...
 
Joined
Oct 2, 2004
Messages
13,791 (2.34/day)
I HAVE NO VIDEO SUPPORT. This crap can't run anything, not even stupid 480p video. What the hell is YOUR problem? And I've installed the Win8.1 driver that fully supports my graphic card and the Youtube was still lagging like I'm trying to view it on Commodore C128...
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,874 (3.68/day)
Location
Concord, NH
System Name Apollo
Processor Intel Core i9 9880H
Memory 64GB DDR4-2667
Video Card(s) AMD Radeon Pro 5600M, 8GB HBM2
Storage 1TB Apple NVMe, 4TB External
Display(s) Laptop @ 3072x1920 + 2x LG 5k Ultrafine TB3 displays
Case MacBook Pro (16", 2019)
Power Supply 96w Power Adapter
Mouse Logitech G602
Software MacOS 10.15.6
I HAVE NO VIDEO SUPPORT. This crap can't run anything, not even stupid 480p video. What the hell is YOUR problem?
You're winey attitude. It's not conducive to people wanting to help you. No one likes a winey s**t who complains all the time, even when they want help.
I've installed the Win8.1 driver that fully supports my graphic card and the Youtube was still lagging like I'm trying to view it on Commodore C128...
It sounds like the driver still isn't loaded up. Does it say it's AMD's driver in device manager because it sounds like you're still on that generic driver. Also yes, the generic driver is going to suck but at least you can see what you're doing to install the right one. That's the point of it...

So lets see Device Manager. The driver should say the driver provider is AMD and not Microsoft. If it says Microsoft, the driver never actually loaded it. It's entirely possible that it might not want to load the older driver through the installer and that you might have better luck manually installing it. Honestly, if you've tried several versions of catalyst without using a driver cleaner, I would clean up the PC again and attempt to install the one that worked with 8.1 again. If it still holds on to the Microsoft driver, you may want to try manually updating it through the device manager by telling it what .inf file should get loaded up for your graphics card if it's an "incompatibility" thing since the old installer might not be Windows 10 aware but, this is all guesswork because we get more ranting than information.

Either way, report back what device manger is. It will illuminate how to proceed and what questions to ask. I'm willing to help so long as you don't turn this thread into a dumping place where rants go to die.

Also, this is all resting on the assumption that you properly removed drivers before installing new ones or that you've successfully attempted to install them. So more info, less ranting please.

gpu-driver.PNG
 
Last edited:
Joined
Jun 24, 2015
Messages
2,135 (1.07/day)
Location
Western Canada
System Name Ol' Beastie R4.0
Processor Ryzen 4650G
Motherboard B550i Aorus Pro AX (F10)
Memory 16GB 4000 16-16-16 @ 1.47V
Storage 256GB PM981
Case NCASE M1v5
Enough is enough. For f%#k's sake, why does @Aquinus still bother to help you? Everything he posts is a suggestion, and you keep coming back with "what the hell is your problem?

Christ alive. This isn't an A10-6800K. If you ran Windows on a Snapdragon 400, this is what you would get. Absolute sh*t quality and performance. If you're already on Windows 10, why not try a refresh or something (clean install)?

What IS your problem, bud? You ask people for help then you hurl shit at them when they try to help you, then you go to a different set of people and continue to hurl shit around.
 
Joined
Jul 9, 2009
Messages
17 (0.00/day)
I got DXVA2 working in Win10 (E2-1800, Zacate) by installing the 15.6 beta drivers. 15.7 and 15.7.1 wouldn't install.

Also previous Windows 10 insider drivers (DX12 supported) were fine, but I'm not sure which driver version it was.
15.6 Beta:
http://forums.guru3d.com/showthread.php?t=400229

I'm pretty sure it'll work for E-450 as well, it's basically the same APU.
 
Joined
May 9, 2012
Messages
6,920 (2.21/day)
Location
Ovronnaz, Wallis, Switzerland
System Name Monster Panzer Max [MPM]/Nostalg33k/Huawei Mediapad M5/Xiaomi Mi Box S/TCL 10 Pro
Processor i5-6600K 3.9/E8500/Kirin960 4xA73/4xA53 /S905X 4X1.5 A53/Snapdragon 675
Motherboard Gigabyte Z170X Gaming 7/XFX 650i Ultra/uh?/uh?/uh?
Cooling Corsair H115i /Alphacool Eisberg /aluminum heatsink/Aluminum heatsink/Heatpipe
Memory 4x4gb HyperX Predator 2800 CL14/2gb DDR2 800/4gb LPDDR4/2gb LPDDR3/6gb LPDDR4X dual channel
Video Card(s) MSI GTX 1070 ARMOR 8gb OC/Asus 8800 Ultra/Mali G71MP8/Mali 450MP5/Adreno 612
Storage 120gb VertexIII,1tb/8gb SSHD,2x1tb,NVMe 512gb,ext1tb P1+Arion/none/32gb+256gb/8gb/128gbUFS 2.1+256gb
Display(s) X58222 32"5ms OC 75hz 2880x1620/8.4" 2560x1600/273E3LHSB 27"1ms 1920x1080/~4" 480x800/6.4 inch FHD+
Case Cougar Panzer Max/none/Aluminum and tempered glass/None/alu frame +back/front glass GG5
Audio Device(s) Fiio Q1 Mark II+Logitec Z333/SB Audigy2 Platinum/AK4376+Harman Kardon speaker/HDMI/Fiio Fa1
Power Supply Seasonic M12II Evo 750 /Enermax Coolergiant 480/12v 1.5A/J5 Create QC3.0 9-12V 1.96A
Mouse Speedlink Sovos Vertical-Asus ROG Spatha-Logitech MX Ergo/touch/Xiaomi XMRM-006/touch
Keyboard GMMK TKL+Gateron Red+white keys/touch/none/touch
Software Win10 64/none/Android 5.1.1 custom/Android TV 8.1/Android 9.1.0
Benchmark Scores bench...mark? i do leave mark on bench sometime, to remember which one is the most comfortable. :o
I got DXVA2 working in Win10 (E2-1800, Zacate) by installing the 15.6 beta drivers. 15.7 and 15.7.1 wouldn't install.

Also previous Windows 10 insider drivers (DX12 supported) were fine, but I'm not sure which driver version it was.
15.6 Beta:
http://forums.guru3d.com/showthread.php?t=400229

I'm pretty sure it'll work for E-450 as well, it's basically the same APU.
if it's not the latest ... he will not read or even consider that option ... for him the latest have to be the best and bugfree directly on day one ... it seems ..

tho nice solution! (can confirm it works on a E-450 mATX ASUS mobo)
 
Joined
Mar 13, 2014
Messages
4,487 (1.83/day)
Processor i7 7700k
Motherboard MSI Z270 SLI Plus
Cooling CM Hyper 212 EVO
Memory 2 x 8 GB Corsair Vengeance
Video Card(s) MSI RTX 2070 Super
Storage Samsung 850 EVO 250 GB and WD Black 4TB
Display(s) Dell 27 inch 1440p 144 Hz
Case Corsair Obsidian 750D Airflow Edition
Audio Device(s) Onboard
Power Supply EVGA SuperNova 850 W Gold
Mouse Logitech G502
Keyboard Logitech G105
Software Windows 10
It's the early adopter thing. MS is just doing the same thing that game publishers have been doing to us for years. Sell it and let your customer base beta test it for you and let them find the bugs.

btw RejZor I like you just fine but the voices in my head don't like you. They say you're too negative and that I should just avoid the Christmas rush and start hating you right now but I'm not listening to them. They can't get along with anybody anyway. :p
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,874 (3.68/day)
Location
Concord, NH
System Name Apollo
Processor Intel Core i9 9880H
Memory 64GB DDR4-2667
Video Card(s) AMD Radeon Pro 5600M, 8GB HBM2
Storage 1TB Apple NVMe, 4TB External
Display(s) Laptop @ 3072x1920 + 2x LG 5k Ultrafine TB3 displays
Case MacBook Pro (16", 2019)
Power Supply 96w Power Adapter
Mouse Logitech G602
Software MacOS 10.15.6
Joined
Mar 19, 2005
Messages
286 (0.05/day)
Location
Southern California :)
System Name Big Beast
Processor AMD Ryzen 5 2600x
Motherboard Asus Strix x570-I Gaming
Cooling NZXT AIO
Memory Patriot Viper 16GB 3400MHz
Video Card(s) AMD Radeon VII
Storage Lot's of it
Display(s) Samsung CHG70 27"
Case NZXT H1
Power Supply 600 watt
Software Windows 10 Profressional x64
Rejzor, look in Task Manager and make sure nothing is taking up a lot of CPU cycles. For example on 8.1 my dad's laptop had a problem with windows update and there would be something called TiWorker.exe maxing out the hard drive and cpu. In task manager under the details tab or Processes tab you can sort by CPU utilization.
 

Toothless

Tech, Games, and TPU!
Supporter
Joined
Mar 26, 2014
Messages
6,670 (2.73/day)
Location
Washington, USA
System Name Veraltet
Processor 3700x
Motherboard AsRock Taichi Ultimate x470
Cooling NH-D15 Chromax
Memory G.Skill 2x16GB 3200mhz
Video Card(s) MSI GTX1080 Ti Gaming X
Storage 2 NVME + 4 HDD
Display(s) LG 34UB88-P + 2x AOC 2425W
Case CoolerMaster NR600
Audio Device(s) SteelSeries Arctis 5
Power Supply Rosewill Fortress 750w
Mouse Corsair Scimitar Pro
Keyboard Corsair K57
Software Windows 10 Professional
Benchmark Scores Brrrrrrr
Okay, since I haven't seen anyone clarify this (if you did then I must be blind today)

Yes, the E-450 is an APU with a 6320g in there, but APUs usually go with the MOBILE version of the chips, so with that in mind, how much power do you think you'll get anyway? I mean when you pair that with a dual-core that runs at 1.65ghz, it's not going to do much of anything.

My laptop has a 6520g in there and it does stuff.. It tries to go places but it doesn't since newer drivers are a bit buggy, I sit on 14.1 or 14.2.

My advice? Grow up and quit fighting Win10 because all it's done is make yourself look like an ass when people are trying to help you.
 

FordGT90Concept

"I go fast!1!11!1!"
Joined
Oct 13, 2008
Messages
26,147 (5.90/day)
Location
IA, USA
System Name BY-2015
Processor Intel Core i7-6700K (4 x 4.00 GHz) w/ HT and Turbo on
Motherboard MSI Z170A GAMING M7
Cooling Scythe Kotetsu
Memory 2 x Kingston HyperX DDR4-2133 8 GiB
Video Card(s) Sapphire Radeon RX 5500 XT Pulse 8 GiB
Storage Crucial MX300 275 GB, Seagate Exos X12 TB 7200 RPM
Display(s) Nixeus NX-EDG274K (3840x2160@144 DP) + Samsung SyncMaster 906BW (1440x900@60 HDMI-DVI)
Case Coolermaster HAF 932 w/ USB 3.0 5.25" bay
Audio Device(s) Realtek ALC1150, Micca OriGen+
Power Supply Enermax Platimax 850w
Mouse SteelSeries Sensei RAW
Keyboard Tesoro Excalibur
Software Windows 10 Pro 64-bit
Benchmark Scores Faster than the tortoise; slower than the hare.
vga.dll means no GPU acceleration for video playback hence the slowness.

Option a: download the driver package that originally worked, run it so it extracts the drivers, and from device manager, point it to that folder and it will hopefully find and install those drivers.

Option b: revert to previous Windows install and wait until AMD releases drivers for Zacate (assuming they ever do).
 

AsRock

TPU addict
Joined
Jun 23, 2007
Messages
16,790 (3.42/day)
Location
UK\US
Processor 2500k \ AMD 3900X+NH-D15
Motherboard ASRock Z68 \ ASRock AM4 Pro 4
Memory Samsung low profile 1600 \ Patriot 2x16GB PVS432G320C6K
Video Card(s) eVga GTX1060 SSC \ XFX R9 390X
Storage 2xIntel 80Gb (SATA2) Crucial MX500 \ Samsung 860 1TB +Samsung Evo 250GB+500GB+ 2xCorsair Force 120GB
Display(s) Samsung 1080P \ Toshiba HDTV 1080P
Case HTPC400 \ Thermaltake Armor case ( VE2000BWS ), With Zalman fan controller ( wattage usage ).
Audio Device(s) Yamaha RX-A820 \ Yamaha CX-830+Yamaha MX-630 Infinity RS4000 Paradigm 5SE + Tannoy Mercury F4
Power Supply PC&Power 750w \ Seasonic 750w MKII
Mouse Steelseries Sensei wireless \ Steelseries Sensei wireless
Keyboard Logitech K120 \ ROCCAT MK Pro ( modded amber leds )
Benchmark Scores Meh benchmarks.
I HAVE NO VIDEO SUPPORT. This crap can't run anything, not even stupid 480p video. What the hell is YOUR problem? And I've installed the Win8.1 driver that fully supports my graphic card and the Youtube was still lagging like I'm trying to view it on Commodore C128...
Well our 450 barely ran ok with video's and in Win 10 it is surely worse with added full screen crashes lol. Funny one is going to AMD's website to check for a driver for it comes up blank lol.

When we 1st got it for our eldest it worked perfectly fine but even set back to it's original state it's no were as good as it was. Like to know what the fuck happened too flash just became to much for it.

Our eldest ( left home now ) gave it to the youngest of brats we have here she's letting me know about the problems as to be honest i don't have the time and just annoys me no end.

No it should not be this bad but it is and it's pointless complaining about it here, but i do feel your pain with this matter.

I say sell it and pick up a older laptop like a DELL 1764, ours is1-2 years older than the 450 uses about 20-30 and is way is a hell load better and really fast with a SSD which is what i typed this on and can be had for about $200.
 
Joined
Nov 9, 2010
Messages
5,194 (1.41/day)
Processor Intel i7 950 @ 3.2GHz
Motherboard ASUS P6X58D-E
Cooling Corsair H50 push/pull
Memory Kingston HyperX 1600 8GB
Video Card(s) Sapphire HD 7970 OC
Storage Plextor M5P 128GB/WD Black 2x1TB,1x6TB/Seagate 1TB
Display(s) Panasonic TC-L32U3
Case Antec DF-85
Audio Device(s) Yamaha RX-V371 AVR
Power Supply XFX 850w Black Edition
Mouse Logitech G402
Keyboard Logitech K120
Software W10 Pro 64 bit
Most of the W10 threads I just look at, and always come to the same conclusion. I feel it's still wait and see time, like it is with ALL MS OSes after launch. I might try it when some decent Dx12 games trickle in, but until then, I think I'll avoid the frustrations in tile happy land.
 

FordGT90Concept

"I go fast!1!11!1!"
Joined
Oct 13, 2008
Messages
26,147 (5.90/day)
Location
IA, USA
System Name BY-2015
Processor Intel Core i7-6700K (4 x 4.00 GHz) w/ HT and Turbo on
Motherboard MSI Z170A GAMING M7
Cooling Scythe Kotetsu
Memory 2 x Kingston HyperX DDR4-2133 8 GiB
Video Card(s) Sapphire Radeon RX 5500 XT Pulse 8 GiB
Storage Crucial MX300 275 GB, Seagate Exos X12 TB 7200 RPM
Display(s) Nixeus NX-EDG274K (3840x2160@144 DP) + Samsung SyncMaster 906BW (1440x900@60 HDMI-DVI)
Case Coolermaster HAF 932 w/ USB 3.0 5.25" bay
Audio Device(s) Realtek ALC1150, Micca OriGen+
Power Supply Enermax Platimax 850w
Mouse SteelSeries Sensei RAW
Keyboard Tesoro Excalibur
Software Windows 10 Pro 64-bit
Benchmark Scores Faster than the tortoise; slower than the hare.
I just upgraded and except for some stupid design decisions, it seems okay and I'm ultra fussy about operating systems. It can mostly be configured to mimic Windows 7 and it does have some nice multi-monitor features that were missing before (e.g. the task bar can be made to appear on each and even allows you to only show windows on secondary displays that are presently shown on that display).
 
Joined
Oct 19, 2007
Messages
7,550 (1.58/day)
Processor Intel i9 9900K @5GHz w/ Corsair H150i Pro CPU AiO w/Corsair HD120 RBG fan
Motherboard Asus Z390 Maximus XI Code
Cooling 6x120mm Corsair HD120 RBG fans
Memory Corsair Vengeance RBG 2x8GB 3600MHz
Video Card(s) Asus RTX 2080 STRIX OC
Storage Samsung 250GB 960 EVO m.2, 970 EVO 1TB, Samsung 850 EVO 1TB SSD, 10TB Synology DS1515+ RAID5
Display(s) Acer Predator 34" 3440x1440 OC'd to 100MHz
Case Corsair 570x RBG Tempered Glass
Audio Device(s) Onboard / Corsair Void Wireless RGB
Power Supply Corsair HX850w Platinum Series
Mouse Logitech G602s
Keyboard Corsair K70 Rapidfire
Software Windows 10 x64 Professional
Benchmark Scores Firestrike - 23520 Heaven - 3670
Then what the hell is the point of "generic" drivers if they do nothing other than paste a stupid name in the Device Manager!? I don't care how "weak" and "underpowered" it was when it came out. It works like absolute junk TODAY on 10 times less demanding things than it did in the past. Why is WU even bothering installing a huge driver if it then does NOTHING to ANY performance!? It doesn't just go backwards with logic, it goes 1000 kilometers backwards.
Seriously, do you even computer?
 

FordGT90Concept

"I go fast!1!11!1!"
Joined
Oct 13, 2008
Messages
26,147 (5.90/day)
Location
IA, USA
System Name BY-2015
Processor Intel Core i7-6700K (4 x 4.00 GHz) w/ HT and Turbo on
Motherboard MSI Z170A GAMING M7
Cooling Scythe Kotetsu
Memory 2 x Kingston HyperX DDR4-2133 8 GiB
Video Card(s) Sapphire Radeon RX 5500 XT Pulse 8 GiB
Storage Crucial MX300 275 GB, Seagate Exos X12 TB 7200 RPM
Display(s) Nixeus NX-EDG274K (3840x2160@144 DP) + Samsung SyncMaster 906BW (1440x900@60 HDMI-DVI)
Case Coolermaster HAF 932 w/ USB 3.0 5.25" bay
Audio Device(s) Realtek ALC1150, Micca OriGen+
Power Supply Enermax Platimax 850w
Mouse SteelSeries Sensei RAW
Keyboard Tesoro Excalibur
Software Windows 10 Pro 64-bit
Benchmark Scores Faster than the tortoise; slower than the hare.
I installed 13.1 drivers for an HD 42xx card today. Steps:
1. download the latest version of AMD drivers for the device for Windows 8 32-bit or 64-bit (match OS obviously).
2. once downloaded, run it.
3. After the initial extraction, it will pop up to continue the install. Cancel. It will fail anyway because the OS doesn't match what the drivers are for.
4. Log in to an admin account if you aren't already.
5. right-click on the start button and select Device Manager
6. expand Display Adapters
7. Find the "Microsoft Basic Display Adapter" that needs updating and double click on it.
8. Change to "driver" tab.
9. Click "Update Driver."
10. Click the button that says you'll find the driver yourself.
11. Navigate to C:\AMD which was created by the installer in step 1.
12. ???
13. Profit!
 
Joined
Oct 2, 2004
Messages
13,791 (2.34/day)
Then again, why the hell discontinue only a 4 years old GPU !? It's idiotic. HD5000 are supported but HD6000 isn't. It's basic, but it's still HD6000 series and I've always been using same drivers as used for discrete GPU's. AMD, stop being lazy.
 

FordGT90Concept

"I go fast!1!11!1!"
Joined
Oct 13, 2008
Messages
26,147 (5.90/day)
Location
IA, USA
System Name BY-2015
Processor Intel Core i7-6700K (4 x 4.00 GHz) w/ HT and Turbo on
Motherboard MSI Z170A GAMING M7
Cooling Scythe Kotetsu
Memory 2 x Kingston HyperX DDR4-2133 8 GiB
Video Card(s) Sapphire Radeon RX 5500 XT Pulse 8 GiB
Storage Crucial MX300 275 GB, Seagate Exos X12 TB 7200 RPM
Display(s) Nixeus NX-EDG274K (3840x2160@144 DP) + Samsung SyncMaster 906BW (1440x900@60 HDMI-DVI)
Case Coolermaster HAF 932 w/ USB 3.0 5.25" bay
Audio Device(s) Realtek ALC1150, Micca OriGen+
Power Supply Enermax Platimax 850w
Mouse SteelSeries Sensei RAW
Keyboard Tesoro Excalibur
Software Windows 10 Pro 64-bit
Benchmark Scores Faster than the tortoise; slower than the hare.
APU versus GPU. Point is: stop complaining and install the driver. There aren't many Windows 7/8.1 drivers Windows 10 will flatly reject. You just have to circumvent the installer.

I think VIA VDock, discreet GPU drivers, and HP printers are the only ones that fail.
 
Joined
Oct 2, 2004
Messages
13,791 (2.34/day)
It doesn't matter if it's APU. It's using HD6000 GPU. End of story. This ain't a mobility product that has a separate driver. Stop defending lazy vendors. Damn.
 

Toothless

Tech, Games, and TPU!
Supporter
Joined
Mar 26, 2014
Messages
6,670 (2.73/day)
Location
Washington, USA
System Name Veraltet
Processor 3700x
Motherboard AsRock Taichi Ultimate x470
Cooling NH-D15 Chromax
Memory G.Skill 2x16GB 3200mhz
Video Card(s) MSI GTX1080 Ti Gaming X
Storage 2 NVME + 4 HDD
Display(s) LG 34UB88-P + 2x AOC 2425W
Case CoolerMaster NR600
Audio Device(s) SteelSeries Arctis 5
Power Supply Rosewill Fortress 750w
Mouse Corsair Scimitar Pro
Keyboard Corsair K57
Software Windows 10 Professional
Benchmark Scores Brrrrrrr
It doesn't matter if it's APU. It's using HD6000 GPU. End of story. This ain't a mobility product that has a separate driver. Stop defending lazy vendors. Damn.
It is a mobile GPU with it's own GPU driver.
 
Joined
Oct 2, 2004
Messages
13,791 (2.34/day)
And yet it installs (or shall I say it used to) from the desktop package. Make up your mind... THIS. AIN'T. MOBILITY. GPU.
 

FordGT90Concept

"I go fast!1!11!1!"
Joined
Oct 13, 2008
Messages
26,147 (5.90/day)
Location
IA, USA
System Name BY-2015
Processor Intel Core i7-6700K (4 x 4.00 GHz) w/ HT and Turbo on
Motherboard MSI Z170A GAMING M7
Cooling Scythe Kotetsu
Memory 2 x Kingston HyperX DDR4-2133 8 GiB
Video Card(s) Sapphire Radeon RX 5500 XT Pulse 8 GiB
Storage Crucial MX300 275 GB, Seagate Exos X12 TB 7200 RPM
Display(s) Nixeus NX-EDG274K (3840x2160@144 DP) + Samsung SyncMaster 906BW (1440x900@60 HDMI-DVI)
Case Coolermaster HAF 932 w/ USB 3.0 5.25" bay
Audio Device(s) Realtek ALC1150, Micca OriGen+
Power Supply Enermax Platimax 850w
Mouse SteelSeries Sensei RAW
Keyboard Tesoro Excalibur
Software Windows 10 Pro 64-bit
Benchmark Scores Faster than the tortoise; slower than the hare.
AMD seems to think the latest drivers should work (15.7.1) but I suspect you tried them:
32-bit
64-bit

AMD said:
AMD APU Product Family Compatibility
AMD Radeon™ HD 6000G Series
AMD uses one driver package for pretty much everything except legacy (HD 4 series and down).


I'm getting a strong impression that E-450 was special order for OEMs only which means drivers are supposed to be provided by the OEM. Have you checked the OEM's website? What is the brand and model number of the laptop?
 
Last edited:
Joined
Oct 2, 2004
Messages
13,791 (2.34/day)
OEM drivers are garbage. They stopped supporting it basically sine day one. Typical for OEM's...

I've forced installed Omega drivers now and Youtube seems to run smooth now. I just hope retarded Windows 10 Update won't force install their "latest" garbage over these...
 
Status
Not open for further replies.
Top