• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

AMD Radeon Crimson Edition Drivers

Joined
May 22, 2010
Messages
95 (0.03/day)
System Name "The scratcher"
Processor i5-3570K
Motherboard MSI Z77MA-G45
Cooling watercooled custom loop
Memory kingston hyperx black 2x8GB
Video Card(s) GB GTX1070 G1 gaming
Storage several
Display(s) Dell 2708WFP
Case CM Cosmos RC1000
Power Supply CM UCP 750W
Software Win 10 Pro x64
i dont have the shader cache option.... installed the beta version for 5000 series....
 
Joined
Oct 2, 2015
Messages
2,338 (1.58/day)
Location
Argentina
System Name Ciel / Yukino
Processor AMD Ryzen R3 1200 @ 3900MHz / Intel Core i3 5005U
Motherboard MSI B350M PRO-VDH / HP 240 G5
Cooling Wraith Stealth / Stock
Memory 2x 8GB Corsair Ballistix Sport DDR4 2400MHz @ 3400MHz / 2x 4GB Hynix + Kingston DDR3L 1600MHz
Video Card(s) Sapphire R9 270X Toxic 2GB / Intel HD 5500
Storage SSD WD Green 240GB M.2 + HDD Toshiba 2TB / SSD Kingston A400 120GB SATA
Display(s) HP w17e 1440x900 @ 75 Hz / Integrated 1366x768 @ 94Hz
Case Generic / Stock
Audio Device(s) Realtek ALC892 / Realtek ALC282
Power Supply Sentey XPP 525W / Power Brick
Mouse Logitech G203 / Elan Touchpad
Keyboard Generic / Stock
Software Windows 10 LTSC x64 + Arch Linux
Benchmark Scores Time Spy: 2200
No VSR for me (neither on CCC), well I guess is beause of possible low performance.
 
Joined
Nov 25, 2015
Messages
11 (0.01/day)
System Name Custom Built
Processor AMD FX-8350
Motherboard ASUS CROSSHAIR V FORMULA-Z
Cooling CORSAIR H110 280mm
Memory G.Skill F3-2400C10-8GTX 8GB DIMM DDR3 PC3-19200U X 4
Video Card(s) GIGABYTE Radeon R9 380 GV-R938G1 GAMING-4GD X 2 CrossfireX
Storage 2 X Mushkin Chronos 60GB SSD, RAID0; 2 X Mushkin Chronos 240GB SSD, RAID0
Display(s) 2 X Acer XG270HU 27"
Case NZXT CA-PH410-B1 RT
Audio Device(s) ASUS Xonar Essence STX
Power Supply EVGA 220-PS-1000-V1 80 PLUS Platinum 1000 W
Mouse Logitech G9x
Keyboard Logitech G510s; Logitech G13
Software Windows 10 Pro 64
Benchmark Scores 3DMark Fire Strike Extreme: 6607 (with FreeSync enabled)
Well, Crimson has turned into a major nightmare for me. First I tried installing it, and couldn't handle missing the hotkeys etc. Then I tried going back to the last good driver, and Civ 4 no longer workded, so then I upgraded again to the Crimson drivers, but kept the CCC and didn't install the AMD Settings app. GPU frequency scaling stopped working when I reverted to the old drivers and still isn't working. I'm aggravated, annoyed, and tired of fighting with this crap...
 
Joined
Mar 1, 2008
Messages
246 (0.06/day)
Location
Antwerp, Belgium
Processor Intel Xeon X5650 @ 3.6Ghz - 1.2v
Motherboard Gigabyte G1.Assassin
Cooling Thermalright True Spirit 120
Memory 12GB DDR3 @ PC1600
Video Card(s) nVidia GeForce GTX 780 3GB
Storage 256GB Samsung 840 Pro + 3TB + 3TB + 2TB
Display(s) HP ZR22w
Case Antec P280
Audio Device(s) Asus Xonar DS
Power Supply Antec HCG-620M
Software Windows 7 x64
This new 'AMD Radeon Crimson Edition Drivers' is infuriating. I was quite happy about this new driver until I installed it... ALL CUSTOM/MANUAL VIDEO CONTROL/QUALITY settings are GONE!! What is left under custom video control is essentially a joke! Below are the missing options:

1. Basic Video Color
2. Color Vibrance + Slider => Replaced by three fixed levels!
3. Video Gamma + Slider
4. Flesh-tone Correction + Slider
5. Brighter Whites
6. Dynamic Range
7. Deinterlacing Setting
8. Pulldown detection
9. Edge enhancement + Slider => Again replaced by three fixed levels!
10. De-noise + Slider
11. Mosquito Noise Reduction + Slider
12. De-blocking + Slider
13. Dynamic Contrast
Did you check under 'Preferences' => 'Radeon Additional Settings' ?
 
Joined
Sep 25, 2007
Messages
5,825 (1.32/day)
Processor Core I7 3770K@4.8Ghz
Motherboard AsRock Z77 Extreme
Cooling Cooler Master Seidon 120M
Memory 12Gb G.Skill Sniper
Video Card(s) EVGA GTX 1070 FTW 2150/2240
Storage Sandisk SSD + 1TB Seagate Barracuda 7200
Display(s) IPS Asus 26inch
Case Antec 300
Audio Device(s) Xonar DG
Power Supply EVGA Supernova 650 G2
Software Windows 10/Windows 7
noticed that also and it is pretty sad to see all those options vanish and they are not in addition settings either, they're just gone.

I only have 4 options under custom
Vibrance
Sharpness
Brightness(only one with slider)
Steady Video
 
Last edited:
Joined
Oct 31, 2014
Messages
8 (0.00/day)
Location
India
System Name Anya
Processor Intel Core i5-4440
Motherboard GIGABYTE G1.Sniper B5
Cooling Antec C20 CPU Cooler
Memory Kingston HyperX FURY 4x4GB 1600MHz
Video Card(s) Sapphire Dual-X Radeon R7 265
Storage Seagate SV35.6 Series 1TB 7200 RPM 3.5"
Display(s) Dell S2240M 21.5" IPS LED Backlit
Case Antec X1 Gaming Cabinet
Audio Device(s) Onboard Realtek ALC898 HD audio
Power Supply Seasonic ECO-430 (SSR-430ST)
Mouse HP X500 Wired USB Mouse
Keyboard Dell KB213 Wired USB Keyboard
Software Microsoft Windows 10 Pro
Did you check under 'Preferences' => 'Radeon Additional Settings' ?
Of course I did. There's none of the settings that I have mentioned above. Even registry edit fails to enable them with crimson. I had to 'downgrade'(/sarcasm) to old CCC with new drivers.
 

fullinfusion

Vanguard Beta Tester
Joined
Jan 11, 2008
Messages
9,860 (2.29/day)
Personally I had zero issues installing this driver. It took less then a minute to install... I love how crisp and vibrant the colours are in videos and such. I played a few games and they ran smooth as budder ;)

Games that always had a slight hicup at always the same place are now gone.. And tbh I say this is the best driver ever released from AMD..

To those complained about fiddling with all the color, de-noise and other settings, I'd say its time to get a descent monitor hmm o_O

Anyways great review @W1zzard
 

qubit

Overclocked quantum bit
Joined
Dec 6, 2007
Messages
15,925 (3.67/day)
Location
Quantum Well UK
System Name Quantumville™
Processor Intel Core i7-2700K at stock (hits 5 gees+ easily)
Motherboard Asus P8Z68-V PRO/GEN3
Cooling Noctua NH-D14
Memory 16GB (4 x 4GB Corsair Vengeance DDR3 PC3-12800 C9 1600MHz)
Video Card(s) Zotac GTX 1080 AMP! Extreme Edition
Storage Samsung 850 Pro 256GB | WD Green 4TB
Display(s) BenQ XL2720Z | Asus VG278HE (both 27", 144Hz, 3D Vision 2, 1080p)
Case Cooler Master HAF 922
Audio Device(s) Creative Sound Blaster X-Fi Fatal1ty PCIe
Power Supply Corsair HX 850W v1
Software Windows 10 Pro 64-bit
Looks like AMD are getting serious about properly supporting their graphics cards with decent drivers, which is great. Let's hope they can keep up this momentum.

I'm glad to see that the control panel starts up much more quickly. Both AMD's and NVIDIA's previous versions based on .NET always took ages to start, which is annoying. Over to you for an improved control panel, NVIDIA.
 
Joined
Oct 31, 2014
Messages
8 (0.00/day)
Location
India
System Name Anya
Processor Intel Core i5-4440
Motherboard GIGABYTE G1.Sniper B5
Cooling Antec C20 CPU Cooler
Memory Kingston HyperX FURY 4x4GB 1600MHz
Video Card(s) Sapphire Dual-X Radeon R7 265
Storage Seagate SV35.6 Series 1TB 7200 RPM 3.5"
Display(s) Dell S2240M 21.5" IPS LED Backlit
Case Antec X1 Gaming Cabinet
Audio Device(s) Onboard Realtek ALC898 HD audio
Power Supply Seasonic ECO-430 (SSR-430ST)
Mouse HP X500 Wired USB Mouse
Keyboard Dell KB213 Wired USB Keyboard
Software Microsoft Windows 10 Pro
To those complained about fiddling with all the color, de-noise and other settings, I'd say its time to get a descent monitor
Well that's me sir! I am complaining all right! Sitting on a Dell S2240M 21.5" IPS LED Backlit monitor with calibrated icc colour profile and still complaining! Must be very rude of me to criticise a driver that loads fast after boot, looks shiny and doesn't have 50% of the features that it previously had!
The problem doesn't go away with "descent" monitor. Everyone buys these GPUs spread over a huge price range for particular purpose that suits the buyer best. I for one, besides moderate gaming, like to watch my videos/movies with full dynamic range, dynamic contrast on, Edge enhancement at 0-5, Deblock/Denoise/Deinterlace/MNR depending on video, Colour vibrance 0, Brighter whites off, Video Gamma (not desktop gamma) at 1.05-1.1, Flesh tone correction 0-10. It is subjective, but that's the way I like it and I see no reason as to why these perfectly working settings which can work wonders for HTPC and had been there for some 8+ years shouldn't be there when I need it!
 
Last edited:
Joined
Nov 25, 2015
Messages
11 (0.01/day)
System Name Custom Built
Processor AMD FX-8350
Motherboard ASUS CROSSHAIR V FORMULA-Z
Cooling CORSAIR H110 280mm
Memory G.Skill F3-2400C10-8GTX 8GB DIMM DDR3 PC3-19200U X 4
Video Card(s) GIGABYTE Radeon R9 380 GV-R938G1 GAMING-4GD X 2 CrossfireX
Storage 2 X Mushkin Chronos 60GB SSD, RAID0; 2 X Mushkin Chronos 240GB SSD, RAID0
Display(s) 2 X Acer XG270HU 27"
Case NZXT CA-PH410-B1 RT
Audio Device(s) ASUS Xonar Essence STX
Power Supply EVGA 220-PS-1000-V1 80 PLUS Platinum 1000 W
Mouse Logitech G9x
Keyboard Logitech G510s; Logitech G13
Software Windows 10 Pro 64
Benchmark Scores 3DMark Fire Strike Extreme: 6607 (with FreeSync enabled)
To those complained about fiddling with all the color, de-noise and other settings, I'd say its time to get a descent monitor hmm o_O
Ya, I have two of these—some of the nicest gaming monitors on the market. Try again... ;)

The drivers take a half an hour to install and uninstall, and they completely screwed up a game that was running perfectly until I tried the new drivers. I've now wasted two days trying to get my system back to where it was before I tried these piece of **** drivers. It's almost bad enough to make me reinstall Windows—something I never do except as an absolute last resort...
 
Joined
Oct 15, 2010
Messages
163 (0.05/day)
I cant connect my main PC monitor (Samsung Freesync 32 inch 4k IPS) at the same time with my 4k Monitor.
In the old drivers, it appear and all i had to do was click on the tv and hit extend desktop.

The only way to connect my tv is to unplug my Display port from my monitor.
Anyone knows whats wrong ?

TV is on HDMI, and Pc Monitor on display port
 

fullinfusion

Vanguard Beta Tester
Joined
Jan 11, 2008
Messages
9,860 (2.29/day)
Ya, I have two of these—some of the nicest gaming monitors on the market. Try again... ;)

The drivers take a half an hour to install and uninstall, and they completely screwed up a game that was running perfectly until I tried the new drivers. I've now wasted two days trying to get my system back to where it was before I tried these piece of **** drivers. It's almost bad enough to make me reinstall Windows—something I never do except as an absolute last resort...
I could shoot a video and link you to how short of a time it actually takes to install and un-install if you like?

Have you tried the latest version of DDU uninstaller?

Its for the crimson driver. V15.7.0.1 http://www.guru3d.com/files-details/display-driver-uninstaller-download.html

@Llewen I wasn't really pointing fingers :p but yeah nice monitors for sure..

What are you using for a video program? I'm on W10 and use either windows media player or vlc player.. The movie and video program on W10 blows for picture quality IMO so yeah I use either the other two.. Vlc has quality options if that helps?
 
Last edited:
Joined
Nov 25, 2015
Messages
11 (0.01/day)
System Name Custom Built
Processor AMD FX-8350
Motherboard ASUS CROSSHAIR V FORMULA-Z
Cooling CORSAIR H110 280mm
Memory G.Skill F3-2400C10-8GTX 8GB DIMM DDR3 PC3-19200U X 4
Video Card(s) GIGABYTE Radeon R9 380 GV-R938G1 GAMING-4GD X 2 CrossfireX
Storage 2 X Mushkin Chronos 60GB SSD, RAID0; 2 X Mushkin Chronos 240GB SSD, RAID0
Display(s) 2 X Acer XG270HU 27"
Case NZXT CA-PH410-B1 RT
Audio Device(s) ASUS Xonar Essence STX
Power Supply EVGA 220-PS-1000-V1 80 PLUS Platinum 1000 W
Mouse Logitech G9x
Keyboard Logitech G510s; Logitech G13
Software Windows 10 Pro 64
Benchmark Scores 3DMark Fire Strike Extreme: 6607 (with FreeSync enabled)
I wasn't complaining so much about the video options, is the lack of hotkeys for colour profiles that really was annoying me. I'm a gamer and I use different colour profiles for different kinds of games, depending on whether they are 3D or 2D, and then I have my default desktop colour profile, and switching between those has become a pain with the new Crimson UI. But I solved my problem with my game no longer starting up. Turns out there was a corrupt file or two on my system, something that probably happened during one of the many times I killed the driver install because I thought it was hanging when it was taking so long.

I'm back to 15.7.1 and I won't try Crimson again until the next major release. Hopefully by then most of the major issues will be resolved and it will be more polished and have a fuller feature set. I like the basics of what they have done, and I do want to use the shader cache, but I couldn't finagle the shader cache with the old CCC UI—although maybe now that I've fixed the corrupted files that will work... NO... I'm not going through this again until there's another update... No matter how much my OCD pokes me...

NO! I'M NOT GOING TO DO IT! *bangs head*

edit: i Oh ya, I did use DDU eventually before I reinstalled the old drivers. But it wasn't until I ran some MS troubleshooting thingy that the corrupt files were found and fixed and my game worked again. It wasn't just sfc /scannow, and I had to look up my errors in the Win event logs and look up information on those before I finally got pointed in the right direction—still took less time than nuking Windows and starting over from scratch...

edit again: And I never doubted that for some people the install process was a breeze, I just wasn't one of those people, and apparently I'm not alone...
 
Last edited:

fullinfusion

Vanguard Beta Tester
Joined
Jan 11, 2008
Messages
9,860 (2.29/day)
I wasn't complaining so much about the video options, is the lack of hotkeys for colour profiles that really was annoying me. I'm a gamer and I use different colour profiles for different kinds of games, depending on whether they are 3D or 2D, and then I have my default desktop colour profile, and switching between those has become a pain with the new Crimson UI. But I solved my problem with my game no longer starting up. Turns out there was a corrupt file or two on my system, something that probably happened during one of the many times I killed the driver install because I thought it was hanging when it was taking so long.

I'm back to 15.7.1 and I won't try Crimson again until the next major release. Hopefully by then most of the major issues will be resolved and it will be more polished and have a fuller feature set. I like the basics of what they have done, and I do want to use the shader cache, but I couldn't finagle the shader cache with the old CCC UI—although maybe now that I've fixed the corrupted files that will work... NO... I'm not going through this again until there's another update... No matter how much my OCD pokes me...

NO! I'M NOT GOING TO DO IT! *bangs head*

edit: i Oh ya, I did use DDU eventually before I reinstalled the old drivers. But it wasn't until I ran some MS troubleshooting thingy that the corrupt files were found and fixed and my game worked again. It wasn't just sfc /scannow, and I had to look up my errors in the Win event logs and look up information on those before I finally got pointed in the right direction—still took less time than nuking Windows and starting over from scratch...

edit again: And I never doubted that for some people the install process was a breeze, I just wasn't one of those people, and apparently I'm not alone...
Yeah I totally agree and understand your frustration for sure.
I do have a recently new W10 install and could be why I had no issues.

How about filling in your system specs so I don't need to ask what your running

I think like you said it could be the time for a new OS install.
 
Joined
Nov 25, 2015
Messages
11 (0.01/day)
System Name Custom Built
Processor AMD FX-8350
Motherboard ASUS CROSSHAIR V FORMULA-Z
Cooling CORSAIR H110 280mm
Memory G.Skill F3-2400C10-8GTX 8GB DIMM DDR3 PC3-19200U X 4
Video Card(s) GIGABYTE Radeon R9 380 GV-R938G1 GAMING-4GD X 2 CrossfireX
Storage 2 X Mushkin Chronos 60GB SSD, RAID0; 2 X Mushkin Chronos 240GB SSD, RAID0
Display(s) 2 X Acer XG270HU 27"
Case NZXT CA-PH410-B1 RT
Audio Device(s) ASUS Xonar Essence STX
Power Supply EVGA 220-PS-1000-V1 80 PLUS Platinum 1000 W
Mouse Logitech G9x
Keyboard Logitech G510s; Logitech G13
Software Windows 10 Pro 64
Benchmark Scores 3DMark Fire Strike Extreme: 6607 (with FreeSync enabled)
I had mostly filled out my system specs. I've added the rest. And no, it is never time for "a new OS install". That's for people who don't know how to maintain and troubleshoot their computers. I've got it working now.... ;)

Not only is formatting and reinstalling generally a huge waste of time, it's also a great way to take years off the life span of my ssd's. Generally the only time I reinstall my OS is when I am either replacing hdd's/ssd's, or installing a new OS. And typically my computer runs very well...
 

Tatty_One

Senior Moder@tor
Staff member
Joined
Jan 18, 2006
Messages
21,780 (4.33/day)
Location
Worcestershire, UK
System Name The Grey
Processor Skylake i7 6700k @ 4.6gig - 1.35V
Motherboard MSI Z170A Tomahawk
Cooling Cooler Master Seidon 240V AIO/Viper140's
Memory 16GB Corsair Vengeance LPX3000 @ 3200mhz CL15 1T
Video Card(s) Palit 8GB GTX 1070 GameRock OC Edition
Storage SkHynix SL308 120GB/CrucialM4 64GB/1TB WD Black
Display(s) LG 29inch 2560x1080 Curved Ultrawide IPS
Case Phanteks Enthoo Pro M Windowed - Gunmetal
Audio Device(s) SB Xifi Elite Pro 7.1through VideoLogic ZXR550's
Power Supply XFX Pro Black Edition 750W Gold modular
Mouse Coolermaster Storm Octane wired
Keyboard Element Gaming Carbon Mk2 Tournament Mech
Software Win 10 Home x64
I had mostly filled out my system specs. I've added the rest. And no, it is never time for "a new OS install". That's for people who don't know how to maintain and troubleshoot their computers. I've got it working now.... ;)

Not only is formatting and reinstalling generally a huge waste of time, it's also a great way to take years off the life span of my ssd's. Generally the only time I reinstall my OS is when I am either replacing hdd's/ssd's, or installing a new OS. And typically my computer runs very well...
In that case you need to show them.......................

Specs.jpg
 
Joined
Nov 25, 2015
Messages
11 (0.01/day)
System Name Custom Built
Processor AMD FX-8350
Motherboard ASUS CROSSHAIR V FORMULA-Z
Cooling CORSAIR H110 280mm
Memory G.Skill F3-2400C10-8GTX 8GB DIMM DDR3 PC3-19200U X 4
Video Card(s) GIGABYTE Radeon R9 380 GV-R938G1 GAMING-4GD X 2 CrossfireX
Storage 2 X Mushkin Chronos 60GB SSD, RAID0; 2 X Mushkin Chronos 240GB SSD, RAID0
Display(s) 2 X Acer XG270HU 27"
Case NZXT CA-PH410-B1 RT
Audio Device(s) ASUS Xonar Essence STX
Power Supply EVGA 220-PS-1000-V1 80 PLUS Platinum 1000 W
Mouse Logitech G9x
Keyboard Logitech G510s; Logitech G13
Software Windows 10 Pro 64
Benchmark Scores 3DMark Fire Strike Extreme: 6607 (with FreeSync enabled)
In that case you need to show them.......................
Oops... Thank you... :)

What are you using for a video program?
I use VLC. The Win 10 native apps suck balls. I've gone to a great deal of trouble to uninstall as many of the default Win 10 apps as possible, as far as is possible.

I had been looking forward to the XBox app, because I was under the mistaken impression that I'd actually be able to order and play some of the good XBox games on Win 10. It turns out that the only XBox "apps" you can play on a PC are garbage casual games designed for phones and tablets, and also designed to suck as many micro payments out of you as possible, so the XBox app got nuked as much as I was able to as well.

All the hype about Win 10 being "THE BEST Winblows EVAR!" was just that—worthless hype. It runs as well as Windows 8 does. It has Windows 7 GUI elements slapped on to keep the old timers happy, and it comes with a ton of worthless garbage...
 
Last edited by a moderator:
Joined
Apr 30, 2012
Messages
3,410 (1.25/day)
Well that's me sir! I am complaining all right! Sitting on a Dell S2240M 21.5" IPS LED Backlit monitor with calibrated icc colour profile and still complaining! Must be very rude of me to criticise a driver that loads fast after boot, looks shiny and doesn't have 50% of the features that it previously had!
The problem doesn't go away with "descent" monitor. Everyone buys these GPUs spread over a huge price range for particular purpose that suits the buyer best. I for one, besides moderate gaming, like to watch my videos/movies with full dynamic range, dynamic contrast on, Edge enhancement at 0-5, Deblock/Denoise/Deinterlace/MNR depending on video, Colour vibrance 0, Brighter whites off, Video Gamma (not desktop gamma) at 1.05-1.1, Flesh tone correction 0-10. It is subjective, but that's the way I like it and I see no reason as to why these perfectly working settings which can work wonders for HTPC and had been there for some 8+ years shouldn't be there when I need it!
If your altering the source that much your problem isn't the driver. Its the source and output method especially if you already Color Calibrated the screen. I know some of the video adjustment settings aren't carried over to Radeon Settings UI. Having to correct or adjust video settings after CC probably means your player is iffy or the source is screwed.
 
Last edited:
Joined
Oct 31, 2014
Messages
8 (0.00/day)
Location
India
System Name Anya
Processor Intel Core i5-4440
Motherboard GIGABYTE G1.Sniper B5
Cooling Antec C20 CPU Cooler
Memory Kingston HyperX FURY 4x4GB 1600MHz
Video Card(s) Sapphire Dual-X Radeon R7 265
Storage Seagate SV35.6 Series 1TB 7200 RPM 3.5"
Display(s) Dell S2240M 21.5" IPS LED Backlit
Case Antec X1 Gaming Cabinet
Audio Device(s) Onboard Realtek ALC898 HD audio
Power Supply Seasonic ECO-430 (SSR-430ST)
Mouse HP X500 Wired USB Mouse
Keyboard Dell KB213 Wired USB Keyboard
Software Microsoft Windows 10 Pro
If your altering the source that much your problem isn't the driver. Its the source and output method especially if you already Color Calibrated the screen. I know some of the video adjustment settings aren't carried over to Radeon Settings UI. Having to correct or adjust video settings after CC probably means your player is iffy or the source is screwed.
As I said it's subjective. Not all videos are recorded same. My video player is perfectly fine, it's WMP or MPC-HC (which is by the way H/W acceleration enabled). If blu-rays are screwed up sources then what am I supposed to view? Granted with blu-rays I need ONLY dynamic contrast on and Edge Enhancement, nothing else. Thanks to 'crimson' there's absolutely no way to do that now. Those settings were there for a reason and it was a great perfection on AMD's part. Now like everything else it's time to dumb down the driver functionalities and it's been dealt with.
 
Joined
Nov 27, 2015
Messages
1 (0.00/day)
Location
Patra,Greece
System Name Mastro PC
Processor i5-4670k
Motherboard Asus maximus vi Hero
Cooling Corsair H100i
Memory 16gb corsair vengeance 1600mhz
Video Card(s) PowerColor 390x Devil
Storage Kingston ssd (0S) / Mushkin Chronos ssd (Games)
Display(s) Asus MX279 IPS
Case CM Storm Trooper
Audio Device(s) Sound Blaster Z
Power Supply Corsair TX 850m
Mouse Razer Naga
Keyboard Razer Anansi
Software Windows 10x64
Never had an amd card in my life.my first card was a 3dfx voodoo back in the 90s and after that nvidia till my late 780 gtx.that been said i bought a 390x devil recently.i used both 15.7.1 and 15.11.1 beta without issues other than getting tones of errors on occt even without overclock.( didnt know it was driver related at that time). Now about crimson.i installed without problems ( i used ddu to remove older drivers first).i noticed improvements on my games at 1440p (dsr) especially at dragon age .also i was able to achieve higher oc without adding to my voltage a lot more and at the same time occt gives me zero errors even after running it several minutes.i did came up with an issue at dying light though.major shutering without vsync at 1440p .with v sync enabled it was capping at 30 fps.didnt have either of these problems before i update.i did manage to solve this though with randeon pro utility using dynamic vsync .to conclude my rather big post i am happy with team red so far and with the crimson software.

Also got a 10% improvement on my furmark fps and a bit higher score at valley
 
Last edited:
Joined
Oct 15, 2010
Messages
163 (0.05/day)
I cant connect my main PC monitor (Samsung Freesync 32 inch 4k IPS) at the same time with my 4k Monitor.
In the old drivers, it appear and all i had to do was click on the tv and hit extend desktop.

The only way to connect my tv is to unplug my Display port from my monitor.
Anyone knows whats wrong ?

TV is on HDMI, and Pc Monitor on display port
Has anyone managed to EXTEND Desktop on a HDMI TV, without creating Infinity Setup (which doesnt extend on second Monitor, but unifies them, and at most clones the main Screen, what i Need is a Desktop extension)

As it seems, i cannot find this Option anywhere. Perhaps i missed something.
The two Monitors Show up when an infinity Setup is created.

Otherwise only the PC Monitor, and if this gets disconnected, then the HDMI one Shows.
 
Joined
Nov 4, 2005
Messages
10,407 (2.04/day)
System Name MoFo 2
Processor AMD PhenomII 1100T @ 4.2Ghz
Motherboard Asus Crosshair IV
Cooling Swiftec 655 pump, Apogee GT,, MCR360mm Rad, 1/2 loop.
Memory 8GB DDR3-2133 @ 1900 8.9.9.24 1T
Video Card(s) HD7970 1250/1750
Storage Agility 3 SSD 6TB RAID 0 on RAID Card
Display(s) 46" 1080P Toshiba LCD
Case Rosewill R6A34-BK modded (thanks to MKmods)
Audio Device(s) ATI HDMI
Power Supply 750W PC Power & Cooling modded (thanks to MKmods)
Software A lot.
Benchmark Scores Its fast. Enough.
This also breaks 4K youtube videos, CPU only, even after re running LAV setup and making sure DXVA is enabled. This is the first time I have considered running two hardware configs, one with Crimson for gaming, and one with the old software for video......


Ohh AMD, how is it that you can be so great at breaking shit when fixing things?
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,412 (4.04/day)
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.75Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-1T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k), 2x Dell S2340M (1080p)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898 8-Channel High Definition Audio
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100
Software Ubuntu 18.04 (5.3.0 Mainline Kernel)
Benchmark Scores Benchmarks aren't everything.
This also breaks 4K youtube videos, CPU only, even after re running LAV setup and making sure DXVA is enabled. This is the first time I have considered running two hardware configs, one with Crimson for gaming, and one with the old software for video......


Ohh AMD, how is it that you can be so great at breaking shit when fixing things?
In Chrome, I would go here to see if anything looks amiss: chrome://gpu/

Mine looks okay but, it will eat up 15% CPU to play 4k on YouTube however, my GPU is most definitely not idle during playback. Memory clocks stay up, GPU clocks come just over 300Mhz (idle,) and GPU load goes up to ~5-25% percent. It's uncertain to me if the CPU load is just rendering or something else going on. I'm curious about this as well. I've had enough issues where I may consider reverting to older drivers.
 
Joined
Nov 4, 2005
Messages
10,407 (2.04/day)
System Name MoFo 2
Processor AMD PhenomII 1100T @ 4.2Ghz
Motherboard Asus Crosshair IV
Cooling Swiftec 655 pump, Apogee GT,, MCR360mm Rad, 1/2 loop.
Memory 8GB DDR3-2133 @ 1900 8.9.9.24 1T
Video Card(s) HD7970 1250/1750
Storage Agility 3 SSD 6TB RAID 0 on RAID Card
Display(s) 46" 1080P Toshiba LCD
Case Rosewill R6A34-BK modded (thanks to MKmods)
Audio Device(s) ATI HDMI
Power Supply 750W PC Power & Cooling modded (thanks to MKmods)
Software A lot.
Benchmark Scores Its fast. Enough.
In Chrome, I would go here to see if anything looks amiss: chrome://gpu/

Mine looks okay but, it will eat up 15% CPU to play 4k on YouTube however, my GPU is most definitely not idle during playback. Memory clocks stay up, GPU clocks come just over 300Mhz (idle,) and GPU load goes up to ~5-25% percent. It's uncertain to me if the CPU load is just rendering or something else going on. I'm curious about this as well. I've had enough issues where I may consider reverting to older drivers.

Firefox is definitely broken for me, and it was not before. CPU utilization is 100% on one core trying to render the content, and GPU is idle. I may have to install Chrome to see if it works.

Chrome works with Crimson, full hardware acceleration, had to force raster acceleration, also enables MSAA for the raster pipeline in hardware.... so old pages can be given a less jaggie look?
 
Last edited:
Joined
May 22, 2010
Messages
95 (0.03/day)
System Name "The scratcher"
Processor i5-3570K
Motherboard MSI Z77MA-G45
Cooling watercooled custom loop
Memory kingston hyperx black 2x8GB
Video Card(s) GB GTX1070 G1 gaming
Storage several
Display(s) Dell 2708WFP
Case CM Cosmos RC1000
Power Supply CM UCP 750W
Software Win 10 Pro x64
i'm going back to the old drivers.... these crimsons are shit:

  1. no shader cache on my 5870, that means lazy programmers as that feature is NOT GPU dependant because shaders are CPU compiled...
  2. the FAN stays at 100% at random(the fan checkbox in overdrive turns on by itself), spcially when i suspend and come out of suspend
  3. my FPS took a nosedive in armored warfare, before i could do 50+fps, now i get 30fps at most
 
Top