• We've upgraded our forums. Please post any issues/requests in this thread.

AMD Releases the Catalyst 13.12 WHQL Graphics Drivers

Joined
Dec 6, 2011
Messages
4,785 (2.17/day)
Likes
1,187
Location
Still on the East Side
#1
After months of Catalyst 13.11 betas AMD has now made available a new WHQL-certified graphics driver, the Catalyst 13.12. This release features support for the Radeon HD 5000, HD 6000, HD 7000, Radeon R7 and R9 Series cards and is available for Windows Vista, 7, 8 and 8.1.

Download: Catalyst 13.12 WHQL 32-bit / Catalyst 13.12 WHQL 64-bit

Show full news post
 
Joined
May 21, 2008
Messages
4,090 (1.17/day)
Likes
766
Location
Iowa, USA
System Name FUTURE CUBE!
Processor intel Core i5 6600k
Motherboard Gigabyte Z170X-Gaming 7
Cooling Phanteks PH-TC14PE BK
Memory G.Skill TridentZ 3000 Mhz C15 32GB 2x16GB
Video Card(s) Gigabyte Aorus 1080 Ti
Storage 2x M.2 Samsung Evo 250GB/500GB / WD Blue 500GB / 2x RAID1 Toshiba P300 3TB
Display(s) Samsung C24FG70 1080p 144hz Quantum Dot/ASUS VH226H 1080p 21.5"
Case "THE CUBE" Custom built, pure Red Alder wood
Audio Device(s) Creative Sound Core3D/ Logitech Z-2300 200 watts/ Beyerdynamic DT 880
Power Supply Seasonic X Gold 650W
Mouse Logitech G700
Keyboard Logitech G910
Software Windows 10 Pro
#2
Downloading now.
 
Joined
Jan 17, 2006
Messages
467 (0.11/day)
Likes
122
System Name Elysium
Processor i7-4790k @ 4800MHz (re-lidded)
Motherboard Asus Z97-WS
Cooling Custom 3 radiator loop for CPU and GPUs, D5 pump
Memory 32GB (4 x 8GB) GSkill @ 2400MHz
Video Card(s) 2 x R9 290x with full cover blocks
Storage Plextor P6E M.2 (OS/work). Samsung 950 Pro 512GB on NVMe card (Games etc.)
Display(s) BenQ BL3200
Case Xigmatek Elysium
Audio Device(s) On board, SBZ + HDMI to sound processor
Power Supply Corsair AX1500i
Mouse Mad Catz MOUS 9
Keyboard K95 RGB
Software Windows 10 Pro x64
Benchmark Scores #1 worldwide on 3D Mark 99 or 2000 or one of those, at one point back in the day. :)
#3
Hmmm, it doesn't seem to let me uncheck gaming evolved. Says it's already installed and up to date, but it isn't installed ...

Just installed and GE does not seem to be there, so maybe it unchecked but didn't display - weird stuff.
 
Joined
Oct 1, 2010
Messages
2,193 (0.83/day)
Likes
633
Location
Marlow, ENGLAND
System Name Chachamaru-III | Retro Battlestation
Processor Intel Core i7 3770K | Intel Pentium II 450MHz
Motherboard BIOSTAR TZ77XE4 (Intel Z77 Chipset) | MSI MS-6116 (Intel 440BX chipset)
Cooling Thermaltake CLW0217 Water 2.0 Extreme, case fully populated
Memory 16GB G.Skill Ares 1600MHz (2x8GB) [30 10-10-10] | 512MB PC133 SDRAM
Video Card(s) MSI GeForce 1070 Gaming Z, Intel HD 4000 (for secondary monitors) | MSI nVIDIA Vanta 16MB
Storage 250GB SK hynix SSD (OS), Seagate 3TB (Storage), Toshiba 3TB (Steam), Samsung 1TB (Personal Files)
Display(s) Samsung 2443BWT-1 24" @1920x1200, Dell 1708fp 17" @1280x1024 & Eizo FlexScan L887 20" @1600x1200
Case Coolermaster HAF 922 | Beige box
Audio Device(s) Creative Sound Blaster Z (Speakers), Sound Blaster Audigy 2 (Headphones) | Yamaha Audician 32 Plus
Power Supply EVGA Supernova 750 G2 | 250W ASETEC
Mouse Microsoft Wireless Laser Mouse 6000 v2.0 | Microsoft Serial Mouse v2.0A
Keyboard UNICOMP Classic | Dell AT102W
Software Microsoft Windows 7 Ultimate 64-bit | Microsoft Windows 98SE
#4
AMD hasn't supported Vista for months now. You need to remove Vista from your list of supported OSes.
 
Joined
Nov 2, 2007
Messages
135 (0.04/day)
Likes
31
System Name blackened 24/7
Processor Intel Core i7-2600K @ 4.4GHz
Motherboard Asus MAXIMUS IV GENE-Z/GEN3
Cooling Corsair H60
Memory 4 x 4Gb Corsair Vengance ddr3 1866Mhz
Video Card(s) Asus Strix 1050ti 4gb
Storage Corsair Force 3 SSD 120gb+4TB WD HD
Display(s) Acer S271HL 27" HD LED 1920x1080
Case Corsair Obsidian 650D
Audio Device(s) X-Fi 2 MB
Power Supply Corsair HX650w
Software Win10 Pro
#5
Finally new drivers (non BETA).. downloading..
 
Joined
Oct 12, 2008
Messages
5,655 (1.69/day)
Likes
2,606
Location
στο άλφα έως ωμέγα
System Name Ha/AhHa/Dell
Processor QX9650 SLAWN C1/i7-980x/i7-6700K
Motherboard GA-X48_DS4 (F3B bios)/Gigabyte x58A-UDR3 v 2.0(modded FH bios)/Dell Foxconn 0XJ8C4 Z170
Cooling CNPS9900 LED/H60/ 3 pipe-center fan-air
Memory 8 Gig of G.Skill F2-8800CL5D/24 Gb Corsair Vengence/ 24Gb Samsung DDR4 2133
Video Card(s) Galaxy NVIDIA GeForce GTX 960/PowerColor R9 280/ASUS R9 380X Strix G1
Storage All have SSDs with HDDs for extra storage and backup/Dell-M.2 Samsung 850 EVO PCIe
Display(s) Asus 266H/Viewsonic 1080p/HP ZR24W
Case CM-690/CM-690 II adv/Dell 8900 series
Audio Device(s) All use on board (Realtek) w/2.1 speakers
Power Supply PC P&C 750/PC P&C Silencer 950/CM 700 Extreme
Mouse Logitech
Keyboard Logitech
Software Windows 10 Pro - 64 bit/Windows 10 Pro - 64bit/Windows 10 Pro - 64bit
#6
AMD hasn't supported Vista for months now. You need to remove Vista from your list of supported OSes.
AMD does support Vista.
You have to look for them.

AMD Catalyst™ Display Driver 32 bit
Description:
Package contains the following graphics drivers and dependent/required software for the products specified in the current version's official release notes for the 32 bit version of Windows Vista:
Display Driver ver. 13.251
OpenCL(tm) Driver ver. 10.0.1348.5
Catalyst Control Center ver. 2013.1206.1602.28764

AMD Catalyst™ Display Driver 64 bit
Description:
Package contains the following graphics drivers and dependent/required software for the products specified in the current version's official release notes for the 32 bit version of Windows Vista:
Display Driver ver. 13.251
OpenCL(tm) Driver ver. 10.0.1348.5
Catalyst Control Center ver. 2013.1206.1602.28764
 

fullinfusion

Vanguard Beta Tester
Joined
Jan 11, 2008
Messages
9,605 (2.65/day)
Likes
3,363
Processor I7-7700K
Motherboard Asus Z270 Maximus IX Code
Cooling Custom water plus another cooler
Memory Corsair Vengeance LED Red 4x8GB 32GB 3200MHz kit
Video Card(s) 2 x MSI RX Vega 56 and a single MSI RX Vega 64 in test rig
Storage 960 EVO/960 Pro M.2 nvme 250/1TB, Samsumg 850 evo 256/ WD 1TB blue
Display(s) Nexius 32" freesync 2 HDR
Case Corsair Obsidion 650D/ cardboard box
Audio Device(s) Onboard
Power Supply EVGA Supernova G2 1300W
Mouse Mionix Naos 7000
Keyboard G15
Software Windows 10 Home
#7
About efn time!! Cant wait to get home and test this driver
 

Solaris17

Creator Solaris Utility DVD
Joined
Aug 16, 2005
Messages
19,267 (4.28/day)
Likes
6,073
Location
Florida
System Name Not named yet
Processor I5 7640x 5Ghz 24/7
Motherboard MSI x299 Tomahawk Arctic
Cooling Corsair H55
Memory 32GB Corsair DDR4 3000mhz
Video Card(s) Gigabyte 1080TI
Storage 2x Seagate 3TB Drives (RAID 0) 1x Seagate 256GB SSD 1x Adata 120GB SSD
Display(s) 3x AOC Q2577PWQ
Case Inwin 303 White (Thermaltake Ring 120mm Purple accent)
Audio Device(s) Onboard on Audio-Technica ATH-AG1
Power Supply Seasonic 1050W Snow
Mouse Roccat Tyon White
Keyboard Ducky Shine 6
Software Windows 10 x64 Pro
#8
oh sweet jesus
 

Solaris17

Creator Solaris Utility DVD
Joined
Aug 16, 2005
Messages
19,267 (4.28/day)
Likes
6,073
Location
Florida
System Name Not named yet
Processor I5 7640x 5Ghz 24/7
Motherboard MSI x299 Tomahawk Arctic
Cooling Corsair H55
Memory 32GB Corsair DDR4 3000mhz
Video Card(s) Gigabyte 1080TI
Storage 2x Seagate 3TB Drives (RAID 0) 1x Seagate 256GB SSD 1x Adata 120GB SSD
Display(s) 3x AOC Q2577PWQ
Case Inwin 303 White (Thermaltake Ring 120mm Purple accent)
Audio Device(s) Onboard on Audio-Technica ATH-AG1
Power Supply Seasonic 1050W Snow
Mouse Roccat Tyon White
Keyboard Ducky Shine 6
Software Windows 10 x64 Pro
#10
The system info and GPU-z seem to still say 13.11 You might need to clean install them just a heads up. Im going to do that now.
 
Joined
Oct 29, 2013
Messages
69 (0.05/day)
Likes
4
Location
Switzerland
System Name Double Overseer
Processor i7 3820 / FX-8350
Motherboard Asus P9X79 / MSI 990FXA-GD65
Cooling Air
Memory Kingston 16 GB RAM 1600 / Corsair 8 GB RAM 1866 (2000)
Video Card(s) PCS+ 7950 Crossfire / Club3d 7950 13 Series / Hauppauge 5500
Storage 240 Kingston HyperX 3K / Crucial MX100 256 GB / 1+3 TB Seagate
Display(s) S240HL Acer / S242HL Acer x2
Case 2x Thermaltake Overseer
Audio Device(s) Onkyo TX-SR309 / 5.1 Canton
Power Supply Fractal Design Newton R3 800 / Seasonic SS-660KM Active
Mouse 5 Euro one
Keyboard Logitech K120
Software Windows 7 64-Bit / Windows 10 64-Bit
Benchmark Scores Firestrike 10400 3DMark11 13400 / triple crossfire Firestrike 12500 3DMark11 15600
#11
Are you serious AMD? I bought Windows 8, because I thought you do not support Vista anymore. Well, Windows 8 isn't that bad.
 
Joined
Apr 30, 2008
Messages
4,315 (1.23/day)
Likes
1,015
Location
Multidimensional
System Name Derp!
Processor i7 7700 @ 4.2Ghz Turbo On
Motherboard Gigabyte B250 Phoenix Wifi ITX Motherboard
Cooling Noctua NH-L9i LP Cooler || Cooler Master Fan Pro RGB 120mm x 2
Memory 16GB Corsair Vengeance LPX DDR4 2400mhz RAM
Video Card(s) AMD Reference RX 480 8GB
Storage 250GB SS 960 Evo M.2 || WD Blue 500GB SSD || 2TB SG FC SSHD
Display(s) Hisense 1080p Smart LED HDTV 40inch
Case Fractal Node 202 Mini ITX Case
Audio Device(s) Realtek HD Audio / HDMI Audio Via GPU
Power Supply Corsair SFX 600W PSU
Mouse CoolerMaster Masterkeys Lite L RGB Mouse
Keyboard CoolerMaster Masterkeys Lite L RGB Mem-Chanical Keyboard
Software Windows 10 Home 64bit
Benchmark Scores Later
#12
Awesome! About time AMD :rolleyes:
 

Solaris17

Creator Solaris Utility DVD
Joined
Aug 16, 2005
Messages
19,267 (4.28/day)
Likes
6,073
Location
Florida
System Name Not named yet
Processor I5 7640x 5Ghz 24/7
Motherboard MSI x299 Tomahawk Arctic
Cooling Corsair H55
Memory 32GB Corsair DDR4 3000mhz
Video Card(s) Gigabyte 1080TI
Storage 2x Seagate 3TB Drives (RAID 0) 1x Seagate 256GB SSD 1x Adata 120GB SSD
Display(s) 3x AOC Q2577PWQ
Case Inwin 303 White (Thermaltake Ring 120mm Purple accent)
Audio Device(s) Onboard on Audio-Technica ATH-AG1
Power Supply Seasonic 1050W Snow
Mouse Roccat Tyon White
Keyboard Ducky Shine 6
Software Windows 10 x64 Pro
#13
Did any of you get odd readings in GPU-Z? After a clean install I dont get a 13.12 i am assuming w1zz just needs to update it. But in the CCC I dont get 13.12 either I get a random reg string
 
Joined
Dec 9, 2013
Messages
7 (0.00/day)
Likes
0
#14
I do not know there is no solution or fix 7790 black and restart the game to run test programs and software crashes and display driver has been restored questions
Stable yet
 

Solaris17

Creator Solaris Utility DVD
Joined
Aug 16, 2005
Messages
19,267 (4.28/day)
Likes
6,073
Location
Florida
System Name Not named yet
Processor I5 7640x 5Ghz 24/7
Motherboard MSI x299 Tomahawk Arctic
Cooling Corsair H55
Memory 32GB Corsair DDR4 3000mhz
Video Card(s) Gigabyte 1080TI
Storage 2x Seagate 3TB Drives (RAID 0) 1x Seagate 256GB SSD 1x Adata 120GB SSD
Display(s) 3x AOC Q2577PWQ
Case Inwin 303 White (Thermaltake Ring 120mm Purple accent)
Audio Device(s) Onboard on Audio-Technica ATH-AG1
Power Supply Seasonic 1050W Snow
Mouse Roccat Tyon White
Keyboard Ducky Shine 6
Software Windows 10 x64 Pro
#16
Joined
Nov 12, 2012
Messages
58 (0.03/day)
Likes
22
Processor i5 4690k
Motherboard GA-Z97X-Gaming 7
Cooling NZXT Havik 140
Memory Corsair Vengeance LPX 16GB 1600MHz
Video Card(s) EVGA GTX 1080 SC ACX 3.0
Storage 128GB Toshiba Q, 500GB Samsung 850, 1TB Samsung 850 M.2, 500GB/2TB Seagate, 1TB WD Blue
Display(s) Acer XG270HU, Acer G257HU
Case NZXT H440
Power Supply SeaSonic M12II 620W
Mouse 2013 Razer Deathadder Black Edition
Keyboard Ducky One Transparent Blue Cherry MX Black
#18
It's also showing as 13.11 for me, but I did not do a fresh install.
 

Solaris17

Creator Solaris Utility DVD
Joined
Aug 16, 2005
Messages
19,267 (4.28/day)
Likes
6,073
Location
Florida
System Name Not named yet
Processor I5 7640x 5Ghz 24/7
Motherboard MSI x299 Tomahawk Arctic
Cooling Corsair H55
Memory 32GB Corsair DDR4 3000mhz
Video Card(s) Gigabyte 1080TI
Storage 2x Seagate 3TB Drives (RAID 0) 1x Seagate 256GB SSD 1x Adata 120GB SSD
Display(s) 3x AOC Q2577PWQ
Case Inwin 303 White (Thermaltake Ring 120mm Purple accent)
Audio Device(s) Onboard on Audio-Technica ATH-AG1
Power Supply Seasonic 1050W Snow
Mouse Roccat Tyon White
Keyboard Ducky Shine 6
Software Windows 10 x64 Pro
#19
Ya I had to do a clean install

Reboot

still showed 13.11

went into dev mgr

right clicked display adapter

uninstalled (checked box to delete) driver

Scanned for new hardware changes

microsoft driver was installed

then ran cat 13.12 installer again.

got the above readout.

but its the same number as 13.11
 
Joined
Apr 15, 2009
Messages
473 (0.15/day)
Likes
266
Processor i5 4690K
Motherboard ASUS Z97-PRO Wi-Fi ac USB 3.1
Cooling Cryorig H5 Ultimate
Memory 16 GB Corsair XMS3 1600
Video Card(s) Sapphire R9 290X 8GB Tri-X OC
Storage Corsair Neutron GTX 240
Display(s) ASUS MG278Q
Case Corsair Carbide 600Q
Power Supply Seasonic Prime 750W Titanium
Software Windows 10 Pro 64
#20
Did those showing an older Catalyst version number do an uninstall of the old driver first?

I did a simple uninstall first and show the same driver version string as Solaris17.
 

Solaris17

Creator Solaris Utility DVD
Joined
Aug 16, 2005
Messages
19,267 (4.28/day)
Likes
6,073
Location
Florida
System Name Not named yet
Processor I5 7640x 5Ghz 24/7
Motherboard MSI x299 Tomahawk Arctic
Cooling Corsair H55
Memory 32GB Corsair DDR4 3000mhz
Video Card(s) Gigabyte 1080TI
Storage 2x Seagate 3TB Drives (RAID 0) 1x Seagate 256GB SSD 1x Adata 120GB SSD
Display(s) 3x AOC Q2577PWQ
Case Inwin 303 White (Thermaltake Ring 120mm Purple accent)
Audio Device(s) Onboard on Audio-Technica ATH-AG1
Power Supply Seasonic 1050W Snow
Mouse Roccat Tyon White
Keyboard Ducky Shine 6
Software Windows 10 x64 Pro
#22
nvidia did this iirc awhile ago were they ran a beta for awhile 333.1/.16/.22/.48 333.58 WHQL

but they were similar drivers. maybe they just didnt update the build number? Not sure I will continue to test tomorrow. I really do not want to go through alot of this for new drivers.

EDIT:: MSI afterburner doesnt even detect a driver.

EDIT 2:: The attached is my current attempt at an install driver is the same build version as the 13.11 betas

EDIT 3:: These drivers dont seem like they were set at 400º for 20min. I have a few reports

Here


Here

that indicate others are running into problems
 

Attachments

Last edited:
Joined
Sep 29, 2013
Messages
96 (0.06/day)
Likes
25
Processor Intel i7 4960x Ivy-Bridge E @ 4.6 Ghz @ 1.42V
Motherboard x79 AsRock Extreme 11.0
Cooling EK Supremacy Copper Waterblock
Memory 65.5 GBs Corsair Platinum Kit @ 666.7Mhz
Video Card(s) PCIe 3.0 x16 -- Asus GTX Titan Maxwell
Storage Samsung 840 500GBs + OCZ Vertex 4 500GBs 2x 1TB Samsung 850
Audio Device(s) Soundblaster ZXR
Power Supply Corsair 1000W
Mouse Razer Naga
Keyboard Corsair K95
Software Zbrush, 3Dmax, Maya, Softimage, Vue, Sony Vegas Pro, Acid, Soundforge, Adobe Aftereffects, Photoshop
#23
AMD 13.12 WHQL seems to be working perfectly fine for me. Not having issues. Just installed it like 2 hours ago. PCIe Bus is showing 16x 3.0 for all three R9-290x's.

The Gaming Evolve crap wasn't listed in the list of things being installed. I'm glad they took it out. All the previous Beta Drivers, I unchecked them.
 
Last edited:
Joined
Dec 16, 2010
Messages
1,484 (0.58/day)
Likes
544
System Name My Surround PC
Processor Intel Core i7 4770K @ 4.2 GHz (1.15 V)
Motherboard ASRock Z87 Extreme6
Cooling Swiftech MCP35X / XSPC Rasa CPU / Swiftech MCW82 / Koolance HX-1320 w/ 8 Scythe Fans
Memory 16GB (2 x 8 GB) Mushkin Blackline DDR3-2400 CL11-13-13-31
Video Card(s) MSI Nvidia GeForce GTX 980 Ti Armor 2X
Storage Samsung SSD 850 Pro 256GB, 2 x 4TB HGST NAS HDD in RAID 1
Display(s) 3 x Acer K272HUL 27" in Surround 7860x1440
Case NZXT Source 530
Audio Device(s) Integrated ALC1150 + Logitech Z-5500 5.1
Power Supply Seasonic X-1250 1.25kW
Mouse Gigabyte Aivia Krypton
Keyboard Logitech G15
Software Windows 8.1 Pro x64
#24
"Resolves graphics corruption issues found in Starcraft"

This is good. I thought my card was dying due to all the issues I was seeing in the game.

The Gaming Evolve crap wasn't listed in the list of things being installed. I'm glad they took it out. All the previous Beta Drivers, I have unchecked them.
Of course it's not in the WHQL drivers, because raptr is a program in beta. I would expect it to remain in the beta driver releases and to be integrated into the WHQL releases when its beta status is removed.
 
Joined
Sep 29, 2013
Messages
96 (0.06/day)
Likes
25
Processor Intel i7 4960x Ivy-Bridge E @ 4.6 Ghz @ 1.42V
Motherboard x79 AsRock Extreme 11.0
Cooling EK Supremacy Copper Waterblock
Memory 65.5 GBs Corsair Platinum Kit @ 666.7Mhz
Video Card(s) PCIe 3.0 x16 -- Asus GTX Titan Maxwell
Storage Samsung 840 500GBs + OCZ Vertex 4 500GBs 2x 1TB Samsung 850
Audio Device(s) Soundblaster ZXR
Power Supply Corsair 1000W
Mouse Razer Naga
Keyboard Corsair K95
Software Zbrush, 3Dmax, Maya, Softimage, Vue, Sony Vegas Pro, Acid, Soundforge, Adobe Aftereffects, Photoshop
#25
Are you serious AMD? I bought Windows 8, because I thought you do not support Vista anymore. Well, Windows 8 isn't that bad.

They've always had Support for Vista. AMD, and I think NVidia as well, have dropped support for Win XP. I bet eventually, when Win9 comes out--talks about it have been hitting the media, will probably be around the time when Support for Vista will be dropped. MS wants to get you buying their products again some how...